Connexion

Forum

Système et matériels » Installation et configuration Nextcloud Vs Locales nextcloud ne fonctionne plus suite à un problème de locales

HomeBoy38 Membre non connecté

Rang

Avatar

Inscrit le : 31/07/2017 à 18h53

Messages: 32

Le 28/09/2019 à 13h32

Reprise du message précédent

Sans suprise avec le 16.0.5 (la vérité est ailleurs)
   
HomeBoy38 Membre non connecté

Rang

Avatar

Inscrit le : 31/07/2017 à 18h53

Messages: 32

Le 07/10/2019 à 20h09
[root@machine ~]# urpme apache-mod_perl
To satisfy dependencies, the following 4 packages will be removed (3.6MB):
apache-mod_perl-2.0.10-6.mga7.x86_64
perl-SOAP-WSDL-3.3.0-4.mga7.noarch
(due to missing perl(APR::Table),
due to missing perl(Apache2::Const),
due to missing perl(Apache2::Log),
due to missing perl(Apache2::RequestIO),
due to missing perl(Apache2::RequestRec))
task-lamp-3-7.mga7.noarch
(due to missing task-lamp-perl)
task-lamp-perl-3-7.mga7.noarch
(due to missing apache-mod_perl)
Remove 4 packages? (y/N) y
removing apache-mod_perl-2.0.10-6.mga7.x86_64 perl-SOAP-WSDL-3.3.0-4.mga7.noarch task-lamp-3-7.mga7.noarch task-lamp-perl-3-7.mga7.noarch
removing package perl-SOAP-WSDL-3.3.0-4.mga7.noarch
1/4: removing perl-SOAP-WSDL-3.3.0-4.mga7.noarch
#############################################
removing package task-lamp-1:3-7.mga7.noarch
2/4: removing task-lamp-1:3-7.mga7.noarch
#############################################
removing package task-lamp-perl-1:3-7.mga7.noarch
3/4: removing task-lamp-perl-1:3-7.mga7.noarch
#############################################
removing package apache-mod_perl-1:2.0.10-6.mga7.x86_64
4/4: removing apache-mod_perl-1:2.0.10-6.mga7.x86_64
#############################################
[root@machine ~]# service httpd restart
Redirecting to /bin/systemctl restart httpd.service

=> le script de papoteur fonctionne à nouveau
=> nextcloud fonctionne à nouveau avec le fichier d'origine
=> je ne saurais dire ce qui a provoqué tous ces problèmes avec les packages ci-dessus
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 472

Le 08/10/2019 à 08h37
Bonjour,

Je ne sais pas si apache-mod_perl est installé chez moi (je pense que oui, je regarde ce soir).
Par contre, je ne peux pas désinstaller task-lamp. Je pense qui j'ai beaucoup trop de paquetages qui en dépendent.
Qu'est qui vous a poussé à désinstaller ce paquetage (apache-mod_perl) en particulier ? Une idée de génie ?

Xuo.
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6722

Le 08/10/2019 à 08h40
Bonjour,
Tu as dû changer autre chose. Chez moi, la suppression de apache-mod_perl n'a aucun effet sur mon script.



Yves
   
HomeBoy38 Membre non connecté

Rang

Avatar

Inscrit le : 31/07/2017 à 18h53

Messages: 32

Le 08/10/2019 à 18h05
Avant, j'ai réinstallé tous les packages qui avaient php dans leur nom et locales. Mais à chaque fois j'ai redémarré apache et retesté ton script, sans succès.
Dans ce processus, j'ai comparé les paquets installés sur mon serveur qui avait le souci avec la VM en 7 natif et la VM en 7 migré d'une 6.
En voulant désinstaller les locales pour les réinstaller, il m'a supprimé quelques paquets -fr que j'ai réinstallé derrière.

J'avais un autre souci avec les mises en jour par le GUI (le téléchargement s'arrêtait en prenant 100% d'un CPU), du coup, j'ai fait en ligne de commandes mais j'avais une erreur venant de perl, donc j'ai aussi listé mes paquets perl (mais il y en avait beaucoup trop pour tout réinstaller). Mes mises à jour semblent à nouveau fonctionner en GUI.

L'"idée de génie" n'était pas de regarder ce qu'il me manquait, mais de regarder ce que j'avais en trop : apache-mod_perl. Du coup, en le désinstallant, il a enlevé les autres mentionnés. Pour le coup, j'espère que je n'ai pas d'autres choses qui ne fonctionnent plus...


   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6722

Le 08/10/2019 à 20h54
Salut HomeBoy,
Alors Mea Culpa.
Je n'avais pas redémarré le serveur après la désinstallation.
Je viens de redémarrer, et oui, maintenant ça fonctionne !
Comme le dit Marc, quel lien peut-il y avoir entre Perl et les locales ?
Dans les autres mentionnés, il n'y a que perl-SOAP-WSDL qui soit fonctionnel, et apparemment personne ne le réclame. Moi je ne l'avais pas.


Yves
   
HomeBoy38 Membre non connecté

Rang

Avatar

Inscrit le : 31/07/2017 à 18h53

Messages: 32

Le 09/10/2019 à 20h22
Pas de soucis :)
Par contre, le lien, je ne saurais même pas par où commencer. Ca me semble encore plus complexe : apache, php, perl et locales ?

Xuo : as-tu pu vérifier que tu es dans le même cas que nous ? Si on est 3 dans le même cas, ce n'est plus une coïncidence.
J'essaye de relancer une personne qui semblait avoir le même souci sur Fedora
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 472

Le 10/10/2019 à 08h31
Bonjour,

Je regarde samedi.

Xuo.
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 472

Le 13/10/2019 à 16h33
Bonjour,

J"ai bien le paquetage apache-mod_perl-2.0.10-6.mga7 installé. Si je le supprime, j'ai plus ou moins les mêmes avertissements que HomeBoy38.

/etc/httpd 164 # urpme apache-mod_perl-2.0.10-6.mga7
Pour satisfaire les dépendances, les 3 paquetages suivants vont être désinstallés (3Mo):
apache-mod_perl-2.0.10-6.mga7.x86_64
task-lamp-3-7.mga7.noarch
(en raison du manque de task-lamp-perl)
task-lamp-perl-3-7.mga7.noarch
(en raison du manque de apache-mod_perl)
Supprimer 3 paquetages ? (o/N)

Là, j'ai fait 'non' pour ne pas désinstaller task-lamp.

Là où je ne comprends plus, c'est que si je désinstalle task-lamp, j'ai toujours le serveur apache qui marche ?
Je pensais que c'était un méta-package qui installait tout ce qu'il fallait pour avoir un serveur web qui tourne, dont le paquetage apache. Si plus de apache => plus de nextcloud ...

Xuo.

EDIT :
Les paquetages deviennent orphelins mais ne sont pas supprimés. Le serveur apache peut donc continuer à tourner (je pense).
Si je comprends bien, cela revient donc à installer :
apache-mod_dav-2.4.39-1.mga7.x86_64
apache-mod_php-7.3.8-1.mga7.x86_64
apache-mod_userdir-2.4.39-1.mga7.x86_64
bogofilter-1.2.4-8.mga7.x86_64
compface-1.5.2-17.mga7.x86_64
hunspell-1.7.0-1.mga7.x86_64
kernel-server-4.14.127-1.mga6-1-1.mga6.x86_64
kernel-server-5.1.14-1.mga7-1-1.mga7.x86_64
lib64c-client0-2007f-13.mga7.x86_64
lib64compface1-1.5.2-17.mga7.x86_64
lib64etpan20-1.9.3-1.mga7.x86_64
lib64gsl23-2.5-1.mga7.x86_64
lib64gslcblas0-2.5-1.mga7.x86_64
lib64mcrypt4-2.5.8-22.mga7.x86_64
lib64mjpegtools2.1_0-2.1.0-4.mga7.x86_64
lib64quicktime0-1.2.4-24.mga7.tainted.x86_64
lib64sasl2-plug-login-2.1.27-1.mga7.x86_64
lib64sasl2-plug-plain-2.1.27-1.mga7.x86_64
lib64zip5-1.5.2-1.mga7.x86_64
libmcrypt-2.5.8-22.mga7.x86_64
perl-BSD-Resource-1.291.100-4.mga7.x86_64
perl-Data-Flow-1.20.0-8.mga7.noarch
perl-Linux-Pid-0.40.0-17.mga7.x86_64
php-bz2-7.3.8-1.mga7.x86_64
php-channel-phpunit-1.3-16.mga7.noarch
php-gd-7.3.8-1.mga7.x86_64
php-imap-7.3.8-1.mga7.x86_64
php-mbstring-7.3.8-1.mga7.x86_64
php-mcrypt-1.0.2-1.mga7.x86_64
php-mysqli-7.3.8-1.mga7.x86_64
php-pear-1.10.9-1.mga7.noarch
php-pear-File_Iterator-1.3.4-6.mga7.noarch
php-sqlite3-7.3.8-1.mga7.x86_64
php-zip-7.3.8-1.mga7.x86_64
phpmyadmin-4.9.0.1-1.mga7.noarch
samba-4.10.8-3.mga7.x86_64
task-lamp-extras-3-7.mga7.noarch
task-lamp-php-3-7.mga7.noarch

à la main au lieu d'installer task-lamp-3-7.mga7.noarch tout seul qui va installer en plus task-lamp-perl-3-7.mga7.noarch et apache-mod_perl-2.0.10-6.mga7 (qui pose problème).

Xuo. Edité par xuo Le 13/10/2019 à 16h40
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6722

Le 13/10/2019 à 17h45
Oui, c'est le mécanisme.
Imagine, task-lamp est un râteau qui amène le sable. Quand tu retires le râteau, le sable reste.
Et côté fonctionnement, ça donne quoi ?


Yves
   
HomeBoy38 Membre non connecté

Rang

Avatar

Inscrit le : 31/07/2017 à 18h53

Messages: 32

Le 13/10/2019 à 18h34
Papoteur se lance dans le jardin zen
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 472

Le 13/10/2019 à 19h55
Bonsoir,

J'aurias du commencer par là.
En supprimant, le paquetage apache-mod_perl-2.0.10-6.mga7, il n'y a plus le problème sur la page d'accueil de NextCloud.

Xuo.
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6722

Le 14/10/2019 à 10h40
:super:
C'est la confirmation du coupable.


Yves
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie