Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Imprimantes scanners et Appareils Photo [Réglé] Scanner Epson XP-235 sous Mageia Linux OK

Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 01/11/2017 à 10h20
Bonjour,

Je possède une imprimante/scanner epson xp-235


J'ai vu des pilotes linux sur le site du fabricant et j'ai donc été assez confiant à l'achat. Trop.

pour l'imprimante, c'est bon.
J'ai jamais réussi pour le scanner.

J'ai fait de multiples tentatives, essayé avec les pilotes fourni pour Fedora, mais il manque des dépendances et j'ai pas pu arriver au bout.


j'ai parcouru le wiki https://wiki.mageia.org/en/Epson_scanners
les autres sujets sur ce forum qui traite du scanner
https://www.mageialinux-online.org/forum/topic-24219+installation-scanner-epson.php
https://www.mageialinux-online.org/forum/topic-23738+scanner-introuvable.php
....


Quelqu'un peut-il m'accompagner dans une nouvelle tentative d'installation, car j'ai pas le niveau seul.
(précédement, j'ai multiplié les tentatives, en empilant les pilotes et solutions sur lesquels je suis tombés)

Je viens de réinstaller complêtement mon système Mageia 6 kde 64, qui est donc neuf et à jour avec free, non free et tainted Edité par Ami age Le 01/11/2017 à 20h13


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2987

Le 01/11/2017 à 11h46
Bonjour

Il faut installer les pilotes propriétaires sur le site epson. Voici ma procédure pour mon XP-510. La version des packages est à revoir.

Pour la partie imprimante, il faut installer le rpm ESC/P-R Driver (generic driver) via le package epson-inkjet-printer-escpr-1.6.9-1lsb3.2.x86_64.rpm pour une 64 bits, pour le 32 bits prendre le i386)

Pour le scanner, il faut télécharger le bundle : iscan-bundle-1.0.2.x64.rpm.tar.gz

Installer le core package&data package Scanner Drive

Respecte bien l'ordre suivant :

a) Installer via un rpm --update ou urpmi le package iscan-data-1.37.0-3.noarch.rpm

b ) Installer via un rpm --update ou urpmi le package iscan-2.30.2-2.x86_64.rpm (pour une 64 bits, pour le 32 bits prendre le i386)

Installer network plugin package

c) Installer via un rpm --update ou urpmi iscan-network-nt-1.1.1-1.x86_64.rpm (pour une 64 bits, pour le 32 bits prendre le i386)
d) Il faut éditer le fichier /etc/sane.d/epkowa.conf et ajouter la ligne suivante

Code TEXT :
net 192.168.1.11 1865
Bien entendu, il faut adapter l'adresse ip et mettre celle de l'imprimante.

Remarque : si lors de l'installation du package un message d'avertissement demande de désinstaller un paquet parce qu'il y a conflit il faut accepter.

Quand cela est fait, pour scanner on lance dans un terminal/konsole la commande iscan. iscan est le logiciel epson pour scanner. Tu noteras qu'on peut également scanner directement via gimp: menu "Ficher" puis sous Menu "Créer" puis choisir "Scanning (iscan). Via cette action, iscan se lance. De plus, tu peux toujours scanner via xsane.

Ensuite, normalement, si suffit dans le centre de contrôle mageia de déclarer son imprimante. Ce dernier installera task-printing-server et task-printing-hp

[
Code BASH :
root@ISIS Téléchargements]# urpmi epson-inkjet-printer-escpr-1.6.9-1lsb3.2.x86_64.rpm
attention : epson-inkjet-printer-escpr-1.6.9-1lsb3.2.x86_64.rpm: Entête V4 DSA/SHA1 Signature, clé ID 8aa65d56: NOKEY
Le paquetage suivant a une signature invalide:
epson-inkjet-printer-escpr-1.6.9-1lsb3.2.x86_64.rpm: Signature incorrecte (NOT OK (no key): epson-inkjet-printer-escpr-1.6.9-1lsb3.2.x86_64.rpm: Entête V4 DSA/SHA1 Signature, clé ID 8aa65d56: NOKEY)
Voulez-vous continuer l'installation ? (o/N) o
installation de epson-inkjet-printer-escpr-1.6.9-1lsb3.2.x86_64.rpm
Préparation...                   ##########################################################################################################################################################################################################
      1/1: epson-inkjet-printer-escpr
                                 ##########################################################################################################################################################################################################
[root@ISIS Téléchargements]# cd iscan-bundle-1.0.2.x64.rpm/
[root@ISIS iscan-bundle-1.0.2.x64.rpm]# cd data/
[root@ISIS data]# ls
iscan-data-1.37.0-3.noarch.rpm
[root@ISIS data]# urpmi iscan-data-1.37.0-3.noarch.rpm
Afin de poursuivre la mise à jour, le paquetage suivant doit être désinstallé :
sane-backends-iscan-1.0.25-2.mga6.x86_64
 (en raison de conflit avec iscan-data-1.37.0-3.noarch) (o/N) o
 
 
SECURITÉ : Les paquetages suivants ne sont _PAS_ signés (OK ((none))) : iscan-data-1.37.0-3.noarch.rpm
installation de iscan-data-1.37.0-3.noarch.rpm
Préparation...                   ##########################################################################################################################################################################################################
      1/1: iscan-data            ##########################################################################################################################################################################################################
Failed to setup automatic scanner configuration via HAL.
If you have trouble accessing your scanner as a regular user, please
install xsltproc and run "/usr/lib/iscan-data/make-policy-file --mode fdi"
to enable this feature.
désinstallation du paquetage sane-backends-iscan-1.0.25-2.mga6.x86_64
      1/1: désinstallation de sane-backends-iscan-1.0.25-2.mga6.x86_64
                                 ##########################################################################################################################################################################################################
[root@ISIS data]# cd ../
core/    data/    plugins/
[root@ISIS data]# cd ../core/
[root@ISIS core]# urpmi iscan-2.30.2-2.x86_64.rpm                                                                                                                                                                                            
 
 
SECURITÉ : Les paquetages suivants ne sont _PAS_ signés (OK ((none))) : iscan-2.30.2-2.x86_64.rpm                                                                                                                                            
installation de iscan-2.30.2-2.x86_64.rpm                                                                                                                                                                                                    
Préparation...                   ##########################################################################################################################################################################################################  
      1/1: iscan                 ##########################################################################################################################################################################################################  
[root@ISIS core]# cd ../plugins/                                                                                                                                                                                                             
[root@ISIS plugins]# ls                                                                                                                                                                                                                      
iscan-network-nt-1.1.1-1.x86_64.rpm                                                                                                                                                                                                          
[root@ISIS plugins]# urpmi iscan-network-nt-1.1.1-1.x86_64.rpm                                                                                                                                                                               
 
 
SECURITÉ : Les paquetages suivants ne sont _PAS_ signés (OK ((none))) : iscan-network-nt-1.1.1-1.x86_64.rpm                                                                                                                                  
installation de iscan-network-nt-1.1.1-1.x86_64.rpm                                                                                                                                                                                          
Préparation...                   ##########################################################################################################################################################################################################  
      1/1: iscan-network-nt      ##########################################################################################################################################################################################################  
[root@ISIS plugins]# echo "net 192.168.1.11 1865" >> /etc/sane.d/epkowa.conf




Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go-M2 Samsung Evo 970 1Tb-SSD 512 Gb Samsung Evo 960 -Raspberry PI2
   
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 01/11/2017 à 16h53
merci pour cette procédure détaillée :)

alors, j'ai trouvé ici avec google
http://support.epson.net/linux/en/iscan_c.php?version=1.0.4

mais les versions sont un peu plus récentes
iscan-2.30.3-1.x86_64.rpm
iscan-data-1.39.0-1.noarch.rpm

j'y vais avec ces dernières versions ?

si je modifie l'adresse, je peux retrouver la version 1.02 que tu indiques
http://support.epson.net/linux/en/iscan_c.php?version=1.0.2
avec iscan-2.30.2-2.x86_64.rpm
iscan-data-1.37.0-3.noarch.rpm Edité par Ami age Le 01/11/2017 à 16h59


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2987

Le 01/11/2017 à 17h16
Bonjour

Tu peux prendre la dernière version sans problème. Mes notes ne sont tout simplement pas à niveau. Après, à adapter selon tes besoins. Mon imprimante/scanner XP-510 est branchée en wifi sur mon réseau. Le scanner fonctionne parfaitement avec iscan.


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go-M2 Samsung Evo 970 1Tb-SSD 512 Gb Samsung Evo 960 -Raspberry PI2
   
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 01/11/2017 à 17h46
ok
alors j'ai fait
a
b
c

j'ai installé les 3 paquets rpm en double cliquant sur les rpm, et tout s'est bien passé :)

pour la partie réseau avec IP de l'imprimante, c'est obligatoire ?
car j'ai pas encore compris comment la connecter à mon réseau
Je n'ai que le wifi pour la connecter, et je sais même pas si elle se connecte, ou récupérer son adresse Ip
c'est un modèle sans écran de contôle que je recommande pas, car c'est pas pratique de taper sur les boutons à l'aveugle.


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2987

Le 01/11/2017 à 18h38
Bonjour

Ah mon avis, si tu l'utilises en USB, c'est inutile. Pour le reste, pour configurer le wifi, j'ai un écran sur l'imprimante pour le configurer. Dans ton cas, je ne sais pas comment cela fonctionne. Je t'invite à regarder la doc de l'imprimante pour voir. Apparemment, tu peux la lier à ta box via le WPS depuis son panneau de contrôle.


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go-M2 Samsung Evo 970 1Tb-SSD 512 Gb Samsung Evo 960 -Raspberry PI2
   
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 01/11/2017 à 18h53
J'ai fouillé pour le wifi, et c'est pas simple. pas mal d'utilisateurs ont du mal à le configurer

je vais donc tester le scanner en usb.


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 01/11/2017 à 18h53
si je tape iscan en console j'ai

[s@localhost ~]$ iscan
Gtk-Message: Failed to load module "canberra-gtk-module"

(iscan:7577): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »

(iscan:7577): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »
^C
[s@localhost ~]$


avec une petite fenêtre qui s'ouvre
"Impossible d'envoyer une commande au scanner. vérifier l'état du scanner"

il faut que je passe par le CCM pour installer un scanner ? et installer le paquet sane par défaut ?
Edité par Ami age Le 01/11/2017 à 18h56


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2987

Le 01/11/2017 à 19h18
Bonjour

Apparemment, en usb, il faut adapter le fichier /etc/sane.d/epkowa.conf .


cf ici


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go-M2 Samsung Evo 970 1Tb-SSD 512 Gb Samsung Evo 960 -Raspberry PI2
   
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 01/11/2017 à 20h01
Bingo



Un grand merci à toi Vouf


Décidément, la communauté Mageia est est bien un des plus beaux atouts de la distribution :) Edité par Ami age Le 01/11/2017 à 20h08


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 01/11/2017 à 20h04
j'ai donc suivi toutes les consignes du lien que tu m'a indiqué, dans les modifs des fichiers

en ligne de commande j'ai celà
[s@localhost ~]$ iscan
Gtk-Message: Failed to load module "canberra-gtk-module"

(iscan:5973): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »

(iscan:5973): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »
Gtk-Message: Le nom du fichier ??T\303\251l\303\251chargements?? n'a pas pu ?tre converti en UTF-8. (essayez d'activer la variable d'environnement G_FILENAME_ENCODING)?: S?quence d'octets incorrecte en entr?e du convertisseur
Gtk-Message: Le nom du fichier ??Mod\303\250les?? n'a pas pu ?tre converti en UTF-8. (essayez d'activer la variable d'environnement G_FILENAME_ENCODING)?: S?quence d'octets incorrecte en entr?e du convertisseur
Gtk-Message: Le nom du fichier ??Vid\303\251os?? n'a pas pu ?tre converti en UTF-8. (essayez d'activer la variable d'environnement G_FILENAME_ENCODING)?: S?quence d'octets incorrecte en entr?e du convertisseur
[s@localhost ~]$


mais c'est sans aucune conséquence
et si je le lance via le lanceur d'application / graphisme / image scan for linux
tout va bien sans le moindre symptôme

Le message, c'est que le programme scan ne trouve pas les paramêtres du thème, des couleurs ? c'est çà ? Edité par Ami age Le 01/11/2017 à 20h07


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
Yuusha Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2017 à 19h52

Localisation : Gironde

Messages: 1069

Le 01/11/2017 à 23h28
Ami age :

Le message, c'est que le programme scan ne trouve pas les paramêtres du thème, des couleurs ? c'est çà ?

C'est un truc comme ça.
En fait dans
Code BASH :
user@linux-2:~$ urpmq -Y canberra
canberra-common
canberra-gtk
lib64canberra-devel
lib64canberra-gtk-devel
lib64canberra-gtk0
lib64canberra-gtk3-devel
lib64canberra-gtk3_0
lib64canberra0
libcanberra-devel
libcanberra-gtk-devel
libcanberra-gtk0
libcanberra-gtk3-devel
libcanberra-gtk3_0
libcanberra0
 
 

il y en a au moins un qui doit te manquer. Il suffit qu'un seul de ces paquets (en 32 bits ou en 64 bits selon ton système et hors les paquets devel) manque pour que tu es ce genre d'avertissement. Mais ce n'est pas important.
   
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2987

Le 02/11/2017 à 07h16
Bonjour

Bon eh bien tant mieux. Ca me fait penser qu'il faudrait trouver du temps pour mettre à jour le wiki de mlo en conséquence. Tu as juste mis à jour le fichier epkowa.conf ou tu as fait plus ? Je rejoins Yuusha. Je pense qu'il te manque quelques petits paquets pour faire disparaître les messages d'erreur.


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go-M2 Samsung Evo 970 1Tb-SSD 512 Gb Samsung Evo 960 -Raspberry PI2
   
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 4624

Le 02/11/2017 à 21h08
j'ai fait toutes les modif indiquées dans le lien ubuntu

pour le wiki, je veux bien le faire
mais j'aurais surement besoin de votre aide


.
_____________________________________ :silence: :silence: :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2987

Le 03/11/2017 à 06h59
Bonjour

Pas de soucis. Je ferai une relecture et complèterai la partie réseau. Éventuellement, quelques captures d'écrans seront ajoutées pour illustrer la configuration de l'imprimante.


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go-M2 Samsung Evo 970 1Tb-SSD 512 Gb Samsung Evo 960 -Raspberry PI2
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie