Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Environnements Graphiques » KDE Plasma [Résolu] SOS écran noir avec Mandriva 2010.1

zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 12/11/2010 à 11h30
Bonjour à tous ! :)

J'ai vu que pg80 a eu un problème de ce côté là, mais le mien semble différent.

Donc, je me suis décidé à adopter la dernière version de Mandriva,
la 2010 spring, et paf ! écran noir ou presque.
(Déjà pareil en live cd...)

Je suis dans le noir quasi-complet, à l'exception de la barre des tâches,
qui apparaît normalement en bas de l'écran.

Pas la moindre corbeille ni dossier home ! Je suis dans le brouillard !
Si je ballade la souris par là, il y a - parfois - un message déroulant
explicatif du volume ou dossier qui se trouve dans les parages.

Un clic droit dans le noir fait apparaître le menu déroulant normal,
avec entre autres les menus "quitter" ou "ouvrir avec dolphin".

Tout cela fait que je ne suis pas complètement planté.

Lorsque j'ouvre une fenêtre dolphin, je peux l'agrandir en hauteur, ok.
Mais en largeur, arrivée aux deux tiers de mon écran, elle devient noire aussi,
laissant masqué ce qu'il y a en dessous.
Idem avec une fenêtre kwrite, ou firefox.

Je suis allé voir au ccm, matériel, Configurer le serveur d'affichage,
ma carte graphique sélectionnée est la même qu'avec la Mandriva 2010.0 !
A savoir ATI Radeon X1950 and earlier, qui m'a jamais trahi jusqu'à présent.
Pas de pilote "nouveau" à l'horizon.
Le bouton "test" répond normalement, l'écran devient tout irisé.


Que m'arrive-t-il ?
Matériel devenu obsolète ? :désolé1:

Merci de votre aide. Edité par zeph Le 25/11/2010 à 12h51


Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
carlos Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2009 à 13h12

Messages: 349

Le 12/11/2010 à 12h28
salut !
j'ai eu le même soucis sur le PC fixe tournant avec une C.G. ATI alors qu'auparavant ça fonctionnait au poil...
j'ai été contraint de désactiver les effets 3D de Kwin pour retrouver des fonds d'écran et un bureau visible.
en même temps, ATI et linux ne semblent pas très copains, par rapport à Nvidia, me suis-je laissé dire... :diable:
   
zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 12/11/2010 à 13h56
Merci de ta réponse.

carlos :
j'ai eu le même soucis sur le PC fixe tournant avec une C.G. ATI alors qu'auparavant ça fonctionnait au poil...

j'ai été contraint de désactiver les effets 3D de Kwin pour retrouver des fonds d'écran et un bureau visible.


Je n'ai jamais activé les effets 3D.... :désolé1: Toujours en 2D.



carlos :
en même temps, ATI et linux ne semblent pas très copains, par rapport à Nvidia, me suis-je laissé dire... :diable:
c'est bien dommage !


Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
carlos Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2009 à 13h12

Messages: 349

Le 12/11/2010 à 15h26
re !
sinon, depuis le ccm, dans "installer/desinstaller des logiciels", tu vires le driver ati puis dans "configurer le serveur d'affichage" tu cliques sur "carte graphique" et en bas de liste tu as xorg : c'est là que tu trouveras les pilotes libres-->nv pour nvidia, vesa et ati en version libre. de là, en cliquant sur la petite flèche, tu vas voir se dérouler la suite de la liste xorg et là tu choisis "ati" tu valides en cliquant sur ok et tu suis le reste de la procédure que va te proposer mandriva. redemarrage. vu que tu n'utilises pas les effets 3D (kwin ou compiz), le pilote libre ati de xorg devrait te suffire.
voilà pour commencer. on va voir si cela te dépanne en attendant mieux...
à toutes fins utiles, peux-tu préciser le modèle de ta C.G. ?
   
zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 12/11/2010 à 18h39
Bonsoir,
je crois que mon problème est résolu. :super:
D'abord, je n'ai pas trouvé de pilote ATI dans "installer/desinstaller des logiciels" malgré des recherches sur ATI, driver, radeon...
Par contre, j'ai glané ces infos ci-après :

Configuration de la carte graphique :
Options :

avec accélération 3D matérielle : non
activer la transparence (extension composite) : NON*.
utiliser l'accélération matérielle du pointeur de la souris : oui
utiliser EXA au lieu de XAA (meilleures performances pour Render et Composite) : oui**

* si OUI ==>> ÉCRAN NOIR TEL QUE DÉCRIT CI-DESSUS (par défaut)
** oui pour tester. Non par défaut.

--------------------------------------

La configuration actuelle est :

Désactiver le Ctrl-Alt-Retour arrière : non
Accélération 3D matérielle : non
Disposition du clavier :
Type de souris :
Moniteur : PLE431
Fréquence de synchronisation horizontale : 24-83
Fréquence de synchronisation verticale : 55-75
Carte graphique : ATI Technologies Inc ATI Radeon X1950 and earlier
Nombre de couleurs : 16 millions de couleurs (24 bits)
Résolution : 1280x1024 24bpp
Pilote Xorg : ati
---------------------------------

explorer et configurer le matériel:
carte vidéo:
Identification
Fabricant: ATI Technologies Inc
Description: RV280 [Radeon 9200 SE]
Classe de matériel: VGA compatible controller
--------------------------------

C'est un peu par hasard que j'ai trouvé le truc... :désolé1:
Tu m'as bien orienté.
Merci de ton aide.
zeph :)


Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
Enzolyte Membre non connecté

Rang

Avatar

Administrateur

Inscrit le : 28/04/2008 à 21h45

Localisation : Albi - France

Messages: 5836

Le 12/11/2010 à 18h40
Salut Zeph

Quand tu es sur ton bureau, essayes de faire un CTRL+MAJ+F12, cela a pour but de voir effectivement si les effets sont activés ou pas. Tu peux nous dire ce qui se passe ? :merci: C'est le même raccourci pour revenir en arrière, il active/désactive les effets 3D ! ;)


"Profites de l'instant présent car hier n'est plus et demain ne viendra peut-être jamais."
Site web    
zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 12/11/2010 à 19h14
Enzolyte :
Quand tu es sur ton bureau, essayes de faire un CTRL+MAJ+F12, cela a pour but de voir effectivement si les effets sont activés ou pas. Tu peux nous dire ce qui se passe ? :merci: C'est le même raccourci pour revenir en arrière, il active/désactive les effets 3D ! ;)


Ben.... rien ! :]

Bureau fixe, statique.


Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 22/11/2010 à 10h13
J'ajoute qu'avec les versions précédentes de Mandriva (2009-1 et 2010-0)
j'avais un écran normal même avec la transparence activée... :diable:
Un bogue ? Ou ma machine obsolète ?


Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
carlos Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2009 à 13h12

Messages: 349

Le 22/11/2010 à 12h22
salut !
j'en reviens à ce que je te disais plus avant, à savoir que le pilote libre xorg ati est bel et bien présent dans les dépôts et tu le trouveras comme je te l'ai indiqué dans mon post précedent (ccm, configurer le serveur d'affichage, carte graphique, xorg (en bas de page), ati) car là, il se trouve que tu utilises le pilote propriétaire ati et qu'il serait souhaitable que tu le vires (ccm, installer/desinstaller des logiciels)...
dans ton cas précis, le pilote libre "xorg ati" semble le plus indiqué pour t'éviter tous ces désagréments. ;-) Edité par carlos Le 22/11/2010 à 12h25
   
zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 22/11/2010 à 13h21
Bonjour,

Citation :
La configuration actuelle est :



Désactiver le Ctrl-Alt-Retour arrière : non

Accélération 3D matérielle : non

Disposition du clavier :

Type de souris :

Moniteur : PLE431 --> iiyama

Fréquence de synchronisation horizontale : 24-83

Fréquence de synchronisation verticale : 55-75

Carte graphique : ATI Technologies Inc ATI Radeon X1950 and earlier

Nombre de couleurs : 16 millions de couleurs (24 bits)

Résolution : 1280x1024 24bpp

Pilote Xorg : ati


C'est pas bon ça ? :gene2l:
Edité par zeph Le 22/11/2010 à 14h00


Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
carlos Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2009 à 13h12

Messages: 349

Le 22/11/2010 à 13h51
salut !
le pilote ati propriétaire est-il toujours coché dans tes dépôts ?
autre question : peux-tu nous montrer ton xorg.conf ? pour cela, tu ouvre une console en root (su puis mot de passe) et tu tapes cette commande :
kwrite /etc/X11/Xorg.conf Edité par carlos Le 22/11/2010 à 13h59
   
zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 22/11/2010 à 14h02
ok. Je fais ce truc.

Par ailleurs, je ne vois aucun pilote sur le ccm/installer-désinstaller des logiciels.
J'ai fait des recherches sur ATI, pilote, driver... rien ou presque : 3 trucs avec nvidia et c'est tout.


Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
carlos Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2009 à 13h12

Messages: 349

Le 22/11/2010 à 14h03
oups ! nos messages se sont croisés...
   
zeph Membre non connecté

Rang

Avatar

Inscrit le : 06/12/2009 à 00h36

Localisation : 93 banlieue Paris

Messages: 124

Le 22/11/2010 à 14h13
exact !

j'obtiens une feuille kwrite blanche... :désolé1:



Donc je suis allé voir manu militari à l'adresse indiquée.



Je fais un copié-collé :



Citation :
# File generated by XFdrake (rev )





Section "Extensions"

Option "Composite" "Disable"

EndSection

# File generated by XFdrake (rev )



# **********************************************************************

# Refer to the xorg.conf man page for details about the format of

# this file.

# **********************************************************************



Section "ServerFlags"

Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)

AllowMouseOpenFail # allows the server to start up even if the mouse does not work

#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)

EndSection



Section "Module"

Load "v4l" # Video for Linux

EndSection



Section "Monitor"

Identifier "monitor1"

VendorName "Plug'n Play"

ModelName "PLE431"

HorizSync 24-83

VertRefresh 55-75



# TV fullscreen mode or DVD fullscreen output.

# 768x576 @ 79 Hz, 50 kHz hsync

ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630



# 768x576 @ 100 Hz, 61.6 kHz hsync

ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

EndSection



Section "Device"

Identifier "device1"

VendorName "ATI Technologies Inc"

BoardName "ATI Radeon X1950 and earlier"

Driver "ati"

Option "DPMS"

Option "AccelMethod" "EXA"

EndSection



Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultColorDepth 24



Subsection "Display"

Depth 8

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubsection



Subsection "Display"

Depth 15

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubsection



Subsection "Display"

Depth 16

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubsection



Subsection "Display"

Depth 24

Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"

EndSubsection

EndSection



Section "ServerLayout"

Identifier "layout1"

Screen "screen1"

EndSection




Mandriva 2010.0 one depuis le 28/11/2009 :) | Mandriva 2010-1 one depuis le 12/11/2010 ! :nono: | Re-Mandriva 2010-0 kde435 depuis le 28/11/2010 :super:
Dual boot lilo
dd 120Go dont partition linux 22Go (hda8) ; RAM 512Mo; swap ~500Mo
   
carlos Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2009 à 13h12

Messages: 349

Le 22/11/2010 à 14h39
on dirait que tu utilises bien le pilote libre de xorg. sinon, il y a, toujours dans xorg, un pilote radeon (plus bas dans la liste déroulante). peut-être voir s'il est plus adapter. simplement cliquer sur test pour voir et annuler si ça n'est pas concluant...
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie