Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Cartes graphiques et webcams NVIDIA Geforce 7900GS Driver propritaire ne fonctionne pas

recupart Membre non connecté

Rang

Avatar

Inscrit le : 05/07/2020 à 16h02

Localisation : France-Drôme

Messages: 1

Le 05/07/2020 à 16h41
Bonjour,
Après des heures de recherches, je n'arrive toujours pas à avoir une installation de MAGEIA 7.1 correcte sur mon PC de récup...
Modèle DELL XPS M1710, Centrino DUO avec 4Go de RAM
Carte graphique NVIDIA NVIDIA GeForce 7900 GS
Mon problème:
Dès le démarrage sur la clé usb, Mageia me propose l'option "Driver NVIDIA" propriétaire. Avec cette option, l'installation se bloque et l’écran reste noir. Pareil si je lance MAGEIA en live avec option driver propriétaire.

Lorsque j'installe MAGEIA 7.1 avec le driver nouveau (option par défaut), l’écran fait des traces après le curseur, des lignes blanches cachent les fenêtres ouvertes, ce qui rend le PC inutilisable.
J'utilise Plasma comme window manager.
J'ai donc téléchargé le script --NVIVIDIA-linux-x86_64-304.137.run-- proposé par NVIDIA. Plusieurs forum déconseillent l'installation de ce driver incompatible avec les derniers noyaux (j'ai le 5.1.14), et de toute façon je ne suis jamais arrivé à la fin du script, gcc incompatible, modprobe pas dans le bon path, je ne sais pas quoi mettre dans l'option --kernel-source-path, ...
J'ai donc essayé de "bricoler" parmi les drivers proposés par le CCM, et j'ai du mal à choisir
Donc voici ma demande:
Parmi les drivers proposés, lequel me convient le mieux?
- Geforce 6100 to Geforce 7950 (celui choisi à l'installation)
- autre choix ???
Existe-t-il un dépot avec un driver plus appropié?
Merci de votre aide...


Rien de plus précieux qu'un bon vieux PC
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 7723

Le 05/07/2020 à 18h36
Bonjour,
Le pilote Nvidia304 n'est plus compatible avec la version de Xorg qui est dans Mageia 7. Tu as la mauvaise option de rester en Mageia 6 ou d'utiliser nouveau dans Mageia 7.
Tu peux dans Plasma changer le compositeur pour prendre Xrender plutôt qu'un OpenGL.


Yves
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie