Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Packaging VpnAutoconnect Compil sur Mageia 7

RVDN06 Membre non connecté

Rang

Avatar

Inscrit le : 03/04/2020 à 10h49

Localisation : PACA

Messages: 4

Le 04/04/2020 à 00h48
Ayant téléchargé les sources sur le site de VPNAutoconnect, je tente de compiler ce logiciel VpnAutonnect sur ma machine Bureau Kde Plasma sur Mageia 7 64 Bits.
La 1ere partie se passe bien le ./configure se termine sans erreurs
Une fois le Make enclenché il se termine avec une erreur libcaps.so n'est pas reconnue il manque libcap pour version 32 bits si je comprends bien , j'ai Mageia 7 les librairies 32 bits apparament sont présentes mais le compilateur pointe sur la librairies 64 Bits
comment faire pour ne plus avoir cette erreur.
Merci


[b][color=#FF9900][/color][/b][s][/s]
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8012

Le 04/04/2020 à 07h26
Bonjour,
Sans regarder dans le détail, si tu fais de la compilation, c'est pour que le programme soit adapté à ton architecture.
Il faut donc que la compilation se fasse pour du 64 bits. Ne cherche pas à l'alimenter en 32 bits.
Cherche s'il n'existe pas une directive quelque part pour lui dire de construire en 64 bits.
Si c'est parce que les "sources" fournissent un module en 32 bits, méfiance, c'est du code non inspectable. A éviter.


Yves
   
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 822

Le 04/04/2020 à 07h58
il faudrait que tu nous mettes le message d'erreur précis car c'est pas clair ton affaire.


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
RVDN06 Membre non connecté

Rang

Avatar

Inscrit le : 03/04/2020 à 10h49

Localisation : PACA

Messages: 4

Le 08/04/2020 à 18h08
Dsl un peu tardif voici le message :
vpnautoconnect-2.0.5

/usr/bin/ld :/usr/lib/gcc/x86_64-mageia-linux-gnu/8.4.0/../../../lipc.so ignorécar incompatible lors de la recherche de -lpcap
/usr/bin/ld ne peut trouver -lpcap
collect2: error:ld a retournéle statut de sortie 1
on quitte le repertoire /home/../Documents/vpnautoconnect....
make: ***[Makefile:899: all-recursive] Error 1

Voila le message merci


[b][color=#FF9900][/color][/b][s][/s]
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 2865

Le 09/04/2020 à 23h30
Bonjour,

Depuis quel site sont chargées les sources ( j' ai vu un site sur sourceforge ( d' ailleurs la version 2.0.5 ne semble pas être la dernière (sortie en 2012)) ?

le paquet lib64pcap-devel est installé ( je suppose que oui car sinon le configure ne peut pas se terminer sinon) ?

Comme paquets , j' ai installé :

lib64gtk+2.0-devel
lib64dbus-glib-devel
(lib64cap-devel)
lib64pcap-devel

Citation :
./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/usertest/Téléchargements/vpnautoconnect-2.0.5/vpnautoconnect-2.0.5/missing: line 1: For: command not found
configure: WARNING: `missing' script is too old or missing
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether NLS is requested... yes
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for shared library run path origin... done
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking whether gcc and cc understand -c and -o together... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTK2... yes
checking for GTHREAD... yes
checking for DBUSGLIB... yes
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking sys/capability.h usability... yes
checking sys/capability.h presence... yes
checking for sys/capability.h... yes
checking pcap.h usability... yes
checking pcap.h presence... yes
checking for pcap.h... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating ressource.h
config.status: creating init_script/lvpnc
config.status: creating po/Makefile.in
config.status: executing po-directories commands
config.status: creating po/POTFILES
config.status: creating po/Makefile
config.status: executing depfiles commands


et le make se termine correctement.

Toutefois cela ne donne rien à l'éxecution en plus cela semble reposer sur des scripts init.d ( donc du mode sysv qui n' est plus utilisé)

   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie