Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Cartes graphiques et webcams [Réglé] X server briqué J'ai briqué mon x server avec le update nouveau noyau

rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 01/03/2020 à 19h51
Désirant la meilleure pilote graphique pour voler avec le simulateur Flightgear j'ai l'habitude de réinstaller cette pilote après chaque mise á jour du noyau car le dkms auto-installer s'arrête avec l'incohérence de deux versions differentes.
Normalement la réinstallation de la pilote Nvidia va bien et le reboot après aussi.
Mais pas cette fois.
Après le telechargement des mises a jour Mageia 7 proposés y compris le noyau 5.5.6-2.mga7, la réinstallation de la pilote Nvidia s'est arrêtée avec un long message...
J'essayé de mettre "nouveau" puis "vesa" , rien ne change, le boot graphique montre "Building Nvidia driver" puis "Installing Nvidia driver" puis c'est retour á l'écran noir et un cursor clignotant.

J'ai essayé avecl les anciens noyaux avec nouveau et vesa mais rien ne fonctionne...

Comment reseter tout ça?


Ps:J'ai un photo du long message d'erreur
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 7716

Le 01/03/2020 à 23h06
Bonsoir,
Sais-tu quelle est la carte ?
Ou au moins quelle version du pilote nvidia elle a besoin ?


Yves
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 2528

Le 01/03/2020 à 23h14
Bonjour,

Je suppose que la combinaison de touche ctrl+alt+f2 ( ou alt+f2) fonctionne ?

Si oui que donne un lspci --nn ( afin de savoir de quelle carte il s' agit).

Que donnent un

/sbin/dkms status
cat /var/log/Xorg.0.log | grep -i Nvidia

?

   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 16h16
merci aux deux pros d'entrer en matière.
Oui je peux accéder aux TTY, c'est ma manière habituelle de faire un init 3 avant de lancer la réinstallation de la pilote Nvidia avec le fichier .run de chez Nvidia.
je répondrai aux autres questions à la casa ce soir pour éviter de raconter n'importe quoi maintenant, merci à+
   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 19h05
lspci -nn
Nvidia gk104, geforce gtx760 [10de:1187] abrégé

/sbin/dkms status
donne beaucoup de lignes mais sauf une photo je ne peux les transmettre...
Il y a une difference entre built et installed nvidia modules; built le 430.64-4 et installed la 440.44
La 440 est la version proprio et la 430 doit être la version Mageia.

cat /var/log/Xorg.0.log | grep -i Nvidia
ne donne rien.
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 2528

Le 02/03/2020 à 19h13
Bonjour,

Donc la version 440 et 430 sont installés en même temps.

Quelle version doit être conservée (la 440 semblant être compatible avec la gtx 760) ?

Dans le cas de la 440,

Je ferais un

Code BASH :
urpme nvidia -a


Ainsi, cela désinstallera la version 430.64.

Je relancerais par la suite le programme d' installation du pilote nvidia (afin d' être sur que tout est bien installé).

Enfin, je ferais un

Code BASH :
cd /boot
dracut -f initrd-$(uname -r).img $(uname -r)


Puis reboot.

Voir ce sujet...

https://www.mageialinux-online.org/forum/topic-27239+changer-une-carte-graphique.php
Edité par nic80 Le 02/03/2020 à 19h15
   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 20h06
La déinstallation de la 430 s'est bien déroulée mais la réinstallation de la 440 s'est arrêtée avec les mêmes erreurs.
Edité par rooman Le 02/03/2020 à 20h16
   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 20h15
1583088115630_1583088089376_1583088079489_img_20200301_175804_resized_20200301_061013986
Même erreur toujours pendant l'installation de la 440 avec le fichier proprio .run
   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 21h12
20200302_210657
Le make.log cité dans le msg d'erreur
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 2528

Le 02/03/2020 à 21h58
Bonjour,

Visiblement, il manque un fichier nommé drmP.h .

Le dernier que j' ai sur ma machine, c' est celui ci.

Citation :
/usr/src/kernel-5.4.17-desktop-1.mga7/include/drm/drmP.h


Donc si un noyau 5.4.17 est installé sur cette machine, potentiellement le pilote va pouvoir se compiler.

Dans ce cas, on peut essayer de copier ce fichier vers le /usr/src/kernel-5.5.6-desktop-2.mga7/include/drm/ ( en espérant qu' il n' y a pas eu de modification entre les versions).

cp /usr/src/kernel-5.4.17-desktop-1.mga7/include/drm/drmP.h /usr/src/kernel-5.5.6-desktop-2.mga7/include/drm/

( Après je ne comprends pas comment le module Nvidia a pu se compiler sur ma machine...) Edité par nic80 Le 02/03/2020 à 22h01
   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 22h02
Si jamais
cat /var/log/Xorg.0.log | grep -i Nvidia
Module mentionné le 440
Puis Failed to initialize the nvidia kernel module, please see the system's kernel log etc...
   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 22h07
Donc même si je pourrais compiler le module avec l'ancien 5.4, je ne peux évoluer vers le 5.5?
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 2528

Le 02/03/2020 à 22h08
Bonjour,

Oui, c' est normal, puisque le module noyau n' a pas pu être compilé ni intégré dans l' initrd.

En revanche, mon idée de copier le fichier n' est peut être pas si bonne que ça... le fichier drmP.h ne semble plus exister dans le noyau 5.5...

edit:

Citation :
Donc même si je pourrais compiler le module avec l'ancien 5.4, je ne peux évoluer vers le 5.5?


Probablement que oui...

C' est bien la dernière version disponible sur le site Nvidia (sur le site Nvidia, il y a une version 440.64, or ici je vois une version 440.44) ?

Peut être qu' un:

wget http://fr.download.nvidia.com/XFree86/Linux-x86_64/440.64/NVIDIA-Linux-x86_64-440.64.run

devrait permettre de récupérer la dernière version et donc d' essayer avec celle ci ( en prenant soit de désinstaller l' ancienne avant)... Edité par nic80 Le 02/03/2020 à 22h18
   
rooman Membre non connecté

Rang

Avatar

Inscrit le : 17/01/2011 à 11h07

Localisation : Lausanne, Switzerland

Messages: 101

Le 02/03/2020 à 22h18
J'ai bootė sur le 5.4.17 et p@@@@@n ça a démarré comme d'habitude!
Super, ose-je éteindre ce soir?
Selon le nvidia x server settings utilitaire je suis en train de rouler avec le driver 440.44, server v 11.0.
Magnifique!

Comment trouver ce qui s'est passé et prevenir pour une prochaine mise à jour du noyau?

Sympa les gars, merci bcp.
Je mettrai resolu si je peux booter demain... Edité par rooman Le 02/03/2020 à 22h20
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 2528

Le 02/03/2020 à 22h20
Bonjour,

Je crois nos post/éditions se sont croisés... Edité par nic80 Le 02/03/2020 à 22h20
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie