Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Installation et configuration [Réglé] Mise à jour Mode d'emploi please...!

Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 2304

Le 14/02/2020 à 23h05

Reprise du message précédent

Bonne nuit
   
apascale Membre non connecté

Rang

Avatar

Inscrit le : 09/02/2020 à 14h37

Localisation : Mantes-La-Jolie

Messages: 65

Le 14/02/2020 à 23h38
Bonne nuit à tout le monde !
et suite au prochain épisode... après la commande puis le reboot, ça avait l'air de bien se passer j'ai vu l'écran bleu de menu mageia !!!, des "installing driver" au-dessus des 3 points d'interrogation ;
puis d'un coup écran noir et de nouveau les trois lignes avec lesquels je suis arrivée sur ce forum :(
[OK] Started Command Scheduler.
[OK] Started Terminate Plymouth Boot Screen
[OK] Hold until boot process finishes up

J'espère que ce week-end ou la semaine prochaine vous me direz que c'est normal...!!! :)
Bon week-end à tout le monde.


@¬-°@ =¢-¦=
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1878

Le 15/02/2020 à 00h27
Bonjour,

Des "installing driver", cela peut être normal, cela dépend de la carte graphique ( par exemple, je soupçonne que la carte graphique soit une carte Nvidia, qui a besoin si le pilote propriétaire est utilisé de se recompiler à chaque changement de noyau).

Il faudrait savoir quelle est le type de carte graphique installée sur le pc.
Pour cela, il est possible de faire la commande (en utilisateur normal), après avoir fait un ctrl + f2 :

Code BASH :
lspci


Si une ligne retournée contient Nvidia ( si c' est le cas laquelle est ce ?), il serait intéressant de connaitre le résultat de la commande (ici je considère que le pilote Nvidia propriétaire est utilisé ( peut être à tort)

Code BASH :
/sbin/dkms status


qui devrait retourner quelque chose comme ceci ( ou potentiellement autre chose que 430.64, cela dépend de la carte graphique, s' il est fait mention de d' une version 304, ce n' est pas bon, ce pilote n'existant plus dans Mageia 7) :

Code BASH :
$/sbin/dkms status
nvidia-current, 430.64-2.mga7.nonfree, 5.4.17-desktop-1.mga7, x86_64: installed 
 


Si l'on n' est dans aucun des cas précité ( et même si l' on est dans ce cas ! ;-) ) , il faudra vérifier ce que contient le fichier log du serveur d' affichage. Pour cela, il faudrait faire la commande suivante ( le (EE) est pour indiquer les messages d' erreurs au démarrage du serveur d' affichage ( et ici cela ne devrait pas être vide)):

cat /var/log/Xorg.0.log | grep "(EE)"

Il sera peut être nécessaire de passer par l' outil de XFdrake ( qui permet de configurer la partie graphique, mais il faut connaitre le modèle de carte graphique). Si la commande /sbin/dkms indique la version de pilote 304 de Nvidia, il faudra obligatoirement choisir le pilote Xorg -> nouveau dans cet outil.

Citation :
3 points d'interrogation


Ceci n' est pas normal, mais c' est potentiellement juste esthétique.

Il est potentiellement possible de tester d' ajouter ou supprimer (selon le cas) l' option vga=791 du menu de démarrage de Mageia. Edité par nic80 Le 15/02/2020 à 01h04
   
apascale Membre non connecté

Rang

Avatar

Inscrit le : 09/02/2020 à 14h37

Localisation : Mantes-La-Jolie

Messages: 65

Le 15/02/2020 à 01h11
Oh Super déjà une piste à suivre, merci.
Alors il y a Nvidia oui
01:00.0 VGA compatible controller : NVIDIA Corporation GF108 High Definition Audi
01:00.1 Audio device : NVIDIA Corporation GF108M [GeForce GT 525M] (Rev a1)


@¬-°@ =¢-¦=
   
apascale Membre non connecté

Rang

Avatar

Inscrit le : 09/02/2020 à 14h37

Localisation : Mantes-La-Jolie

Messages: 65

Le 15/02/2020 à 01h25
J'ai vu le nvidia 430.64 au début oui et aussi les dernières lignes à l'écran font apparaître des paquetages tels que : vboxadditions,...-1.mha6, ...desktop... .mga6, x86_64 : installed-binary fr on ...desktop... .mga6, x86_64
(les pts de suspensions pour les différents chiffres, points et tirets)


@¬-°@ =¢-¦=
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1878

Le 15/02/2020 à 01h33
Bonjour,

Donc à priori la carte Geforce GT 525M est d' après le site de Nvidia supportée par le pilote 390.87 ( mais je ne vois pas de trace de cette version dans les paquets, mais le paquet 390.132 semble correspondre). En revanche si la version 430.64 est installée, cela ne fonctionnera pas, cette version de pilote ne prenant pas en charge la geforce GT 525M visiblement.

Il est possible de faire lancer XFdrake en root afin de sélectionner le pilote nouveau temporairement si ce n' est pas le cas.

En effet, le pilote propriétaire ne sera pas installable si les dépots Non Free ne sont pas actifs ( un urpmq --list-media active doit retourner des lignes de type

Code TEXT :
Nonfree Release
Nonfree Updates


Si ce n' est pas le cas, il sera nécessaire de les activer ( en version x86_64 uniquement !)

Il faudrait regarder les paquets relatifs à Nvidia qui sont installés:

Code BASH :
rpm -qa | grep nvidia


Si c' est les paquets 430.64 qui sont installés, il sera probablement nécessaire de les désinstaller, activer les dépots non free ( en root);

Code BASH :
urpmi.update --no-ignore "Nonfree Release"
urpmi.update --no-ignore "Nonfree Release"
 

;

pour installer les mêmes paquets en version 390.132.


Edité par nic80 Le 15/02/2020 à 01h39
   
apascale Membre non connecté

Rang

Avatar

Inscrit le : 09/02/2020 à 14h37

Localisation : Mantes-La-Jolie

Messages: 65

Le 15/02/2020 à 01h38
Pour cat /var/log/Xorg.0.log | grep "(EE)" :
[ 55.647] (EE) No device detected
[ 55.647] (EE)
[ 55.647] (EE) no screens found (EE)
[ 55.647] (EE)
[ 55.647] (EE) Please also check the log file at "/var/log/Xorg. 0.log" for additional information.
[ 55.647] (EE)
[ 55.647] (EE) Server terminated with error (1). Closing log file.

J'ai tapé "/var/log/Xorg. 0.log" et ça donne pas mal de trucs, en vrac:
Module "ramdac"
NVIDIA GeForce GT 525M GPU
NVIDIA 390.xx Legacy drivers. Please
https://bugs.mageia.org for help



@¬-°@ =¢-¦=
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1878

Le 15/02/2020 à 01h56
Bonjour,

Pour désinstaller les paquets en nvidia en 430.64, il faudrait faire un urpme sur tous les paquets retournés par la commande ( s' ils contiennent la mention 430.64):

Code BASH :
rpm -qa | grep nvidia


Puis installer les paquets en version 390.132 par un (en root)

Code BASH :
urpmi x11-driver-video-nvidia390


puis lancer la commande suivante:

Code BASH :
cd /boot
dracut -f initrd-$(uname -r).img $(uname -r)
 


puis redémarrer le pc ( en espérant qu'il redémarre, la commande dracut n' étant pas anodine)

Si les paquets nvidia en 390.132 sont installés, je pense qu' il n' est pas recommandé de sélectionner le pilote nouveau dans XFdrake ( en effet, c' est soit nouveau ( pilote libre), soit le pilote propriétaire, mais pas les deux en même temps)

Note importante: avant de lancer l' urpmi, il faudrait vérifier que les dépots Non free sont bien en x86_64 ( urpmq --list-media active --list-url doit retourner uniquement des urls contenant x86_64 à l' intérieur. Sinon les paquets i586 vont potentiellement faire leur retour. Edité par nic80 Le 15/02/2020 à 02h21
   
apascale Membre non connecté

Rang

Avatar

Inscrit le : 09/02/2020 à 14h37

Localisation : Mantes-La-Jolie

Messages: 65

Le 15/02/2020 à 02h34
urpmq --list-media active
donne plus que les résultats attendus :
Core Release
Core Updates
Nonfree Release
Nonfree Updates


Je ne m'en sors pas avec le XFdrake, je ne vois rien qui ressemble à GeForce 525 ou 390, il y en a plein d'autres dans serveur x.

J'ai rebooté, sélectionné mageia 7, ça tourne.
Je reviendrai vers vous, vous tenir au courant.
Merci pour tout.


@¬-°@ =¢-¦=
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1878

Le 15/02/2020 à 02h56
Bonjour,

C' est normal que dans XFdrake on ne trouve ni 525 ni 390...

En fait il est impossible de lister toutes les cartes existantes. Les cartes sont donc classées dans des catégories (nvidia 635 and later, nvidia xxx to yyy (je ne me souviens plus des classifications à cette heure avancée)...), celles ci pointant implicitement vers une version du pilote (340,390 ou 430) et donc installant le paquet adéquat.
   
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2753

Le 15/02/2020 à 07h15
Bonjour

Pour le coup, vous m'impressionnez !! apascale qui dit ne pas être une professionnelle de l'informatique mais qui assure grave avec la ligne de commande et qui ne lâche pas l'affaire ! nic80, Jybz, papoteur et les autres qui restent disponibles et à l'affût !

En espérant que le problème de apascale soit réglé, en tout cas, c'est une belle collaboration !!


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go avec driver libre-1 DD 500 Go Western Digital WD20EARS Caviar Blue en mode SATA -SSD 512 Gb Samsung Evo -Raspberry PI2 -Synology DS216+
   
Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 2304

Le 15/02/2020 à 08h35
Ouhlà ! Grosse vie nocturne ici !

Nic80, avant de déboguer le coté pilote graphique, ne souhaites tu pas finir la mise à jour ?

Au dernières nouvelles il restait ~1000 paquets mga6, je trouve que ça en fait un peu trop pour passer au sujet suivant, même si vous m'avez l'air sur la bonne piste !

Peux-tu nous :
rpm -qa --last | grep mga6 | wc -l
rpm -qa --last | grep mga6 | nc termbin.com 9999
?

S'il n'y en a plus beaucoup, alors on peut considéré que c'est "bien" mis à jour ! :-D
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1878

Le 15/02/2020 à 09h13
Bonjour,

Pour les paquets mga6, Apascale a indiqué sur ce post avoir faire un urpmi --auto-update ( qui s' est terminé sans encombre apparament ) avant de supprimer les paquets i586, on pourrait supposer que la majeure partie des paquets mga6 ( dont la plupart étaient visiblement en x86_64) ont été mis à jour à cette occasion. Puis certains paquets ne sont probablement pas possible à mettre à jour, le nom ayant changé entre la version 6 et la version 7 ( lib64cdio18 en est un exemple, mais les kernel aussi ( il me semble en avoir vu quelques uns dans la liste des paquets)).

Je retiens que potentiellement pour une carte GT 525M, le pilote sélectionné n' est probablement pas le bon. D' ailleurs si c' est le cas, peut être faudrait t' il interdire le paquet 430.64 d' installation en empêchant le 390.132 à se mettre à jour, car rien ne dit que si le paquet s' est installé une fois, il ne soit pas proposé de nouveau dans le futur ( voir au prochain urpmi --auto-update , pour mettre à jour les paquets mga6 éventuels si apascale a installé les paquets nvidia manuellement).

edit: Je serais curieux de savoir ce que retourne la commande

lspci -nn | grep -i Nvidia

En effet, une recherche sur ce site, la geforce GT 525M aurait pour id 10de:0dec ou 10de:0df5 .

Or si j' en crois le fichier /usr/share/ldetect-lst/Cards+ et le fichier pcitable contenu dans le fichier /usr/share/ldetect-lst/pcitable.gz, le fichier pcitable indique pour ces deux id "Card:NVIDIA GeForce 420 to GeForce 630" et dans le fichier /usr/share/ldetect-lst/Cards+ à la rubrique Card:NVIDIA GeForce 420 to GeForce 630, il y a

Citation :
# nvidia390 supports some GeForce 410 cards as well,
# but does not support some 415 cards. The higher bound
# is used in the name, since this way both auto-selection
# and manual user selection by model number always result in a
# working driver for 410/415, since all of those are also
# supported by nvidia340.
NAME NVIDIA GeForce 420 to GeForce 630
DRIVER nouveau
DRIVER2 nvidia390
DRIVER2_NEEDS_SSE


Donc c' est bien le pilote 390 qui devrait être installé...

Edité par nic80 Le 15/02/2020 à 10h38
   
apascale Membre non connecté

Rang

Avatar

Inscrit le : 09/02/2020 à 14h37

Localisation : Mantes-La-Jolie

Messages: 65

Le 15/02/2020 à 10h59
Bonjour à tout le monde !
Cette nuit j'ai lancé mageia7 avant d'avoir vu le message de nic80 pour rpm -qa | grep nvidia (et 2 autres commandes) ...
Je me disais que je ferai les commandes ce matin mais mon ordi tourne toujours... ça sent le roussi...!
Voilà ce qui défile, exemple d'une ligne :
[..... . ..... ] audit: type=1131 audit(............. . ... : .... ): pid=1 uid=0 auid=429
4967295 ses=429
4967295 msg='unit=bumblebeed comm="system" exe="/usr/lib/systemd/system" hostname=? addr=? terminal= ? res=failed'
pour le "res=..." c'est failed ou success selon. (les pts de suspension pour les chiffres qui changent selon les lignes)

J'y crois alors je persiste puisque vous prenez le temps de me guider et m'expliquez, merci merci ! quelle aventure !
mais là j'avoue que je m'en veux d'avoir mis la charrue avant les bœufs en voyant l'écran bleu du menu boot et en lançant mageia7 !!

Je vous laisse tranquille jusqu'à lundi soir car je ne pourrai pas m'occuper de mon ordi. Je pars dans une heure, à midi, et serai obligée d'éteindre l'ordi.
Bon week-end et à lundi !!...))


@¬-°@ =¢-¦=
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 7178

Le 15/02/2020 à 11h07
Bonjour,
N'oublie pas de dormir la nuit, c'est fait pour ça ;)
Blumblebee ?
Ceci est associé à une technologie de double cartes graphiques, l'une dite intégrée, l'autre dite séparée.
Dans ce genre de matériel, il faut configuré Xorg (le serveur graphique) avec la carte intégrée, en général une carte Intel.
Donc, redémarre en mode recovery, et lance
Code BASH :
XFdrake

(avec XF en majuscules)
Sélectionne avec les flèches la première ligne qui indique le nom de la carte, en principe Intel. Tu fais Entrée à chaque proposition. Puis tu quittes (je ne sais plus s'il y a une option de sauvegarde, mais je ne crois pas). Et tu redémarres.


Yves
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1878

Le 15/02/2020 à 11h09
Bonjour,

L' affichage de bumblebeed est nouveau ?

En règle générale, ce programme est utilisé sur les portables ( ce que semble être le pc à cause de la carte GT 525M) qui utilisent à la fois une carte Intel et une carte Nvidia ( cette dernière étant utilisée pour des applications graphiques "lourdes" ). Visiblement dans ce cas, il est préférable de configurer la carte Intel dans XFdrake ( je n' ai pas testé, n' ayant pas de système utilisant cette technologie).

edit: @Papoteur, je viens de lancer XFdrake, lequel il faudrait choisir ? 810 and later ? ;-) Edité par nic80 Le 15/02/2020 à 11h16
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie