Connexion

Forum

Environnements Graphiques » KDE Plasma [Réglé] [MAJ vers Mageia 7]Icônes manquantes dans les applis GTK sous Plasma

alouali Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2014 à 09h56

Localisation : Lyon, France

Messages: 36

Le 01/12/2019 à 16h13
Bonjour,

depuis la mise à jour vers Mageia 7, je n'ai presque plus d'icônes sur les applications GTK (GIMP, Inkscape) sous Plasma :

bug-gtk1

bug-gtk2_a32d8
(et d'ailleurs Inkscape crashe après le lancement).

J'ai essayé de changer plusieurs fois les thèmes des applications, icones, GTK (breeze, adwaite, oxygen...) à l'aide de systemsettings, j'ai essayé de redémarrer, d'installer gnome-control-center et gnome-tweaks, de vider le ~/.cache, tout ça sans résultats.

Une idée ?
Merci !
Site web    
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 01/12/2019 à 17h20
Bonjour,

Est ce que le phénomène se produit également sur un nouveau profil utilisateur crée à l' occasion (puisqu' il s' agit d' une mise à jour, peut être y a t' il un problème avec l' ancien profil) ?

J' ai vu que gnome-tweak a été installé, donc gnome l' a probablement été aussi ? Le problème se pose aussi avec cet environnement ?



   
alouali Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2014 à 09h56

Localisation : Lyon, France

Messages: 36

Le 01/12/2019 à 20h23
Bonjour,

je viens d'essayer avec le compte invite et un autre utilisateur, même problème.

Par contre impossible de lancer gnome (xorg ou wayland), au bout de 1s je reviens sur l'écran de connexion SDDM.

J'ai essayé aussi OpenBox, message d'erreur à la connexion que je ne peux copier assez obscur (je crois qu'il y ai question d'un problème avec une lib de mgaonline et le thème breeze), puis ensuite quand je lance Gimp même problème d'icônes.
Site web    
alouali Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2014 à 09h56

Localisation : Lyon, France

Messages: 36

Le 01/12/2019 à 20h45
Je me rends compte que ce problème n'est finalement pas apparu tout de suite après la mise à jour vers Mageia 7.

En effet, je me souviens après cette maj avoir utilisé la visionneuse de PDF de gtk evince (qui marche mieux pour l'impression que Okular chez moi), et que les icônes étaient bien présentes dans un premier temps, mais aujourd'hui elles ont elles aussi disparues.
Site web    
alouali Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2014 à 09h56

Localisation : Lyon, France

Messages: 36

Le 02/12/2019 à 21h17
Du nouveau : voici les messsage que j'ai sur la console en lançant gimp et inkscape depuis un terminal :
$gimp
WARNING: icon 'gimp-default-colors' failed to load. Check the files in your icon theme.
WARNING: icon 'gimp-swap-colors' failed to load. Check the files in your icon theme.

** (gimp:7826): WARNING **: 21:15:21.591: Invalid borders specified for theme pixmap:
/usr/share/themes/Breeze/gtk-2.0/../assets/line-h.png,
borders don't fit within the image

$ inkscape

(inkscape:8602): GdkPixbuf-CRITICAL **: 21:15:27.294: gdk_pixbuf_scale_simple: assertion 'dest_width > 0' failed

(inkscape:8602): GLib-GObject-CRITICAL **: 21:15:27.294: g_object_ref: assertion 'G_IS_OBJECT (object)' failed
terminate called after throwing an instance of 'Gtk::IconThemeError'

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Abandon (core dumped)
Site web    
alouali Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2014 à 09h56

Localisation : Lyon, France

Messages: 36

Le 02/12/2019 à 22h04
Trouvé un dépannage pour Gimp (car lui au moins se lance, contrairement à Inkscape) :

Gimp > Editions > Préférences > Thème d'icône > Legacy (c'est le seul qui fonctionne)

Reste plus qu'à trouver une solution pour Inkscape...
Site web    
alouali Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2014 à 09h56

Localisation : Lyon, France

Messages: 36

Le 02/12/2019 à 22h45
Ca y est ! J'ai trouvé une solution qui fonctionne pour Inkscape aussi :
en root, j'ai lancé la commande :

Code BASH :
gdk-pixbuf-query-loaders --update-cache


Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie