Connexion

Forum

Retours d'expériences Mageia 7.1 et imp hp Scanner non reconnu

CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 06/11/2019 à 09h49
Bonjour,
Après installation de Magéia 7.1 mon imprimante multifonction HP Photosmart b109a est reconnue mais le scanner ne l'est plus.
J'ai configuré grâce au CCM, rien à faire le scanner n'est pas reconnu.

Merci de vos réponses.


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 06/11/2019 à 13h40
Bonjour,

La connexion est faite par usb ?
   
CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 15/11/2019 à 08h55
Bonjour,
Oui connexion usb.
Pardon pour le délai de réponse mais j'ai été obligé de m'absenter.
PR


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
m@rco123 Membre non connecté

Rang

Avatar

Inscrit le : 15/05/2009 à 08h07

Localisation : Val d'Oise

Messages: 2892

Le 15/11/2019 à 09h35
Bonjour .
Tu es passé par hplip ?


Lenovo g70-70
cg intel 810 / ssd SanDisk 250Go
Mageia 7 plasma 64b

Packard Bell ls11hr
cg intel 810 / ssd SanDisk 128Go
Mageia 6 plasma 64b
   
CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 16/11/2019 à 08h39
Bonjour,
oui je suis passé par hplip dans le CCM.
PR


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 16/11/2019 à 09h07
Bonjour,

le paquet lib64sane-hpaio1 est installé ( si en 64 bits) ?

Est ce qu' un lsusb indique quelque chose ?

Le scanner n' est pas détecté y compris en root ( ou seulement en utilisateur normal) ? Dans ce cas, est ce que l' utilsateur est dans le groupe scanner ?
   
CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 16/11/2019 à 10h03
Bonjour,
lsusb:
Bus 002 Device 003: ID 03f0:7a11 HP, Inc Photosmart B109a-m

Le groupe scanner était vide, je me suis rajouté.

Je me logue en root pour les autres réponses

PR


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 16/11/2019 à 10h26
Bonjour,
en root le logiciel xsane ne trouve pas le scanner

lib64sane-hpaio1 est installé

PR


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 16/11/2019 à 12h23
Bonjour,

D' après ce que j' ai lu, la découverte du scanner se fait grâce à la ligne contenue dans le fichier de règle udev suivant:

/usr/lib/udev/rules.d/56-hpmud.rules

ATTR{idVendor}=="03f0", ENV{ID_USB_INTERFACES}=="*:0701??:*|*:ffcc00:", OWNER="root", GROUP="lp", MODE="0664", ENV{libsane_matched}="yes", ENV{hp_test}="yes", ENV{ID_HPLIP}="1"

Le fichier est il présent ( présent dans le fichier hplip-model-data) ? Remarque la présence dans le groupe scanner ne semble pas nécessaire ( plutôt le group lp))

Sinon est ce que le paquet sane-backends est aussi installé ?
   
CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 17/11/2019 à 09h44
Bonjour,
le groupe lp n'existe pas dans le système
sane-backends est bien installé

Dois-je créer le groupe "lp"?

Merci de vos réponses.

PR


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 17/11/2019 à 09h52
Le fichier /usr/lib/udev/rules.d/56-hpmud.rules existe bien

PR


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 17/11/2019 à 10h46
Bonjour,

Si le scanner n' est pas trouvé par xsane ( ou sane-find-scanner) en root, pour l' instant je pense que la création du groupe lp n' est pas nécessaire pour l' instant ( root étant propriétaire du périphérique éventuellement crée par la règle udev, le scanner devrait être trouvé dans tout les cas).

Que donne un sane-find-scanner ?
   
m@rco123 Membre non connecté

Rang

Avatar

Inscrit le : 15/05/2009 à 08h07

Localisation : Val d'Oise

Messages: 2892

Le 17/11/2019 à 10h55
bonjour .
En terminal, peux tu lancer la commande :
scanimage -L juste en user Edité par m@rco123 Le 17/11/2019 à 11h04


Lenovo g70-70
cg intel 810 / ssd SanDisk 250Go
Mageia 7 plasma 64b

Packard Bell ls11hr
cg intel 810 / ssd SanDisk 128Go
Mageia 6 plasma 64b
   
CatHare Membre non connecté

Rang

Avatar

Inscrit le : 24/12/2008 à 09h03

Localisation : Carcassonne Aude 11

Messages: 194

Le 19/11/2019 à 11h55
Bonjour,

@nic80:
found USB scanner (vendor=0x03f0 [HP], product=0x7a11 [Photosmart B109a-m]) at libusb:002:002
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

@m@arco:
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Merci à tous les deux

PR


Point n'est besoin d'espérer pour entreprendre ni de réussir pour persévérer :hello:
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6840

Le 19/11/2019 à 13h42
Hum, intéressant.
Le scanner est détecté, mais pas configuré.
D'après le site d'Ubuntu, l'installation du scanner scanner doit se faire en même temps que l'imprimante par hp-setup. Je te recommande de relancer cette étape.
https://doc.ubuntu-fr.org/hplip#installer_le_scanner_multifonctions
Quelques conseils de chez HP :
https://developers.hp.com/hp-linux-imaging-and-printing/KnowledgeBase/Troubleshooting/TroubleshootScanning


Yves
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie