Connexion

Forum

Logiciels » Autres logiciels [Réglé] Letsencrypt ne marche plus

xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 473

Le 06/10/2019 à 10h36
Bonjour,

Jusqu'à présent, je n'avais pas de problème pour utiliser Letsencrypt avec Mageia.
Je ne me rappelle pas si j'avais déjà utilisé letsencrypt avec Mageia 7 ou seulement avec Mageia6.
Je ne peux pas revenir à Mageia6 (trop de travail).
J'ai mon certificat qui expire dans 5 jours et j'ai l'erreur suivante :

Creating virtual environment...
Traceback (most recent call last):
File "<stdin>", line 27, in <module>
File "<stdin>", line 19, in create_venv
File "/usr/lib64/python2.7/subprocess.py", line 185, in check_call
retcode = call(*popenargs, **kwargs)
File "/usr/lib64/python2.7/subprocess.py", line 172, in call
return Popen(*popenargs, **kwargs).wait()
File "/usr/lib64/python2.7/subprocess.py", line 394, in __init__
errread, errwrite)
File "/usr/lib64/python2.7/subprocess.py", line 1047, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory

Revenir à une version antérieure de letsencrypt ne résoud pas le problème.

Quelqu'un peut-il m'aider ?

Merci.

Xuo.

PS : je lance la commande suivante :
letsencrypt-auto certonly --no-self-upgrade --no-bootstrap --debug --webroot --dry-run --text -d mondomaine.fr

--no-self-upgrade --no-bootstrap on été ajoutés pour essayer d'empêcher letsencrypt de se mettre à jour. Mais ça ne change rien. Le problème semble donc venir de Mageia.

Xuo. Edité par xuo Le 06/10/2019 à 10h45
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1430

Le 06/10/2019 à 11h16
Bonjour,

D' où vient le script letsencrypt-auto, je n' en ai pas trouvé trace dans les paquets Mageia.

Visiblement, il y a un fichier/chemin qui n' est pas trouvé par le script (OSError: [Errno 2] No such file or directory). Il reste à savoir lequel...

Après une recherche rapide, letsencrypt-auto semble être l' ancien nom de certbot. Est ce que l' on pourrait passer par les outils certbot ?

Edité par nic80 Le 06/10/2019 à 11h55
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 473

Le 06/10/2019 à 12h01
Bonjour,

Effectivement, je n'arrive pas à trouver quel fichier manque.
J'ai installé cerbot avec :
git clone https://github.com/certbot/certbot.git

Les scripts letsencrypt-auto et cerbot-auto sont identiques. Mon script utilise letsencrypt-auto. J'ai changé pour utiliser cerbot-auto mais ça ne change rien.
Et les logs ne sont même pas mis à jour. Le dernier date du 12/07, date de mon dernier certificat.

Il y a d'autres personnes qui utilisent letencrypt avec Mageia7 ?

Xuo. Edité par xuo Le 06/10/2019 à 12h03
   
gustine Membre non connecté

Rang

Avatar

Inscrit le : 26/09/2010 à 11h56

Localisation : 62 Liévin, France

Messages: 74

Le 06/10/2019 à 12h26
Hello,

Pour ma part, j'utilise acme.sh. Mais tous les 3 mois, je dois repasser sous Mageia 6 (que j'ai conservé en double boot) pour renouveler mon certificat.
J'ai comparé les deux installations sans trouver ce qui pourrait manquer à Mageia 7.


I7-8700 - UHD Graphics 630 - 2x8 MO - Mageia 7 - Mate - serveur LAMP.
Site web    
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1430

Le 06/10/2019 à 12h38
Bonjour,

Citation :
git clone h*tps://github.com/certbot/certbot.git


Pourquoi avoir utilisé le git de certbot ?

Il y a un paquet dans Mageia 7 ( qui je suppose devrait installer les dépendances python3 nécessaires)...

Citation :
J'ai comparé les deux installations sans trouver ce qui pourrait manquer à Mageia 7


Les logs ne sont pas parlants ( par exemple en remplaçant la ligne 113 par SYSLOG_LEVEL_DEFAULT=9 et la ligne 83 par DEFAULT_LOG_LEVEL=3 et la ligne 90 par DEBUG_LEVEL_DEFAULT=3) ? ;-) Edité par nic80 Le 06/10/2019 à 14h02
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 473

Le 06/10/2019 à 13h54
Bonjour,

@gustine : je n'ai pas gardé de version Mageia6 de mon serveur. Ca va être compliqué de repasser en Mageia6. C'est mon dernier choix.
@nic80 : J'ai cherché un letsencrypt et un cerbot dans les dépots mais je n'ai rien trouvé. Vous êtes sûr qu'il y en a un ?

Xuo.

EDIT : je me fais avoir à chaque fois. Il faut chercher certbot et pas cerbot !!! J'essaye avec la version des dépôts de Mageia. Edité par xuo Le 06/10/2019 à 13h56
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 473

Le 06/10/2019 à 14h17
Bonjour,

Tout s'est bien passé avec la version de cerTbot des dépôts de Mageia7.
Merci à tous pour votre aide. Je vais passer un meilleur week-end :hehe:

Xuo.
   
Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 1868

Le 06/10/2019 à 14h40
:resolu:
   
gustine Membre non connecté

Rang

Avatar

Inscrit le : 26/09/2010 à 11h56

Localisation : 62 Liévin, France

Messages: 74

Le 06/10/2019 à 17h21
:magic: Je ne sais pas pourquoi mais cette fois, j'ai renouvelé mon certificat sans plantage et sans passer par Mageia 6...
Au cours des trois derniers mois, il y a dû y avoir une mise à jour qui a résolu le problème.

En fait, le changement doit être plus récent puisque le 1er octobre à 4h02, j'ai eu la bonne surprise de ne pas avoir de Segmentation fault contrairement aux mois précédents.

Bref, tout baigne. Viva Mageia ! Edité par gustine Le 06/10/2019 à 17h24


I7-8700 - UHD Graphics 630 - 2x8 MO - Mageia 7 - Mate - serveur LAMP.
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie