Connexion

Forum

Logiciels » Bureautique Installation LibreOffice 6.3 - info utile Changement de commande

Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 863

Le 11/09/2019 à 14h38
Bonjour tout le monde,

pour les ceusses et les celles qui aiment bien avoir la dernière version de LibreOffice d'installé, je signale que les commandes ont changé avec la 6.3.

Avant il fallait faire :
Code :
urpmi *.rpm


Maintenant, on doit utiliser la commande :
Code :
 sudo urpmi *.rpm


Dans les deux cas, on doit supprimer la version de la TDF avec un
Code :
urpme -a libreoffice


en saisissant le numéro de la version de LibreOffice juste après libreoffice (pas d'espace entre les deux).

Voilà. J'espère que vous perdrez moins de temps que moi. :magic:

Page du wiki de mlo modifiée. Edité par Ysabeau Le 11/09/2019 à 14h56


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1603

Le 11/09/2019 à 17h03
Heu... Sudo n'est pas installé par défaut.
De plus, il faut aussi placer l'utilisateur "normal" comme administrateur en l'ajoutant dans le groupe wheel (il me semble).

Tu es sûr qu'il faille faire ça pour utiliser urpmi ?
Je ne comprends vraiment pas ce qui diffère, les nuances et surtout je ne comprends pas pourquoi urpmi en root échouerait par rapport à un utilisateur avec des droits administrateur (mais n'étant pas root) en utilisant sudo.

(et de manière général, je déteste sudo, donc il fallait que je l'écrive.)
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 863

Le 11/09/2019 à 17h57
Jybz :
Tu es sûr qu'il faille faire ça pour utiliser urpmi ?
Je ne comprends vraiment pas ce qui diffère, les nuances et surtout je ne comprends pas pourquoi urpmi en root échouerait par rapport à un utilisateur avec des droits administrateur (mais n'étant pas root) en utilisant sudo.

(et de manière général, je déteste sudo, donc il fallait que je l'écrive.)


Ben j'ai passé une ou deux heures à ne pas pouvoir installer LibreOffice pour cause de paquets pas reconnus ! Avec sudo en cinq minutes c'était fait. Et j'étais bien en root quand j'ai essayé sans sudo et avec. Et, non je ne sais pas pourquoi mais c’est comme ça. En fait j'ai vu apparaître un fichier install (et même un readme d'ailleurs) qui n'existait pas avant dans les paquets LibreOffice.



OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6425

Le 11/09/2019 à 19h55
Si tu faisais su - pour devenir root, alors tu changes de répertoire. Dans ce cas, urpmi *.rpm ne trouve plus les fichiers que tu as stockés, alors que avec le sudo, tu ne changes pas de répertoire et ils sont trouvés.


Yves
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 863

Le 12/09/2019 à 09h19
J'ai toujours procédé comme suit :

  • téléchargement et décompression des paquets
  • clic droit sur le fichier rpms -> ouvrir un terminal ici
  • su puis mot de passe
  • urpmi *.rpm

Jusque là ça a toujours fonctionné. Là j'ai fait pareil, mais dû faire sudo urpmi *.rpm pour que ça s'installe. J'avais même installé la première 6.3 sans problème et sans sudo. Mais les suivantes, impossible. Edité par Ysabeau Le 12/09/2019 à 09h19


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1603

Le 12/09/2019 à 10h55
su tiret_du_six
As tu testé ?
   
stroibe974 Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 13/08/2018 à 16h22

Localisation : Réunion

Messages: 941

Le 12/09/2019 à 20h30
Jybz :
su tiret_du_six
As tu testé ?


C'est ce qu'il ne faut pas faire, justement, non ?

Code :
su -

va conduire directement dans le /home de root, et du coup le RPM à installer ne sera pas trouvé par la commande
Code :
urpmi *.rpm


Alors que, à l'inverse, la commande
Code :
su

te laisse dans le répertoire courant, où le RPM devrait se trouver.


Mageia 7 (64bits) - Plasma - Intel Core i7-8700K @ 3.70Ghz - 16Go RAM
frenchmageiauser_9c2c8
   
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1603

Le 12/09/2019 à 21h03
Certes il ne trouvera pas le RPM qui est situé dans /home/utilisateur/téléchargements, mais rien ne t'empêche d'y aller avec la commande "Change Directory" cd.
Code BASH :
cd /home/utilisateur/Téléchargements/

Il n'y a pas que le répertoire qui change, mais aussi les variables d'environnements !
Par exemple :
Code BASH :
su
<mdp>
echo ${USER}
exit
su -
<mdp>
echo ${USER}

H'et oui !
Le résultat n'est pas le même !
   
Yuusha Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2017 à 19h52

Localisation : Gironde

Messages: 346

Le 12/09/2019 à 23h37
Jybz :
Heu... Sudo n'est pas installé par défaut.
De plus, il faut aussi placer l'utilisateur "normal" comme administrateur en l'ajoutant dans le groupe wheel (il me semble).

pas forcément dans le groupe wheel. Celui-ci donne tous les droits d'administrations mais il est possible de ne donner à l'utilisateur que certains droits spécifiques. C'est la force de sudo (outre le fait qu'il m'empêche de laisser mon PC allumé avec un terminal root ouvert :mdr2: ). Il faut modifier le fichier /etc/sudoers pour gérer les droits. Celui-ci ne doit être modifié qu'avec visudo afin d'éviter d'avoir un fichier erroné.
sudo a ses défauts mais il est bien pratique nottament lorsqu'un programme vient avec énormément de fichiers de configurations et de variables d’environnement. Cela évite de faire la configuration 2 fois : une fois pour root et une fois pour chaque utilisateur (sinon on peut utiliser les modules mais c'est une autre histoire :hehe: ).
   
DéBé Membre non connecté

Rang

Avatar

Inscrit le : 30/01/2010 à 14h07

Localisation : Finistère

Messages: 1236

Le 13/09/2019 à 08h47
Yuusha :
Il faut modifier le fichier /etc/sudoers pour gérer les droits. Celui-ci ne doit être modifié qu'avec visudo afin d'éviter d'avoir un fichier erroné.
.


:blub: pourquoi faire si simple..... Je n'aime pas beaucoup sudo non plus, mais encore moins vi ......


Desktop :Mageia 7 x86-64 Plasma 5 - GeForce N210 Pilote Nouveau - Ram 4096 Mb - AMD Athlon 64 X2 Dual Core Processor 4800+ / Notebook Asus F200M Emmabuntüs DE2 XFCE4
   
Yuusha Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2017 à 19h52

Localisation : Gironde

Messages: 346

Le 13/09/2019 à 09h01
DéBé :
:blub: pourquoi faire si simple..... Je n'aime pas beaucoup sudo non plus, mais encore moins vi ......

C'est une protection pour éviter de se retrouver avec un fichier erroné qui rendrait le PC complètement inutilisable. Je trouve au contraire qu'il s'agit d'une bonne idée. Cela évite à l'administrateur de faire n'importe quoi.
   
DéBé Membre non connecté

Rang

Avatar

Inscrit le : 30/01/2010 à 14h07

Localisation : Finistère

Messages: 1236

Le 13/09/2019 à 09h25
Vu mon faible niveau dans l'utilisation de vi, c'est là que je risque de faire "n'importe quoi" :mrgreene:


Desktop :Mageia 7 x86-64 Plasma 5 - GeForce N210 Pilote Nouveau - Ram 4096 Mb - AMD Athlon 64 X2 Dual Core Processor 4800+ / Notebook Asus F200M Emmabuntüs DE2 XFCE4
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 863

Le 13/09/2019 à 10h44
J'avoue que je ne comprends pas grand chose à vos ratiocinations :désolé1: mais je précise que je n'ai pas installé ni paramétré ni quoi que ce soit sudo. J'ai entré la commande sans me poser de question et ça a installé LibreOffice 6.3 qui ne pouvait pas s'installer autrement.

Donc voilà.


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1603

Le 13/09/2019 à 11h04
Bien, j'ai voulu voir où était le problème, alors j'ai commencé par installé par un simple su (sans su -), et... Je n'ai pas trouvé d'erreur. C'est normal que tout ce passe bien ?
Code BASH :
44%[10:02:10][jybz@localhost RPMS (master)]$ su
Mot de passe : 
44%[10:02:27][root@localhost RPMS]$ urpmi /home/jybz/Téléchargements/LibreOffice_6.3.1.2_Linux_x86-64_rpm/RPMS/*.rpm

Code BASH :
 
SECURITÉ : Les paquetages suivants ne sont _PAS_ signés (OK ((none))) : /home/jybz/Téléchargements/LibreOffice_6.3.1.2_Linux_x86-64_rpm/RPMS/libobasis6.3-extension-mediawiki-publisher-6.3.1.2-2.x86_64.rpm
Code BASH :
 
Code BASH :
 
installation de libobasis6.3-extension-mediawiki-publisher-6.3.1.2-2.x86_64.rpm libobasis6.3-writer-6.3.1.2-2.x86_64.rpm libobasis6.3-kde-integration-6.3.1.2-2.x86_64.rpm libobasis6.3-onlineupdate-6.3.1.2-2.x86_64.rpm libobasis6.3-pyuno-6.3.1.2-2.x86_64.rpm libobasis6.3-librelogo-6.3.1.2-2.x86_64.rpm libreoffice6.3-calc-6.3.1.2-2.x86_64.rpm libobasis6.3-extension-javascript-script-provider-6.3.1.2-2.x86_64.rpm libobasis6.3-firebird-6.3.1.2-2.x86_64.rpm libobasis6.3-xsltfilter-6.3.1.2-2.x86_64.rpm libobasis6.3-ooofonts-6.3.1.2-2.x86_64.rpm libobasis6.3-math-6.3.1.2-2.x86_64.rpm libobasis6.3-extension-beanshell-script-provider-6.3.1.2-2.x86_64.rpm libobasis6.3-en-US-6.3.1.2-2.x86_64.rpm libobasis6.3-ogltrans-6.3.1.2-2.x86_64.rpm libobasis6.3-extension-nlpsolver-6.3.1.2-2.x86_64.rpm libobasis6.3-gnome-integration-6.3.1.2-2.x86_64.rpm libobasis6.3-draw-6.3.1.2-2.x86_64.rpm libobasis6.3-extension-pdf-import-6.3.1.2-2.x86_64.rpm libreoffice6.3-base-6.3.1.2-2.x86_64.rpm libobasis6.3-extension-report-builder-6.3.1.2-2.x86_64.rpm libobasis6.3-libreofficekit-data-6.3.1.2-2.x86_64.rpm libreoffice6.3-dict-en-6.3.1.2-2.x86_64.rpm libreoffice6.3-6.3.1.2-2.x86_64.rpm libobasis6.3-calc-6.3.1.2-2.x86_64.rpm libreoffice6.3-impress-6.3.1.2-2.x86_64.rpm libreoffice6.3-math-6.3.1.2-2.x86_64.rpm libreoffice6.3-ure-6.3.1.2-2.x86_64.rpm libreoffice6.3-dict-es-6.3.1.2-2.x86_64.rpm libobasis6.3-base-6.3.1.2-2.x86_64.rpm libreoffice6.3-freedesktop-menus-6.3.1-2.noarch.rpm libobasis6.3-python-script-provider-6.3.1.2-2.x86_64.rpm libobasis6.3-postgresql-sdbc-6.3.1.2-2.x86_64.rpm libobasis6.3-core-6.3.1.2-2.x86_64.rpm libobasis6.3-graphicfilter-6.3.1.2-2.x86_64.rpm libreoffice6.3-dict-fr-6.3.1.2-2.x86_64.rpm libreoffice6.3-draw-6.3.1.2-2.x86_64.rpm libobasis6.3-images-6.3.1.2-2.x86_64.rpm libobasis6.3-impress-6.3.1.2-2.x86_64.rpm libreoffice6.3-writer-6.3.1.2-2.x86_64.rpm libreoffice6.3-en-US-6.3.1.2-2.x86_64.rpm libobasis6.3-ooolinguistic-6.3.1.2-2.x86_64.rpm depuis /home/jybz/Téléchargements/LibreOffice_6.3.1.2_Linux_x86-64_rpm/RPMS
Préparation...                   #####################################################################################################################################
     1/42: libreoffice6.3-ure    #####################################################################################################################################
     2/42: libobasis6.3-ooofonts #####################################################################################################################################
     3/42: libobasis6.3-core     #####################################################################################################################################
     4/42: libobasis6.3-writer   #####################################################################################################################################
     5/42: libobasis6.3-base     #####################################################################################################################################
     6/42: libobasis6.3-impress  #####################################################################################################################################
     7/42: libobasis6.3-pyuno    #####################################################################################################################################
     8/42: libobasis6.3-math     #####################################################################################################################################
     9/42: libobasis6.3-en-US    #####################################################################################################################################
    10/42: libobasis6.3-draw     #####################################################################################################################################
    11/42: libobasis6.3-calc     #####################################################################################################################################
    12/42: libobasis6.3-images   #####################################################################################################################################
    13/42: libreoffice6.3        #####################################################################################################################################
    14/42: libreoffice6.3-calc   #####################################################################################################################################
    15/42: libreoffice6.3-base   #####################################################################################################################################
    16/42: libreoffice6.3-dict-en
                                 #####################################################################################################################################
    17/42: libreoffice6.3-impress
                                 #####################################################################################################################################
    18/42: libreoffice6.3-math   #####################################################################################################################################
    19/42: libreoffice6.3-dict-es
                                 #####################################################################################################################################
    20/42: libreoffice6.3-dict-fr
                                 #####################################################################################################################################
    21/42: libreoffice6.3-draw   #####################################################################################################################################
    22/42: libreoffice6.3-writer #####################################################################################################################################
    23/42: libreoffice6.3-en-US  #####################################################################################################################################
    24/42: libobasis6.3-librelogo
                                 #####################################################################################################################################
    25/42: libobasis6.3-ogltrans #####################################################################################################################################
    26/42: libobasis6.3-postgresql-sdbc
                                 #####################################################################################################################################
    27/42: libobasis6.3-extension-mediawiki-publisher
                                 #####################################################################################################################################
    28/42: libobasis6.3-kde-integration
                                 #####################################################################################################################################
    29/42: libobasis6.3-onlineupdate
                                 #####################################################################################################################################
    30/42: libobasis6.3-extension-javascript-script-provider
                                 #####################################################################################################################################
    31/42: libobasis6.3-firebird #####################################################################################################################################
    32/42: libobasis6.3-xsltfilter
                                 #####################################################################################################################################
    33/42: libobasis6.3-extension-beanshell-script-provider
                                 #####################################################################################################################################
    34/42: libobasis6.3-extension-nlpsolver
                                 #####################################################################################################################################
    35/42: libobasis6.3-gnome-integration
                                 #####################################################################################################################################
    36/42: libobasis6.3-extension-pdf-import
                                 #####################################################################################################################################
    37/42: libobasis6.3-extension-report-builder
                                 #####################################################################################################################################
    38/42: libobasis6.3-libreofficekit-data
                                 #####################################################################################################################################
    39/42: libobasis6.3-python-script-provider
                                 #####################################################################################################################################
    40/42: libobasis6.3-graphicfilter
                                 #####################################################################################################################################
    41/42: libobasis6.3-ooolinguistic
                                 #####################################################################################################################################
    42/42: libreoffice6.3-freedesktop-menus
                                 #####################################################################################################################################
/bin/update-desktop-database
/bin/update-mime-database
mkdir: impossible de créer le répertoire « /usr/share/icons/hicolor/icon-theme.cache »: N'est pas un dossier
mkdir: impossible de créer le répertoire « /usr/share/icons/hicolor/index.theme »: N'est pas un dossier
/bin/gtk-update-icon-cache
/bin/update-desktop-database
/bin/update-desktop-database
43%[10:02:55][root@localhost RPMS]$ 
 
Edité par Jybz Le 13/09/2019 à 11h06
   
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1603

Le 13/09/2019 à 11h12
pour les supprimer, la commande que j'ai tapé dans le dossier contenant les rpm téléchargés :
Code BASH :
$ urpme $(ls ./*rpm | sed -e "s/\.rpm$//g" -e "s/^\.\///g")
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie