Connexion

Forum

Logiciels » Autres logiciels [Résolu] Anki ne démarre plus Le logiciel Anki ne démarre plus

Sondage: -
0.0% - [0 Vote]
0.0%
Largo43 Membre non connecté

Rang

Avatar

Inscrit le : 05/06/2008 à 23h16

Localisation : LYON

Messages: 97

Le 20/08/2019 à 19h18
Bonjour

Depuis aujourd’hui, le logiciel Anki ne démarre plus et j'ai la fenêtre suivante qui s'ouvre :

Startup Error
Please notify support of this error:
Traceback (most recent call last):
File "/usr/share/anki/aqt/__init__.py", line 194, in run run()
File "/usr/share/anki/aqt/__init__.py", line 246, in _run pm = ProfileManager(opts.base, opts.profile)
File "/usr/share/anki/aqt/profiles.py", line 73, in _init_ self.maybeMigrateFolder()
File "/usr/share/anki/aqt/profiles.py", line 125, in maybeMigrateFolder oldBase = self. oldFolderLocation()
File "/usr/share/anki/aqt/profiles.py", line 122, in _oldFolderLocation return os.path.join(loc, "Anki")
File "/usr/1ib64/python2.7/posixpath.py", line 70, in join elif path == " or path.endswith('/'):
AttributeError: 'QString' object has no attribute 'endswith'


Je fais OK et rien ne se passe.

J'ai essayé de désinstaller et de réinstaller

J'ai essayé de renommer le dossier usr/share/anki pour qu'il s'en créé un propre au lancement.

Rien n'y fait... :nono:

Quelqu'un aurait une idée de la marche à suivre ?

Merci de votre aide. :D

(Je suis sous Mageia 7 64bits, bureau KDE avec tous les paquets à jour) Edité par Largo43 Le 08/09/2019 à 20h02
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1526

Le 20/08/2019 à 19h59
Bonjour,

Je pense qu' il s' agit d' un problème de python.

Cette partie me fait penser que quelque chose a du changer dans python..

Code PYTHON :
"/usr/1ib64/python2.7/posixpath.py", line 70, in join elif path == " or path.endswith('/'):
AttributeError: 'QString' object has no attribute 'endswith'


Il y a eu une mise à jour de Python ?
Edité par nic80 Le 20/08/2019 à 19h59
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6822

Le 20/08/2019 à 21h16
Il faudrait passer à la version 2.1, c'est ce qu'a fait Fedora, pour la même erreur.
https://bugzilla.redhat.com/show_bug.cgi?id=1701691
Donc ouvrir un rapport de bug...


Yves
   
Largo43 Membre non connecté

Rang

Avatar

Inscrit le : 05/06/2008 à 23h16

Localisation : LYON

Messages: 97

Le 21/08/2019 à 23h08
Bonjour

Merci à tous pour votre aide.

nic80 :
Il y a eu une mise à jour de Python ?

Il semble que la dernière mise à jour de Python date de mai 2019. J’aurais donc tendance à dire que cela ne vient pas de là.

Papoteur :
Il faudrait passer à la version 2.1, c'est ce qu'a fait Fedora, pour la même erreur.
https://bugzilla.redhat.com/show_bug.cgi?id=1701691
Donc ouvrir un rapport de bug...


J'ai fait un rapport de bug en m'inspirant de celui de Fedora : https://bugs.mageia.org/show_bug.cgi?id=25339

J'espère que cela permettra d'accélérer le passage à la version 2.1 ...
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6822

Le 22/08/2019 à 07h38
Merci.


Yves
   
david.david Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 11/02/2008 à 23h08

Localisation : Bernwiller, Haut-Rhin

Messages: 2622

Le 25/08/2019 à 16h57
Voilà anki 2.1.15 est disponible dans Core/Updates_testing !


ASUS K73S (portable) :
Intel Core i3-2350M_2.3GHz, 8 GO RAM DDR3, écran LED 17" (1600x900), CG Intel HD intégrée + CG Nvidia GeForce 610M_1GB dédiée (Technologie Optimus), SSD Samsung 850 EVO 250GB + SSD Samsung 850 EVO 500GB.

Mageia 7 - x86_64bits/ KDE Plasma-5.15.4 (DVD édition), c' est de la bombe, vive MAGEIA et toute l'équipe du STAFF MLO.
de david.david <david.david@mageialinux-online.org>
28281 .Venez nous rejoindre sur le salon IRC de MLO
   
Largo43 Membre non connecté

Rang

Avatar

Inscrit le : 05/06/2008 à 23h16

Localisation : LYON

Messages: 97

Le 08/09/2019 à 20h03
Merci ::d

J'ai eu la mise à jour aujourd'hui. Tout fonctionne !
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie