Connexion

Forum

Système et matériels » Installation et configuration samba et pare-feu sur mageia 7 le pare-feu même en cochant partage de fichier windows smb bloque nautilus

domchab Membre non connecté

Rang

Avatar

Inscrit le : 07/07/2011 à 20h43

Localisation : Camboulazet

Messages: 111

Le 19/08/2019 à 19h43
bonjour

J'utilise samba pour partager des repertoires et avoir accès à un serveur NAS sous Raspbian. Sur 2 machines sous mageia 7 il me faut désactiver complètement le pare-feu pour pouvoir accès aux autres serveurs. Si j'active le pare-feu même en cochant "partage de fichiers windows smb", nautilus (je suis sous gnome) ne "voit pas" les serveurs dans le reseau.
Je peux par contre monter les serveurs en ligne de commande ou en renseignant le champ "saisir l'adresse du serveur" de nautilus avec l'adresse smb://192.168.... du serveur à joindre. Il s'agit donc seulement de l'affichage dans nautilus qui est défaillant.
J'ai par ailleurs limité samba avec max protocole = SMB3_10 (dans le smb.conf) car le protocole 3_11 me pose encore plus de problèmes.
Avez vous une idée de ce qui empêche nautilus de travailler correctement avec samba?

merci d'avance de toutes vos suggestions
   
gustine Membre non connecté

Rang

Avatar

Inscrit le : 26/09/2010 à 11h56

Localisation : 62 Liévin, France

Messages: 74

Le 19/08/2019 à 20h04
Bonjour,
As-tu activé aussi le service nmb en plus du service smb ?


I7-8700 - UHD Graphics 630 - 2x8 MO - Mageia 7 - Mate - serveur LAMP.
Site web    
domchab Membre non connecté

Rang

Avatar

Inscrit le : 07/07/2011 à 20h43

Localisation : Camboulazet

Messages: 111

Le 19/08/2019 à 20h41
oui nmb est activé
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6724

Le 19/08/2019 à 21h20
Peut-être faut-il installer gvfs-smb ?


Yves
   
domchab Membre non connecté

Rang

Avatar

Inscrit le : 07/07/2011 à 20h43

Localisation : Camboulazet

Messages: 111

Le 19/08/2019 à 21h48
il est installé aussi.
quand je désactive le pare-feu je vois mes serveurs et quand je le remet ils disparaissent. C'est magique tant que je ne sais pas pourquoi, ou plutôt quel port mysterieux est utilisé par le couple nautilus samba.
   
Visiteur

Visiteur

Rang

Avatar

Message : 0

Le 13/10/2019 à 09h12
Même symptômes chez moi.

Mais je n'arrive toujours pas à accéder à ces partages, samba me demande de m'authentifier, même si j'ai spécifié dans le partage un accès public.
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie