Connexion

Forum

Packaging Ajouter OnlyOffice Desktop editor Suite bureautique

Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 838

Le 06/08/2019 à 14h44

Reprise du message précédent

Ouaip.

Cela dit, le document qui m'avait été soumis et qui pose un problème de compatibilité a des problèmes comparables au même endroit avec Onlyoffice.


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1481

Le 06/08/2019 à 14h45
Tentative de compilation :
Caché :


Code BASH :
 
cd ~/outils/
git clone --recursive https://github.com/ONLYOFFICE/DesktopEditors
make
[...]
g++: error: /home/jibz/outils/DesktopEditors/core/Common/3dParty/icu/linux_64/build/libicuuc.so.58: Aucun fichier ou dossier de ce type
g++: error: /home/jibz/outils/DesktopEditors/core/Common/3dParty/icu/linux_64/build/libicudata.so.58: Aucun fichier ou dossier de ce type
[...]
cd Common/3dParty/icu/
cat build.sh 
cat fetch.sh
./fetch.sh
cd ../../../
make
[...]
In file included from ../../DesktopEditor/xml/build/qt/libxml2_all.c:1:
../../DesktopEditor/xml/build/qt/../../libxml2/buf.c:15: warning: « IN_LIBXML » redéfini
 #define IN_LIBXML
 
<ligne-de-commande>: note: ceci est l'emplacement d’une précédente définition
In file included from ../../DesktopEditor/xml/build/qt/libxml2_all.c:1:
../../DesktopEditor/xml/build/qt/../../libxml2/buf.c: Dans la fonction « xmlBufMemoryError »:
../../DesktopEditor/xml/build/qt/../../libxml2/buf.c:94:5: warning: trop d'arguments pour le format [-Wformat-extra-args]
     __xmlSimpleError(XML_FROM_BUFFER, XML_ERR_NO_MEMORY, NULL, NULL, extra);
     ^~~~~~~~~~~~~~~~
../../DesktopEditor/xml/build/qt/../../libxml2/buf.c: Dans la fonction « xmlBufOverflowError »:
../../DesktopEditor/xml/build/qt/../../libxml2/buf.c:109:5: warning: trop d'arguments pour le format [-Wformat-extra-args]
     __xmlSimpleError(XML_FROM_BUFFER, XML_BUF_OVERFLOW, NULL, NULL, extra);
     ^~~~~~~~~~~~~~~~
In file included from ../../DesktopEditor/xml/build/qt/../../libxml2/c14n.c:2237,
                 from ../../DesktopEditor/xml/build/qt/libxml2_all.c:2:
../../DesktopEditor/xml/build/qt/../../libxml2/elfgcchack.h: Au plus haut niveau:
../../DesktopEditor/xml/build/qt/../../libxml2/elfgcchack.h:1348:33: error: redéfinition de « xmlBufContent »
 extern __typeof (xmlBufContent) xmlBufContent __attribute((alias("xmlBufContent__internal_alias")));
                                 ^~~~~~~~~~~~~
In file included from ../../DesktopEditor/xml/build/qt/../../libxml2/buf.c:1345,
                 from ../../DesktopEditor/xml/build/qt/libxml2_all.c:1:
../../DesktopEditor/xml/build/qt/../../libxml2/elfgcchack.h:1348:33: note: la définition précédente de « xmlBufContent » était ici
 extern __typeof (xmlBufContent) xmlBufContent __attribute((alias("xmlBufContent__internal_alias")));
                                 ^~~~~~~~~~~~~
In file included from ../../DesktopEditor/xml/build/qt/../../libxml2/c14n.c:2237,
                 from ../../DesktopEditor/xml/build/qt/libxml2_all.c:2:
../../DesktopEditor/xml/build/qt/../../libxml2/elfgcchack.h:1358:29: error: redéfinition de « xmlBufEnd »
 extern __typeof (xmlBufEnd) xmlBufEnd __attribute((alias("xmlBufEnd__internal_alias")));
                             ^~~~~~~~~
In file included from ../../DesktopEditor/xml/build/qt/../../libxml2/buf.c:1345,
                 from ../../DesktopEditor/xml/build/qt/libxml2_all.c:1:
../../DesktopEditor/xml/build/qt/../../libxml2/elfgcchack.h:1358:29: note: la définition précédente de « xmlBufEnd » était ici
 extern __typeof (xmlBufEnd) xmlBufEnd __attribute((alias("xmlBufEnd__internal_alias")));
                             ^~~~~~~~~
[...]

Avec plus de 77000 ligne comme les dernières qui se répètent, en gros, tout est redéfini... Je suis momentanément bloqué, juste pour core. Et a aucun moment il explique comment on s'y prendre pour compiler leur truc ^^
   
bernado82 Membre non connecté

Rang

Avatar

Inscrit le : 02/09/2017 à 08h34

Localisation : /home

Messages: 24

Le 06/08/2019 à 18h25
Bonjour,

Pour ma part, moi aussi j'ai renoncé à l'installation de la version RPM d'OnlyOffice Desktop Editors sur openSuse. Sur Leap 15.0/15.1 (j'ai pas testé sur Tumbleweed) , le programme marchait (bien qu'étaient indiqués des problèmes de dépendance de librairies) mais c'est juste qu'ensuite, était systématiquement resignalé ce problème à chaque nouvelle installation de paquets par YaST, donc au final, l'utilisation du RPM était possible mais juste agaçant par la suite... Le RPM n'est annoncé que compatible avec Redhat et dérivées (Fedora/CentOS), les autres distros RPM se trouvant confrontées à des librairies pas toujours nommées pareil.

Il faut donc faire comme suggéré par l'éditeur et installer la version AppImage d'OnlyOffice Desktop Editors. Certes, un Snap est aussi proposé... Je l'ai testé et le problème avec c'était qu'une partie des polices installées sur le système n'était pas accessible dans l'application, c'est ce que j'avais constaté.

@Ysabeau

Outre LibreOffice, d'autres Suites bureautiques sont accessibles aux Linuxiens, même si aucune n'est aussi complète que celle-ci...

Pour la compatibilité "pure" avec les documents issus de Microsoft Office, s'il y a échec avec LibreOffice et OnlyOffice, alors on peut en tenter l'ouverture avec SoftMaker FreeOffice 2018 (la nouvelle "égérie" bureautique (contestée?) de Manjaro) ou WPS Office 2019. Edité par bernado82 Le 07/08/2019 à 09h45


Utilitaires pour tablettes avec SoC Rockchip:
https://www.mediafire.com/folder/2x89dia7hud7h/Rockchip_Tools ou https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ
Les outils Rockchip sont parfois "moches", voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip
Facebook    
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 838

Le 06/08/2019 à 20h26
bernado82 :
Pour la compatibilité "pure" avec les documents issus de Microsoft Office, s'il y a échec avec LibreOffice et OnlyOffice, alors on peut en tenter l'ouverture avec SoftMaker FreeOffice 2018 (la nouvelle "égérie" bureautique (contestée?) de Manjaro) ou WPS Office 2019.


Merci. Le truc qui foirait dans LibreOffice et Onlyoffice est correct dans WPS Office à qui je reproche d'avoir ajouté des icônes sur mon bureau.

Cela dit j'ai encore un PC sous Windows avec MSOffice 2016 :-), mais il est terriblement lent et je ne m'en sers plus guère (quasiment jamais).


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 838

Le 07/08/2019 à 15h32
Et un autre truc que je reproche à WPS Office c'est de décider qu'il doit ouvrir les pdf en lieu et place de mon logiciel préféré (Okular en l'espèce) et ça ne me plait pas du tout.

Pas que les pdf. Du coup je dois reconfigurer les associations de fichiers.
Edité par Ysabeau Le 07/08/2019 à 15h34


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 838

Le 09/08/2019 à 14h59
J'ai aussi fini par installer FreeOffice. Là encore, le paquet rpm n'était pas utilisable. J'ai donc récupéré le paquet .tgz et suis passée par les opérations habituelles pour l'installer (en passant par la console donc). FreeOffice traite aussi mieux le truc qui foirait dans LibreOffice et Onlyoffice, mais il y a des trucs qui clochent ailleurs :-).


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1481

Le 09/08/2019 à 15h17
Ysabeau :
FreeOffice traite aussi mieux le truc qui foirait dans LibreOffice et Onlyoffice, mais il y a des trucs qui clochent ailleurs :-).

la licence ? :troll:
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 838

Le 09/08/2019 à 15h30
Jybz :
la licence ? :troll:


:hehe:


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 838

Le 15/08/2019 à 18h40
N'installez pas WPS Office, c'est pas très performant, en anglais, envahissant et pénible à désinstaller.

Il faut :

  1. renommer le dossier en calligramme chinois du dossier personnel, par exemple en wpsoffice ;
  2. en ligne de commande, faire
    Code :
    urpme wps-office
    pour trouver les paquets, il y en a deux (ici : wps-office-11.1.0.8722-1.x86_64 et lib64wps0.4_4-0.4.10-2.mga7.x86_64) ;
  3. supprimer les deux paquets l'un après l'autre avec la commande
    Code :
    urpme a-
    suivie du nom du paquet ;
  4. entrer dans le dossier qu'on a renommé, wpsoffice ici;
  5. supprimer les fichier,
    Code :
     rm -f *.*
  6. remonter et supprimer le dossier wspoffice,
    Code :
    rmdir wpsoffice


Et on est enfin débarrassé de cette cochonnerie. Edité par Ysabeau Le 15/08/2019 à 18h40


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 838

Le 16/08/2019 à 15h40
Je continue mes expériences et mes comptes-rendus.

Pour supprimer Freeoffice il faut aller dans usr/bin où se trouve le fichier uninstall_smfreeoffice2018. Et, dans la console, saisir uninstall_smfreeoffice2018.

Voilà, je suis débarrassée de cette cochonnerie aussi.


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie