Connexion

Forum

Système et matériels » Autres matériels et périphériques Library Recherche de librairie

saroyan Membre non connecté

Rang

Avatar

Inscrit le : 26/09/2011 à 11h28

Localisation : Nouvelle Aquitaire

Messages: 101

Le 01/08/2019 à 19h28
Bonjour,

J'ai ma messagerie sous Protonmail et pour pouvoir l'utiliser sous Linux il faut installer un logiciel "Bridge".

Celui-ci demande un nombre important de librairie car mon PC ne possède pas.
.
Existe t-il un packetage avec des librairies et si oui comment les récupérer.

libQtGui.so.5
Libc.so.6
lib64xcrypt1
qt5-qtdeclarative
libQtCore.so.5
libQt5test.so.5
Qtbase5-commun.5.4.2
etc...

Merci par avance de votre aide,

Cdlt


Je fais ce que je peux avec ce que j'ai.
Mageia 6
KDE
64 bits
8 Go de Ram
Site web    
m@rco123 Membre non connecté

Rang

Avatar

Inscrit le : 15/05/2009 à 08h07

Localisation : Val d'Oise

Messages: 2845

Le 01/08/2019 à 19h58
en tapant qt dans le ccm tu dois pouvoir trouver ce qui t’intéresse ...
du qt5 devel ou autres ?


Lenovo g70-70
cg intel 810 / ssd SanDisk 250Go
Mageia 7 plasma 64b

Packard Bell ls11hr
cg intel 810 / ssd SanDisk 128Go
Mageia 6 plasma 64b
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6708

Le 01/08/2019 à 20h34
saroyan :
Bonjour,

J'ai ma messagerie sous Protonmail et pour pouvoir l'utiliser sous Linux il faut installer un logiciel "Bridge".

Celui-ci demande un nombre important de librairie car mon PC ne possède pas.
.
Existe t-il un packetage avec des librairies et si oui comment les récupérer.

libQtGui.so.5
Libc.so.6
lib64xcrypt1
qt5-qtdeclarative
libQtCore.so.5
libQt5test.so.5
Qtbase5-commun.5.4.2
etc...

Merci par avance de votre aide,

Cdlt

Bonjour,
Un programme de ce type est compilé pour une plateforme. Quelle est-elle ? Il y a une chance infime pour que cela fonctionne sur Mageia.
Qu'est-ce qui est fourni ? Un rpm, une archive ? Il faudrait un Flatpack. On a par exemple du Qt 5.12, et là il cherche du 5.4.


Yves
   
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 530

Le 03/08/2019 à 06h06
urpmf libQtGui.so.5

ça doit te donner le package qui contient la lib en question, tu l'installes et ainsi de suite


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
saroyan Membre non connecté

Rang

Avatar

Inscrit le : 26/09/2011 à 11h28

Localisation : Nouvelle Aquitaire

Messages: 101

Le 05/08/2019 à 14h52
Bonjour a tous,

En premier merci de votre aide.

Ensuite j'ai fait ce qui avait été indiqué mais sans résultat que ce soit sur CCM ou avec URPMI qui ne reconnaît pas ses packages !

Autrement l'installation de Bridge se fait en RPM.

Si vous avez d'autres suggestions je suis bien évidement preneur.

Merci


Je fais ce que je peux avec ce que j'ai.
Mageia 6
KDE
64 bits
8 Go de Ram
Site web    
Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 1851

Le 05/08/2019 à 15h10
Code BASH :
[jibz@jabztop test1]$ urpmf libQtGui.so
lib64qtgui4:/usr/lib64/libQtGui.so.4
 
[jibz@jabztop test1]$ urpmf libc.so
glibc:/lib/libc.so.6
glibc:/lib64/libc.so.6
 
[jibz@jabztop test1]$ urpmf lib64xcrypt1
lib64xcrypt1:/usr/lib64/libcrypt.so.1
 
[jibz@jabztop test1]$ urpmf libQtDeclarative
lib64qtdeclarative4:/usr/lib64/libQtDeclarative.so.4
 
...
 

Donc :
Code BASH :
[jibz@jabztop test1]$ urpmi lib64qtgui4 glibc lib64xcrypt1 lib64qtdeclarative4 ...
 

Parcontre, la version 5 n'est pas là, seulement 4.8
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie