Connexion

Forum

Système et matériels » Réseau Internet Wi-Fi freebox et openvpn

Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 1857

Le 17/06/2019 à 10h54
Salut à tous !

J'ai tenté d'utiliser le VPN de la freebox. Ça boite plutôt bien. :hehe:

Avant d'arriver au problème, les étapes pour arriver à mon point :

Dans son réseau local :
aller sur mafreebox.free.fr et s'y identifier
aller dans "Param-tres de la Freebox"
Aller dans "Serveur VPN"
Aller dans "OpenVPN Routé"
Cliquez sur "Activer"
aller dans "Utilisateurs",
cliquez sur "Ajouter un utilisateur"
mémorisez bien votre mot de passe, vous allez le retapez à chaque fois xD
retourner dans "OpenVPN routé"
double cliquez sur l'utilisateur pour télécharger le fichier de configuration

Aller dans un terminal, installez openvpn
# urpmi openvpn
puis copier collez la configuration au drôle de nom :
# cp /home/utilisateur/Téléchargements/config_openvpn_utilisateur.opvn /etc/openvpn/FreeboxUtilisateur.opvn
Lancez la configuration :
# openvpn /etc/openvpn/FreeboxUtilisateur.opvn
On demande le nom d'utilisateur, et le mot de passe.

On est déjà presque à la fin, mais là ça se complique.
Chez moi, le "serveur" vpn à la passerelle de mal configurée apparemment (gateway).
Il m'est impossible d'accéder au pages web. Va savoir pourquoi ! Pourtant, toutes les IP sont accessibles...

On file dans drakconf pour configurer les réseaux (ou on clic sur l'icone du wifi par exemple en bas à gauche)
on clic que tun0 qu'on configure,
on spécifie l'adresse IP fixe au lieu d'automatique/dhcp
On récupère du terminal l'adresse que le serveur nous a donné, on laisse le masque comme il nous est proposé par défaut, on remplace la passerelle (qui est chez moi par défaut 212.27.38.253 par 192.168.27.94
on déconnecte, on reconnecte.

Enfin, j'ai accès à internet ! Et à mon réseau local.
Cependant, comme on a déconnecté, on a perdu la connexion IPv6. C'est con.
De plus, apparemment la configuration fixe n'a rien donné !
Code BASH :
tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>  mtu 1500
        inet 192.168.27.65  netmask 255.255.255.255  destination 212.27.38.253
        inet6 xxxx:xxxx:xxxx:xxxx::10  prefixlen 124  scopeid 0x0<global>
        inet6 fe80::xxxx:xxxx:xxxx:xxxx  prefixlen 64  scopeid 0x20<link>
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 100  (UNSPEC)
        RX packets 11296  bytes 11889584 (11.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 9183  bytes 1254819 (1.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 

Là je ne comprends plus.

J'ai tenté plusieurs modifications du fichier de configuration, comme ces trucs là :
Code BASH :
#topology subnet
#ifconfig 192.168.27.65 255.255.255.224
#pull-filter ignore "ifconfig"
#route-gateway 192.168.27.94
#route-gateway 192.168.0.254
 
#redirect-gateway
#pull-filter ignore redirect-gateway
#route-gateway 192.168.27.94
redirect-gateway
 

Mais ne souhaitant pas définir des ip fixes, ça ne me plait pas, si je ne change pas tout, openvpn se met en PLS et ne démarre plus.

Voilà, si l'un de vous sait comment s'y prendre mieux, ce serait parfait, en attendant, vous pouvez utiliser votre VPN comme moi, boiteux... :hehe:
   
Guygoye Membre non connecté

Rang

Avatar

Inscrit le : 25/10/2018 à 09h40

Messages: 340

Le 18/06/2019 à 21h08
J’hésitais à utiliser cette méthode, mais vu tes déboires, je vais suivre ce fil pour voir ;)

J'aviserai en fonction de tes résultats. Désolé je ne peux pas aider.
A part le montage du disque de la Freebox au démarrage c'est tout ce que j'ai su faire!
   
Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 1857

Le 18/06/2019 à 21h26
Hum... Je me demande si c'est une question de table de routage non mise à jour...
Quand je serais dehors je testerai les solutions sur ce site : https://linoxide.com/how-tos/how-to-flush-routing-table-from-cache/
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie