Connexion

Forum

Cauldron, la prochaine version de Mageia Passage au chaudron

funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 07/05/2019 à 18h54
'lut,

J'ai voulu installer (en compilant) la dernière version de kdenlive 19.04 qui est une version majeure avec 60% du code réécrit et des grosses évolutions de fonctionnalités et d'ergonomie, malheureusement pas moyen sous mageia 6.1 qui a une version de KF5/plasma trop vieille. Je me suis donc résolu à faire une mise à jour vers la version cauldron alors que jusqu'à présent j'attendais patiemment la sortie de la version finale.

La mise à jour s'est globalement très bien passée, moyennant quelques reboots réguliers, je me suis retrouvé avec une distrib parfaitement stable et fonctionnelle avec toute mes configurations système perso (client d'authentification LDAP, NFS, etc.). Quasiment rien à faire, bravo !
Je dois juste déplorer 2, 3 détails, parce que sinon ça serait pas rigolo, SDDM m'affiche mon fond d'écran flou, c'est moche ! Pour ceux qui veulent retrouver une belle image, il faut aller dans le fichier /usr/share/sddm/themes/breeze/Main.qml et au niveau de WallpaperFader au lieu de

visible: config.type == "image"

on met

visible: false

et voilà le résultat



sinon j'ai un popup pénible à chaque login avec rfkill pour les utilisateurs de blueman (pour piloter le bluetooth) qui me demande un mot de passe, il faut créer une règle polkit /usr/share/polkit-1/rules.d/blueman.rules qui contient

Code BASH :
/* Allow users in wheel group to use blueman feature requiring root without authentication */
polkit.addRule(function(action, subject) {
    if ((action.id == "org.blueman.network.setup" ||
         action.id == "org.blueman.dhcp.client" ||
         action.id == "org.blueman.rfkill.setstate" ||
         action.id == "org.blueman.pppd.pppconnect") &&
        subject.isInGroup("wheel")) {
        return polkit.Result.YES;
    }
});


sinon sous XFCE j'ai perdu la transparence de mon tableau de bord, j'ai galéré pour la remettre en place, le curseur pour régler la transparence ayant disparu dans la configuration, en fait c'est devenu bien plus compliqué (voir par là https://docs.xfce.org/xfce/xfce4-panel/preferences/transparent-panel ) comment faire simple...

cela donne basiquement cela



il me reste à remettre à jour mes fichiers conky qui sont tous cassés avec la mise à jour de conky


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1120

Le 07/05/2019 à 22h21
Wouaou ! Des images de profil un peu "années 70/80", mais visuellement ta configuration en jette !
:super:
   
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 07/05/2019 à 23h43
Jybz :
Wouaou ! Des images de profil un peu "années 70/80", mais visuellement ta configuration en jette !


C'est des photos perso de chacun des utilisateurs et qui ont effectivement quelques années, en revanche je découvre que le compilo n'est pas stable, il fait des erreurs internes et termine en segmentation fault, c'est plutôt génant.



FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Jybz Membre non connecté

Rang

Avatar

Inscrit le : 10/10/2018 à 10h26

Messages: 1120

Le 08/05/2019 à 09h35
GCC ?!
   
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 08/05/2019 à 11h08
oui gcc, c'est pour compiler ffmpeg, j'ai viré les options d'optimisation dans le makefile et ça passe, il en reste pas moins que c'est pas terrible


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Yuusha Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2017 à 19h52

Messages: 287

Le 15/05/2019 à 11h25
funix :
[en revanche je découvre que le compilo n'est pas stable, il fait des erreurs internes et termine en segmentation fault, c'est plutôt génant.


Bonjour,

Vérifie l'utilisation de ta RAM et de tes CPU lors de la compilation. J'ai le même problème avec une Mageia 6 en VirtualBox et gcc 5.5.0. Je n'ai pas encore pu déterminer d'où venait le problème (RAM ou CPU) à 100% mais c'est clairement lorsqu'un de ces évènements ce produit qu'il advient une erreur de gcc.

Je n'ai jamais réussi à compiler correctement kdenlive, surtout que Plasma n'est pas mon bureau par défaut. Quand je veux tester une nouvelle version, j'utilise la AppImage même si elle est limitée.

Pour la nouvelle version de kdenlive je vais attendre quelque temps pour qu'ils corrigent tous les bogues.
   
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 15/05/2019 à 19h55
C'est délicat à trouver car on a aucun message d'erreur si ce n'est le segmentation fault, en revanche ça plante à un endroit spécifique, dans une fonction particulière, mais je ne vois rien de louche, dès que je supprime l'option d'optimisation, ça passe. Dans la même configuration avec la 6.1, ça compile sans problème (avec l'option d'optimisation).

je compile kdenlive sans problème sous XFCE, mais c'est vrai qu'il faut les packages de plasma (voir par là j'ai mis à jour la compil de la 19.04 avec mageia 7 cauldron https://www.funix.org/fr/linux/index.php?ref=montage )


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Messages: 6042

Le 16/05/2019 à 08h13
funix :

je compile kdenlive sans problème sous XFCE, mais c'est vrai qu'il faut les packages de plasma (voir par là j'ai mis à jour la compil de la 19.04 avec mageia 7 cauldron https://www.funix.org/fr/linux/index.php?ref=montage )

Bonjour,
Je suis allé voir tes instructions de compilation. Juste deux remarques.
Dans Mageia 7, le python est en version 3.7, donc il faudra certainement adapter la destination de mlt.
Par ailleurs, le package kde-l10n-fr n'existe plus dans Mageia 6


Yves
   
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 16/05/2019 à 22h07
OK merci je vais corriger cela


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 19/05/2019 à 15h52
C'est corrigé, il me reste toutefois à réinstaller cinelerra, openshot et le reste

je dois déplorer la disparition de l'éditeur Kompozer qui avait l'avantage de pouvoir jouer sur les attributs des images ce que ne permet pas bluegriffon, mais bon il n'est plus maintenu et il ne se compile plus, à défaut j'ai édité de l'html dans libreoffice, ça marche plutôt bien et en plus on peut à nouveau fixer les attributs des images (sauf que c'est en cm au lieu de pixels). En revanche, je ne comprends pas pourquoi ils ont inversé dans libreoffice le Annuler et le OK, c'est d'un pénible, je pers un temps fou à tout refaire à chaque fois :pascontent1:
je sais ça n'a pas grand chose à voir avec cauldron, mais ça fait partie de la découverte de cette nouvelle version.


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 01/06/2019 à 11h15
c'est bon j'ai réinstallé toute la batterie des logiciels de montage vidéo, cinelerra, cinelerra GG, openshot 2.4.4 et la dernière version de kdenlive, la compilation d'openshot video editor a été particulièrement épique avec pas mal de modifications dans le code vu qu'il n'est pas compatible avec la version 7 d'imagemagick fournie avec mageia 7. Pour les curieux, c'est par là https://www.funix.org/fr/linux/index.php?ref=montage .


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 16/06/2019 à 10h21
j'suis passé sur les dépots de la mageia 7, après mise à jour, écran noir, le driver nvidia dysfonctionne avec le noyau 5.1.9, obligé de rester avec la version 5.1.5 en attendant


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie