Connexion

Forum

Logiciels » Bureautique Installation beugée de Gscan2pdf erreur dans a compilation lors de l'installation par CCM

dantou Membre non connecté

Rang

Avatar

Inscrit le : 04/01/2011 à 00h46

Localisation : Maubeuge France Nord

Messages: 506

Le 01/05/2019 à 16h16
Bonjour,
Décidément, je n'ai pas de chance ! Suite à ma recherche sur Pdfshuffler -pour lequel j'ai posté ici même - j'ai trouvé Gscan2pdf.
Bien, je l'installe.
Mais que nenni, toujours rien.
Je recommence sous Konsole et obtiens ceci :
avec CCM,et installation de Gscan2pdf révision 1.1
/usr/bin/gscan2pdf
Gtk2.pm did not return a true value at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.22.3/base.pm line 99.
...propagated at /usr/lib/perl5/5.22.3/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.3/Gscan2pdf/Document.pm line 67.
Compilation failed in require at /usr/bin/gscan2pdf line 47.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 47.

Je désinstalle, et réinstalle, avec CCM, Gscan2pdf révision 1
[root@localhost rpm_perso]# /usr/bin/gscan2pdf
Gtk2.pm did not return a true value at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.22.3/base.pm line 99.
...propagated at /usr/lib/perl5/5.22.3/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.3/Gscan2pdf/Document.pm line 67.
Compilation failed in require at /usr/bin/gscan2pdf line 47.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 47.
[root@localhost rpm_perso]#
Donc, si vous avez des remarques, n'hésitez pas.
Merci.
Cordialement, Dan.


Acer Aspire E 15 (E5-573G-565T) -Intel I5 4200 - Geforce 940M - 4 G° RAM - DD 1 T° - Dual-boot Windows 10 / Mageia 5
PC Antec Sonata 300 - Intel E8400 - ATI Radeon HD 5470 - 6 G° RAM - 1 T° DD1 - 500 G° DD2 -
Synology DS 215J - DSM 5.2 - DD : WD Red 3 T°
Magéia 64 bits - KDE - Digikam -
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 01/05/2019 à 16h33
Bonjour,

Est ce qu' il y a une raison particulière de lancer le programme avec les droits root ?

   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6840

Le 01/05/2019 à 17h43
urpmi gscan2pdf
et tu auras un version 1.8 fonctionnelle.
Je ne sais pas ce que tu as récupéré, mais je pense qu'il manque des dépendances.


Yves
   
dantou Membre non connecté

Rang

Avatar

Inscrit le : 04/01/2011 à 00h46

Localisation : Maubeuge France Nord

Messages: 506

Le 01/05/2019 à 19h11
Bonjour,
Citation :
Est ce qu' il y a une raison particulière de lancer le programme avec les droits root ?

Non, aucune raison, si ce n'est que je le venais de l'installer - donc en root - et que j'y suis resté. Ca peut expliquer ? En tous cas, la réponse est toujours la même.
Citation :
Je ne sais pas ce que tu as récupéré
: c'est ce que propose le CCM. (version 1.8.2-1.1)
j'ai tout désinstallé.
Puis j'ai fait :
[dan@localhost rpm_perso]$ /usr/bin/gscan2pdf
Gtk2.pm did not return a true value at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.22.3/base.pm line 99.
...propagated at /usr/lib/perl5/5.22.3/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.3/Gscan2pdf/Document.pm line 67.
Compilation failed in require at /usr/bin/gscan2pdf line 47.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 47.
[dan@localhost rpm_perso]$ /usr/bin/gscan2pdf
Gtk2.pm did not return a true value at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.22.3/base.pm line 99.
...propagated at /usr/lib/perl5/5.22.3/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.22.3/Gscan2pdf/Document.pm line 67.
Compilation failed in require at /usr/bin/gscan2pdf line 47.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 47.
Ca n'a pas l'air très fonctionnel quand même chez moi.
Petite précision, je suis en : Linux localhost 4.9.35-desktop-1.mga6 #1 SMP Thu Jun 29 19:27:27 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux.
Est-ce que ça joue ( comme pour pdfshuffler ?)


Acer Aspire E 15 (E5-573G-565T) -Intel I5 4200 - Geforce 940M - 4 G° RAM - DD 1 T° - Dual-boot Windows 10 / Mageia 5
PC Antec Sonata 300 - Intel E8400 - ATI Radeon HD 5470 - 6 G° RAM - 1 T° DD1 - 500 G° DD2 -
Synology DS 215J - DSM 5.2 - DD : WD Red 3 T°
Magéia 64 bits - KDE - Digikam -
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6840

Le 01/05/2019 à 21h59

Gtk2.pm did not return a true value at /usr/lib/perl5/vendor_perl/5.22.2/Gtk2/Ex/Simple/List.pm line 9.
Code PEARL :
 
use Gtk2;
 

As-tu le rpm perl-Gtk2 installé ?
Quelle version ?
rpm -q perl-Gtk2
Il semble que tu ne fais pas les mises à jour, parce que le noyau 4.9 est ancien, sauf si tu l'as choisi volontairement.


Yves
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 01/05/2019 à 22h09
Bonjour,

@papoteur: je crois que c' est à cause de ceci le noyau 4.9.35
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6840

Le 01/05/2019 à 22h14
nic80 :
Bonjour,

@papoteur: je crois que c' est à cause de ceci le noyau 4.9.35

Certains ont la mémoire plus longue que d'autres ....
Bon, avec le problème PDFShuffer, il y a manifestement un souci de fonctionnement de GTK2.


Yves
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1532

Le 02/05/2019 à 00h14
Bonjour,

Citation :
il y a manifestement un souci de fonctionnement de GTK2


Il manquerait une lib64gtk+2.0_0 ou un gtk+2.0 ( j' ai pas envie de tester (une désinstallation de lib64gtk+2.0_0 vu tout ce que ça désinstalle :hehe: !) ?

@dantou : je pense qu' il faut d' abord régler ce problème d' abord ( peut être en regardant ceci) ... la première chose que gscan2pdf me dit c' est qu' il ne trouve pas de périphérique !
   
dantou Membre non connecté

Rang

Avatar

Inscrit le : 04/01/2011 à 00h46

Localisation : Maubeuge France Nord

Messages: 506

Le 02/05/2019 à 11h10
Bonjour,
Papoteur a raison, c'est bien parce que j'ai un problème de compatibilité (matériel je pense) quelque part que je reste sur le noyau Linux localhost 4.9.35.
Et c'est parce que pdfshuffler ne fonctionne plus (ou pas avec cette version du noyau) que j'ai cherché et essayé gscan2pdf.
Par contre je ne comprends pas Papoteur, pourquoi tu penses que c'est relié avec la connexion de mon imprimante réseau ?
J'ai toujours utilisé Pdfshuffler indépendamment de l'impression.
Par effectivement, si Gscan2pdf doit être relié, je préfère arrêter là, d'autant que pour moi, Gscan2pdf est juste un remplaçant temporaire de Pdfshuffler que j'espère bien récupérer tant il est simple à utiliser.
Par contre, effectivement, c'est insatisfaisant de ne pas savoir le faire fonctionner, et ça me dérange. Je n'aime pas les "pourquoi" non résolus :)).

Edité par dantou Le 02/05/2019 à 11h27


Acer Aspire E 15 (E5-573G-565T) -Intel I5 4200 - Geforce 940M - 4 G° RAM - DD 1 T° - Dual-boot Windows 10 / Mageia 5
PC Antec Sonata 300 - Intel E8400 - ATI Radeon HD 5470 - 6 G° RAM - 1 T° DD1 - 500 G° DD2 -
Synology DS 215J - DSM 5.2 - DD : WD Red 3 T°
Magéia 64 bits - KDE - Digikam -
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6840

Le 02/05/2019 à 13h47
dantou :
Bonjour,
Papoteur a raison, c'est bien parce que j'ai un problème de compatibilité (matériel je pense) quelque part que je reste sur le noyau Linux localhost 4.9.35.
Et c'est parce que pdfshuffler ne fonctionne plus (ou pas avec cette version du noyau) que j'ai cherché et essayé gscan2pdf.
Par contre je ne comprends pas Papoteur, pourquoi tu penses que c'est relié avec la connexion de mon imprimante réseau ?
J'ai toujours utilisé Pdfshuffler indépendamment de l'impression.
Par effectivement, si Gscan2pdf doit être relié, je préfère arrêter là, d'autant que pour moi, Gscan2pdf est juste un remplaçant temporaire de Pdfshuffler que j'espère bien récupérer tant il est simple à utiliser.
Par contre, effectivement, c'est insatisfaisant de ne pas savoir le faire fonctionner, et ça me dérange. Je n'aime pas les "pourquoi" non résolus :)).


J'ai relié le problème de PDFShuffler et celui de Gscan2pdf parce que tous les deux utilisent Gtk2.0 je considère que le problème du noyau et de l'imprimante sont indépendant de celui-ci.


Yves
   
stroibe974 Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 13/08/2018 à 16h22

Localisation : Réunion

Messages: 1013

Le 02/05/2019 à 15h43
dantou :
d'autant que pour moi, Gscan2pdf est juste un remplaçant temporaire de Pdfshuffler que j'espère bien récupérer tant il est simple à utiliser.


Je suis assez surpris parce que pour moi, gscan2pdf est un programme qui commande un scanner dans le but de numériser un document et d'en faire un fichier PDF... non ?
Si c'est pour assembler plusieurs PDF en un seul fichier, je prendrais plutôt KPDFTools ou PDFsam.


Mageia 7 (64bits) - Plasma - Intel Core i7-8700K @ 3.70Ghz - 16Go RAM
frenchmageiauser_9c2c8
   
Antoniop Membre non connecté

Rang

Avatar

Inscrit le : 21/12/2011 à 23h51

Localisation : France

Messages: 205

Le 07/05/2019 à 08h12
stroibe974 :
dantou :
d'autant que pour moi, Gscan2pdf est juste un remplaçant temporaire de Pdfshuffler que j'espère bien récupérer tant il est simple à utiliser.


Je suis assez surpris parce que pour moi, gscan2pdf est un programme qui commande un scanner dans le but de numériser un document et d'en faire un fichier PDF... non ?
Si c'est pour assembler plusieurs PDF en un seul fichier, je prendrais plutôt KPDFTools ou PDFsam.


Ou alors, en ligne de commande, qpdf !
https://www.mageialinux-online.org/forum/topic-20543-2+pdftk-indisponible-sous-mga5.php#m245073
   
dantou Membre non connecté

Rang

Avatar

Inscrit le : 04/01/2011 à 00h46

Localisation : Maubeuge France Nord

Messages: 506

Le 09/05/2019 à 23h43
Bonjour,
J'ai peut-être un autre problème alors. Antoniop dit :
Citation :
pour moi, gscan2pdf est un programme qui commande un scanner
. Si Gscan2pdf est pour commander un scanner, ce n'est pas ce dont j'ai besoin. PdfShuffler permet d'agréger plusieurs "pdf", pour en faire un dossier par exemple, de tous vos bulletins, vos ordonnances ... scannées indépendamment au fil des siècles ....
Ce que fait très bien KPDFTools par exemple, que je ne connaissais pas avant cette recherche, et dont je pourrai me satisfaire si ...
Seulement PdfShuffler est francisé alors que j'ai KPFTools en anglais !
Mais bon on va peut être arrêter de s'arracher les cheveux, car il ne m'en reste déjà plus beaucoup. Alors si je n'ai pas de solution, j'arrête de vous embêter la semaine prochaine . Il y a d'autre problèmes plus urgents certainement auxquels vous pourriez certainement des solutions.
Merci quand même à tous.
Cordialement, Dan.


Acer Aspire E 15 (E5-573G-565T) -Intel I5 4200 - Geforce 940M - 4 G° RAM - DD 1 T° - Dual-boot Windows 10 / Mageia 5
PC Antec Sonata 300 - Intel E8400 - ATI Radeon HD 5470 - 6 G° RAM - 1 T° DD1 - 500 G° DD2 -
Synology DS 215J - DSM 5.2 - DD : WD Red 3 T°
Magéia 64 bits - KDE - Digikam -
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie