Connexion

Forum

Logiciels » Graphisme photo et vidéo Port firewire IEEE 1394 Problème d'acquisition

Gillux33 Membre non connecté

Rang

Avatar

Inscrit le : 21/01/2009 à 10h41

Localisation : Sud bassin d'Acachon (33)

Messages: 46

Le 29/01/2019 à 11h32
Bonjour à tous,

Avec Mageia 5 je pouvais récupérer mes vidéos DV de ma Sony, par le port IEEE 1394 avec Kino.

Comme dans Mageia 6 il n'y a plus Kino, j'ai essayé avec Kdenlive.

Mais en acquisition, je vois la webcam mais pas le port 1394, la caméra étant bien branchée sur le port et allumée.

J'ai essayé avec Avidemux et Openshot, mais rien vu pour l'acquisition vidéo...

J'ai bien les librairies 1394 d'installées...


Merci de votre aide

Gilles

Mageia 6, 64-bits, kde/Plasma 5.12.2, noyau 4.18.12


Mageia7 x86_64 Plasma
Carte mère P5G41T-M LE / Pentium(R) Dual-Core CPU E6800 @ 3.33GHz / 4 Go RAM
gillux33
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6723

Le 29/01/2019 à 20h37
Bonjour,
kino utilisait dvgrab qui est toujours disponible.
C'est en ligne de commande, mais de mémoire, ça fonctionnait.


Yves
   
Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 1858

Le 29/01/2019 à 20h42
Je n'ai jamais eu de firewire... Est-ce que, lorsqu'on branche un matériel sur le port firewire, des informations sont données via dmesg ?


D'après ce petit graphique
trouvé sur ce site http://www.brendangregg.com/linuxperf.html ,
je crois que la commande dmesg serait pas mal.

Gillux33, peux tu lancer dans un terminal :
$dmesg --follow
brancher le périphérique
voir le changement sur le terminal et nous le copier coller ici ? Edité par Jybz Le 29/01/2019 à 20h46
   
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 530

Le 29/01/2019 à 21h33
tape un

lsmod | grep 1394

ça permettra de voir si les modules qui pilotent le firewire sont bien lancés, tu devrais voir une sortie qui ressemble à ça

video1394 15228 0
raw1394 23548 0
ohci1394 30028 1 video1394
ieee1394 85124 4 video1394,raw1394,sbp2,ohci1394

au lieu de video1394, tu peux avoir également dv1394 qui est jugé plus performant, si ce n'est pas le cas il faut les lancer avec modprobe (dans l'ordre ohci, ieee, raw et dv ou video), branche ton périphérique et jette un coup d'oeil en même dans le journal (journalctl -f) vérifie que les fichiers spéciaux ont bien été créés sous /dev (a priori sous /dev/1394). Repère bien le fichier spécial d'entrée qu'il faudra indiquer à kdenlive ou à n'importe quel logiciel capable de faire de la capture firewire.


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6723

Le 30/01/2019 à 08h21
Jybz :
D'après ce petit graphique
trouvé sur ce site http://www.brendangregg.com/linuxperf.html ,
je crois que la commande dmesg serait pas mal.

Et tu voudrais qu'on déduise de ce graphique qu'on peut avoir des infos du port 1394 avec la commande dmesg ?
Tu présumes trop de nos capacités ;-)


Yves
   
Jybz Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 10/10/2018 à 10h26

Messages: 1858

Le 30/01/2019 à 09h38
Papoteur :
Et tu voudrais qu'on déduise de ce graphique qu'on peut avoir des infos du port 1394 avec la commande dmesg ?
Tu présumes trop de nos capacités ;-)


:$
Désolé.
Mais de toutes les manières, Funix m'a l'air bien plus compétent ! (Je ne pense jamais à journalctl...)
   
Gillux33 Membre non connecté

Rang

Avatar

Inscrit le : 21/01/2009 à 10h41

Localisation : Sud bassin d'Acachon (33)

Messages: 46

Le 30/01/2019 à 14h49
Bonjour à tous,

$ dmesg --follow
(je n'ai copié que les lignes concernant firewire)
897.443994] firewire_ohci 0000:0f:06.1: isochronous cycle inconsistent
[ 897.952146] firewire_core 0000:0f:06.1: rediscovered device fw0
[ 898.045749] firewire_core 0000:0f:06.1: created device fw1: GUID 08004601026bb4ac, S100
[ 898.045756] firewire_core 0000:0f:06.1: phy config: new root=ffc1, gap_count=5
[ 898.552142] firewire_core 0000:0f:06.1: rediscovered device fw0
[ 898.645633] firewire_core 0000:0f:06.1: rediscovered device fw1


[root@localhost gilles]# lsmod | grep 1394
[root@localhost gilles]# modprobe ohci
modprobe: FATAL: Module ohci not found in directory /lib/modules/4.14.89-desktop-1.mga6
[root@localhost gilles]#

Comme ohci pas trouvé, je n'ai pas essayé les autres...

pas de /dev/1394

dvgrab est bien installé...

[root@localhost gilles]# journalctl -f
-- Logs begin at mar. 2018-01-30 17:17:58 CET. --
janv. 30 14:42:11 localhost.localdomain kactivitymanagerd[4176]: Current score : 2
janv. 30 14:42:11 localhost.localdomain kactivitymanagerd[4176]: First update : QDateTime(2019-01-30 14:25:42.000 CET Qt::TimeSpec(LocalTime))
janv. 30 14:42:11 localhost.localdomain kactivitymanagerd[4176]: Last update : QDateTime(2019-01-30 14:35:11.000 CET Qt::TimeSpec(LocalTime))
janv. 30 14:42:11 localhost.localdomain kactivitymanagerd[4176]: Interval length is 0
janv. 30 14:42:11 localhost.localdomain kactivitymanagerd[4176]: New score : 3
janv. 30 14:42:11 localhost.localdomain kactivitymanagerd[4176]: ResourceScoreUpdated: "57db6f56-5afd-45c8-a76e-52872cbb30b9" "org.kde.kwrite" "/run/media/gilles/GILLES-11/Firewire"
janv. 30 14:42:11 localhost.localdomain plasmashell[4139]: KActivitiesStats( 0x3979fd0 ) ResultModelPrivate::onResultScoreUpdated result added: "/run/media/gilles/GILLES-11/Firewire" score: 3 last: 1548855729 first: 1548854742
janv. 30 14:42:39 localhost.localdomain su[6331]: (to root) gilles on pts/0
janv. 30 14:42:39 localhost.localdomain su[6331]: pam_systemd(su:session): Cannot create session: Already running in a session
janv. 30 14:42:39 localhost.localdomain su[6331]: pam_unix(su:session): session opened for user root by gilles(uid=1001)
janv. 30 14:42:52 localhost.localdomain kernel: firewire_ohci 0000:0f:06.1: isochronous cycle inconsistent
janv. 30 14:42:53 localhost.localdomain kernel: firewire_core 0000:0f:06.1: rediscovered device fw0
janv. 30 14:42:53 localhost.localdomain kernel: firewire_core 0000:0f:06.1: created device fw1: GUID 08004601026bb4ac, S100
janv. 30 14:42:53 localhost.localdomain kernel: firewire_core 0000:0f:06.1: phy config: new root=ffc1, gap_count=5
janv. 30 14:42:53 localhost.localdomain kernel: firewire_core 0000:0f:06.1: rediscovered device fw0
janv. 30 14:42:53 localhost.localdomain kernel: firewire_core 0000:0f:06.1: rediscovered device fw1


Merci de votre aide
Bonne journée
Gilles


Mageia7 x86_64 Plasma
Carte mère P5G41T-M LE / Pentium(R) Dual-Core CPU E6800 @ 3.33GHz / 4 Go RAM
gillux33
Site web    
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 530

Le 30/01/2019 à 20h50
visiblement les modules firewire ont quelque peu évolué et n'ont plus les mêmes noms ! Il faut dire que ça fait longtemps que je n'ai plus branché mon vieux caméscope DV.
On progresse ! La sortie de journalctl est plutôt positive, il semblerait que les modules soient chargés et qu'ils ont créé un fichier spécial pour pouvoir accéder à ton périphérique qui s'appelle fw1, il faudrait voir où il se trouve un "find /dev -name "fw*" -print" devrait te donner son emplacement, donne nous ce que ça donne.





FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Gillux33 Membre non connecté

Rang

Avatar

Inscrit le : 21/01/2009 à 10h41

Localisation : Sud bassin d'Acachon (33)

Messages: 46

Le 31/01/2019 à 13h52
Bonjour à tous,

[gilles@localhost ~]$ find /dev -name "fw*" -print
/dev/fw1
/dev/fw0
[gilles@localhost ~]$

Gilles


Mageia7 x86_64 Plasma
Carte mère P5G41T-M LE / Pentium(R) Dual-Core CPU E6800 @ 3.33GHz / 4 Go RAM
gillux33
Site web    
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 530

Le 31/01/2019 à 21h16
malheureusement je ne vois pas d'option pour dvgrab pour spécifier le fichier d'entrée qui est a priori /dev/fw1, il doit le reconnaitre automatiquement quand tu tapes dvgrab capture (que tu interromps avec un ctrl+C) tu dois retrouver un fichier capture.avi qui doit être visible avec mplayer ou vlc.
A défaut sous kdenlive dans la configuration au niveau d'acquisition tu peux indiquer le périphérique vidéo /dev/fw1, dans vlc tu peux également spécifier un périphérique de lecture où tu vas mettre /dev/fw1 attention il faudra mettre ton caméscope en lecture en même temps, contrairement à kino a priori ils ne permettent pas de piloter ton caméscope.



FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Gillux33 Membre non connecté

Rang

Avatar

Inscrit le : 21/01/2009 à 10h41

Localisation : Sud bassin d'Acachon (33)

Messages: 46

Le 01/02/2019 à 18h28
Bonjour à tous,

Eh bien, j'ai mis /dev/fw1 dans la configuration, mais kdenlive n'affiche pas la vidéo du caméscope.

Je pense faire un dual boot Mageia5 / Mageia 6, puisque que ça fonctionnait avec Kino

Merci à tous et bonne soirée
Gilles


Mageia7 x86_64 Plasma
Carte mère P5G41T-M LE / Pentium(R) Dual-Core CPU E6800 @ 3.33GHz / 4 Go RAM
gillux33
Site web    
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 530

Le 02/02/2019 à 09h08
tu n'es pas loin, ça serait dommage d'arrêter là, tu as essayé avec dvgrab (avec l'option debug) ? essaye également avec /dev/fw0


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1429

Le 02/02/2019 à 09h44
Bonjour,

L' acquisition firewire est elle toujoues disponible dans Kdenlive ( dans la page ci dessous, il est indiqué que la partie firewire a été supprimé dans le portage vers Kde5) ?

https://userbase.kde.org/Special:MyLanguage/Kdenlive/Manual/Settings_Menu/Configure_Kdenlive
   
Gillux33 Membre non connecté

Rang

Avatar

Inscrit le : 21/01/2009 à 10h41

Localisation : Sud bassin d'Acachon (33)

Messages: 46

Le 02/02/2019 à 10h23
Bonjour à tous,

Bien sûr que j'ai essayé avec /dev/fw0

Dans la configuration de Kdenlive, ça ne s'appelle plus "Capture"
mais "Acquisition" et l'onglet "Firewire" a disparu.
Il ne reste que "FFmpeg" et "Filmer l'écran"

> La capture Firewire - au minimum - a été enlevée durant le portage vers
> KDE 5 en raison du manque de main-d'œuvre.

Merci à tous
Bonne journée
Gilles


Mageia7 x86_64 Plasma
Carte mère P5G41T-M LE / Pentium(R) Dual-Core CPU E6800 @ 3.33GHz / 4 Go RAM
gillux33
Site web    
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1429

Le 02/02/2019 à 10h54
Bonjour,

D' après cette page ( sur une Fedora), il peut être nécessaire d' ajouter des permissions supplémentaires ( ajout du user au groupe video ( si présent sur Mageia) ainsi que des droits sur les périphériques /dev/fw0 (et/ou /dev/fw1).

Est ce le cas ?

   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie