Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Imprimantes scanners et Appareils Photo Problème de droits sur imprimante cups et samsung clp 680

lcb1 Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2011 à 11h15

Localisation : Toulouse area

Messages: 281

Le 08/01/2019 à 11h23
Bonjour

pour une raison inconnue j'ai eu soudain un problème de droits sur une imprimante samsung CLP680 en USB.

Après avoir désinstallé, viré les conf de /etc et réinstallé, j'ai pu imprimer mais uniquement en suivant les instruction suivant sur https://wiki.archlinux.org/index.php/CUPS/Troubleshooting#Bad_permissions

A savoir

Citation :
Bad permissions

Check the permissions of the printer USB device. Get the bus and device number from lsusb:

lsusb

Bus <BUSID> Device <DEVID>: ID <PRINTERID>:<VENDOR> Hewlett-Packard DeskJet D1360

Check the ownership by looking in devfs:

# ls -l /dev/bus/usb/<BUSID>/<DEVID>

The cups daemon runs as user "cups" and belongs to group "lp", so either this user or group needs read & write access to the USB device. If you think the permissions look wrong, you can change the group and permission temporarily:

# chgrp lp /dev/bus/usb/<BUSID>/<DEVID>
# chmod 664 /dev/bus/usb/<BUSID>/<DEVID>

Then check if cups can now see the USB device correctly.

To make a persistent permission change that will be triggered automatically each time the USB device is attached, add the following line:

/etc/udev/rules.d/10-local.rules

SUBSYSTEM=="usb", ATTRS{idVendor}=="<VENDOR>", ATTRS{idProduct}=="<PRINTERID>", GROUP:="lp", MODE:="0664"

After editing, reload the udev rules with this command:

# udevadm control --reload-rules

Each


en particulier

# chgrp lp /dev/bus/usb/<BUSID>/<DEVID>
# chmod 664 /dev/bus/usb/<BUSID>/<DEVID>



Dernier problème, il n'y a pas de fichier 10-local.rules dnas /etc/udev/rules.d/

Est-ce que je dois créer un tel fichier ? Ou est-ce que ça se passe ailleurs sur Mageia ? Et enfin, est-ce que ce fichier 10-local.rules doit être créé comme indiqué (avec des variables) ou est-ce qu'il faut attribuer les "VENDOR" et "PRINTERID" selon le retour de la commande lsusb ?

Pour info je peux imprimer en user avec une commande simple genre

cat test.txt > /dev/usb/lp0



Merci en cas d'aide
Bruno Edité par lcb1 Le 08/01/2019 à 12h28


Mageia 7 noyau : 5.2.16-desktop-2.mga7, Bureau : Plasma, CM ASRock H81 Pro BTC CG, Asus Geforce GTX 750 ti Sur SSD
& Asus N73S laptop
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4128

Le 08/01/2019 à 13h14
Bonjour,

Je ne peux pas te dire si cette manip prévue pour Arch est valable pour Mageia, mais il n'y a aucun problème à créer le fichier 10-local.rules dans /etc/udev/rules.d/. Le N° n'est là que pour fixer les priorités.
Toutes les variables encadrées par < > doivent être remplacées par leur valeur.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
lcb1 Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2011 à 11h15

Localisation : Toulouse area

Messages: 281

Le 08/01/2019 à 15h15
Hello lebharon
vais voir ça de plus près, ai essayé la procédure sans succès jusqu'à présent. intéressant sur les n° ...
merci pour l'aide, comme toujours ... Edité par lcb1 Le 08/01/2019 à 15h21


Mageia 7 noyau : 5.2.16-desktop-2.mga7, Bureau : Plasma, CM ASRock H81 Pro BTC CG, Asus Geforce GTX 750 ti Sur SSD
& Asus N73S laptop
   
lcb1 Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2011 à 11h15

Localisation : Toulouse area

Messages: 281

Le 09/01/2019 à 08h50
Après avoir passé deux jours, je n'ai trouvé aucune solution, l'usb n'est pas pris en compte par le CUPS, le systèmei reconnaît lui l'imprimante (via lsusb par exemple). Je ne sais tjs pas pourquoi ce problème est apparu soudainement.

Le système est devenu instable, CUPs reconnaissant au début l'usb et puis plus rien.

Du coup j'ai installé en réseau, ça a pris 30 secondes.

Le problème ne vient pas de l'imprimante, puisque j'ai pu installé sans difficulté sur le portable, et en émulation win via virtualbox !

Le mystère demeure.

Edité par lcb1 Le 11/01/2019 à 14h41


Mageia 7 noyau : 5.2.16-desktop-2.mga7, Bureau : Plasma, CM ASRock H81 Pro BTC CG, Asus Geforce GTX 750 ti Sur SSD
& Asus N73S laptop
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie