Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Réseau Internet Wi-Fi Bluetooth inaccessible Bluetooth soft blocked : Yes

Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 29/12/2018 à 12h40
Bonjour,

J'ai voulu utiliser la connexion Bluetooth sans succès.
la commande rfkill donne:

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: ideapad_bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
4: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no



Comment faut-il procéder pour débloquer le Bluetooth, je n'ai rien vu au niveau du CCM.


Patrick
Site web    
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 496

Le 29/12/2018 à 14h04
Bonjour,

chez moi, j'ai ceci:
[xxx@msi ~]$ rfkill list all
1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: no
8: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
[xxx@msi ~]$


_ Si je bloque le bluetooth (hci0, position 8) avec la commande rfkill block 8 => l'icône du bluetooth (blueman) dans le tableau de bord m'indique "bluetooth désactivé"
_ Si je débloque avec la commande rfkill unblock 8 => ça revient à la normal


Peut-être peux-tu essayer de la même manière de débloquer la 1 ou la 4 ?



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 31/12/2018 à 19h53
La manip indiquée a bien modifié le statut . Merci

Mais lorsque je cherche à communiquer entre mon ordinateur et mon téléphone portable,
aucun ne détecte l'autre !!

Existerait-il des problèmes d'interopérabilité ?


Patrick
Site web    
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 496

Le 01/01/2019 à 17h49
Perso j'utilise blueman sous XFCE, et tout est "graphique".
Il tourne bien, le service bluetooth ? Parce que tu sembles en avoir 2 ( idepad_bluetooth et hci0) :désolé1:
Bref, ça donne quoi avec en ligne de commande systemctl status bluetooth.service



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 02/01/2019 à 02h05
voila le resultat

[root@localhost ~]# systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: active (running) since mer. 2019-01-02 02:10:42 CET; 8min left
Docs: man:bluetoothd(8)
Main PID: 830 (bluetoothd)
Status: "Running"
CGroup: /system.slice/bluetooth.service
└─830 /usr/libexec/bluetooth/bluetoothd

janv. 02 02:10:42 localhost.localdomain systemd[1]: Starting Bluetooth service...
janv. 02 02:10:42 localhost.localdomain bluetoothd[830]: Bluetooth daemon 5.45
janv. 02 02:10:42 localhost.localdomain systemd[1]: Started Bluetooth service.
janv. 02 02:10:42 localhost.localdomain bluetoothd[830]: Starting SDP server
janv. 02 02:10:43 localhost.localdomain bluetoothd[830]: Bluetooth management interface 1.14 initialized
janv. 02 02:00:15 localhost.localdomain bluetoothd[830]: Endpoint registered: sender=:1.51 path=/MediaEndpoint/A2DPSource
janv. 02 02:00:15 localhost.localdomain bluetoothd[830]: Endpoint registered: sender=:1.51 path=/MediaEndpoint/A2DPSink
[root@localhost ~]#


Patrick
Site web    
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 496

Le 02/01/2019 à 11h11
Le service tourne bien, alors tu as l'outil btmon qui te permet de le monitorer (à lancer dans une console en root)
Tu "visualises" alors tout ce qui se passe côté Linux, dans ton cas tous les événements lorsque tu veux communiquer avec d'autres appareils.

Cela t'aide-t-il à déceler le problème ?





Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 02/01/2019 à 19h08
voila ce que donne cette commande, je l'ai lancée avant de chercher à connecter mon téléphone.
[root@localhost ~]# btmon
Bluetooth monitor ver 5.45
= Note: Linux version 4.14.89-desktop-1.mga6 (x86_64) 0.024168
= Note: Bluetooth subsystem version 2.22 0.024172
= New Index: 4C:BB:58:C0:CF:74 (Primary,USB,hci0) [hci0] 0.024173
= Open Index: 4C:BB:58:C0:CF:74 [hci0] 0.024174
= Index Info: 4C:BB:58:C0:CF:74 (Realtek Semiconductor Corporation) [hci0] 0.024174
@ MGMT Open: bluetoothd (privileged) version 1.14 {0x0001} 0.024176
@ MGMT Open: btmon (privileged) version 1.14 {0x0002} 0.024207



l'utilitaire semble ne pas se terminer, il ne rend pas la main

Pendant l'essai, le téléphone a bien détecté un PC sous Windows mais pas celui sous Linux.


Patrick
Site web    
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 496

Le 03/01/2019 à 10h22
En fait, il semble que pour des raisons de sécurité, par défaut nos PC linux sont configurés pour ne pas être "visibles". Je viens de revérifier et j'observe ce que tu décris. En fait, j'avais systématiquement appairer mes autres périphériques depuis mon pc, et jamais l'inverse.

Si tu consultes les paramètres de ton matériel, j'imagine que tu as ceci:
[root@msi]# hciconfig hci0
hci0: Type: Primary Bus: USB
BD Address: ACL MTU: 1021:5 SCO MTU: 96:6
UP RUNNING PSCAN


PSCAN autorise le fait de pouvoir faire une recherche. Maintenant il faut aussi que tu autorises le fait de pouvoir être vu lorsqu'un autre appareil scanne les environs. Pour cela, il faut paramétrer ta carte avec la commande hciconfig hci0 piscan

En revérifiant tes paramètres, tu dois avoir ISCAN qui s'est rajouté

[root@msi]# hciconfig hci0
hci0: Type: Primary Bus: USB
BD Address: ACL MTU: 1021:5 SCO MTU: 96:6
UP RUNNING PSCAN ISCAN


Et là normalement c'est bon ! Tu es visible depuis l'extérieur



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 03/01/2019 à 14h14
Sans faire aucune action préalable, j'obtiens ceci:
[root@localhost ~]# hciconfig hci0
hci0: Type: Primary Bus: USB
BD Address: 4C:BB:58:C0:CF:74 ACL MTU: 820:8 SCO MTU: 255:16
UP RUNNING PSCAN ISCAN
RX bytes:1190 acl:0 sco:0 events:67 errors:0
TX bytes:1076 acl:0 sco:0 commands:67 errors:0

[root@localhost ~]#

Linux reste invisible mais l'inverse est vrai aussi !


Patrick
Site web    
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 496

Le 03/01/2019 à 14h49
Moince alors ! Quelle déception ...

En dernier lieu, vu que ton rfkill donne 2 cartes bluetooth
1: ideapad_bluetooth: Bluetooth
4: hci0: Bluetooth

Si on fait une recherche "linux hci0 ideapad_bluetooth" sur le net, tu ne sembles pas être le seul à avoir le problème ... problème de firmware apparemment. C'est quoi ta machine ?

Peut-être que ça n'est pas le hci0 qu'il faut configurer, mais ideapad_bluetooth ? Perso Je t'ai indiqué hci0 car je n'ai que ça sur ma machine; de plus, dans btmon, sans rien faire, on voit qu'il se met à à l'écoute de hci0.

Du coup, ça donne quoi si tu refais les manip sur ideapad_bluetooth ?
Juste une précision : si tu peux t'assurer qu'au redémarrage de ta machine, les cartes ne soient pas remise en soft_blocked (par défaut) ;)
Edité par choucroot Le 03/01/2019 à 15h04



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 03/01/2019 à 23h32
Ma machine est un Lenovo Ideapad

Aucune des cartes Bluetooth n'est passée en soft_blocked

La seconde carte Bluetooth semble correctement configurée
[root@localhost ~]# hciconfig ideapad_bluetooth
hci0: Type: Primary Bus: USB
BD Address: 4C:BB:58:C0:CF:74 ACL MTU: 820:8 SCO MTU: 255:16
UP RUNNING PSCAN ISCAN
RX bytes:1232 acl:0 sco:0 events:74 errors:0
TX bytes:2546 acl:0 sco:0 commands:74 errors:0

[root@localhost ~]#


Patrick
Site web    
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 496

Le 04/01/2019 à 10h36
_ ideapad_bluetooth ayant la même adresse BD Address que hci0, j'imagine que ça pointe sur le même "circuit".

_ Vu sur d'autres distrib, il y a pléthore d' "IdeaPad" différents, avec certains qui pose problème mais a priori pas de sur le bluetooth ( cf https://doc.ubuntu-fr.org/liste_portables_lenovo?&#autres_series ). T'es dans la liste ?

_ Chez lenovo, ils listent la compatibilité de leur matos avec linux, mais seul un ideapad présent ! ( https://support.lenovo.com/fr/fr/solutions/pd031426 ). Et Mageia pas dans le tableau, c'est pas normal ;-)

Là je sèche. Es-tu en dual boot et si oui sous Windows le bluetooth fonctionne-t-il ? ( parce que si c'est l'antenne du blutooth qui est foutue, ou un truc dans le genre qui fait que physiquement il ne peut émettre ou recevoir, on ne pourra pas le déceler comme ça )



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 04/01/2019 à 13h42
Tu as raison, j'aurai du commencer par ce test.

La visibilité est totale entre le portable sous Windows et le téléphone.

Le problème n'est donc pas matériel.

Merci beaucoup pour ton assistance.


Patrick
Site web    
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 496

Le 04/01/2019 à 14h01
Bon. Dommage qu'on n'ait pas réussi à régler le problème.

Peut-être peux-tu aussi renommer ce fil avec comme titre "${ta machine} et bluetooth KO". Car ça semble spécifique à ton Lenovo, et pour le coup ça ne vient pas du "Bluetooth soft blocked : Yes" . Tu pourras alors être visible sur un moteur de recherche et pourquoi pas toucher des gens qui ont (eu) le même problème.

Ou peut-être un expert bluetooth pour prendre le relais ? :hello:



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Pat91 Membre non connecté

Rang

Avatar

Inscrit le : 31/05/2017 à 15h08

Localisation : region parisienne

Messages: 87

Le 05/01/2019 à 00h45
Comment procéder pour modifier le titre ?


Patrick
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie