Connexion

Forum

Logiciels » Bureautique LibreOffice 6.1 bugs gênants liés à KDE qui ne seront pas corrigés Certains rendent difficile l'utilisation d'Impress

Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 940

Le 28/12/2018 à 14h53
Bonjour tout le monde,

donc les développeurs de LibreOffice ayant traîné des pieds pour prendre en charge KDE 5, on se retrouve, depuis les versions 6 (donc pas uniquement la 6.1), avec des bugs gênants qui, dans certains cas, rendent presque impossible l'utilisation d'Impress avec un bureau Plasma.

Pour l'un d'entre eux, impossibilité de réduire la taille de la présentation sans faire planter LibreOffice (j'en ai un autre qui fait geler l'ordinateur...), réponse officielle d'un des gars qui s'occupe des bugs :

Citation :
kde5: remove older kde/tde plugins, and references to that
KDE4 is out of maintenance upstream since Nov. 2014, and binaries
provided by TDF have switched to KDE5 as the official backend.


De ce que je comprends c’est un peu, beaucoup, du foutage de gueule (comme si c'était de notre faute si les dév. ont merdé sur ce coup là). Bref.

Que doit-on faire pour régler le problème de notre côté ? Des idées ? C'est d'autant plus important avec Mageia 7 dans les starting-blocks.

Merci.


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6847

Le 28/12/2018 à 15h57
Bonjour Ysabeau,
As-tu le rpm libreoffice-kde4 installé ?
Si oui, je pense qu'il faut le désinstaller. Quel est le résultat ?
Ce que je comprends, c'est que le support de KDE4 est viré. Ça me parait normal. Maintenant, il n'y aurait donc rien de prévu pour Plasma5 ?


Yves
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 940

Le 28/12/2018 à 16h32
Autant je comprends que le support KDE4 soit viré, autant je ne comprends pas pourquoi la version LibreOffice que tu télécharges du site de LibreOffice contienne ça et que quand tu l'installes, elle ne semble prévue que pour KDE 4. C'est là où est le foutage de gueule intégral de mon point de vue.

Donc personnellement j'ai la dernière version, la 6.1.4.2 téléchargée du site de LibreOffice et voilà ce qu'elle me dit :

Version: 6.1.4.2
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4;
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded

Je n'ai pas choisi la version, j'ai pris celle qui se proposait. J'avoue ne pas comprendre ce qu'il faut faire. Comment désinstaller le rpm kde 4 sans désinstaller tout LibreOffice ?

Et s'il n'y a rien de prévu pour Plasma ça va poser des problèmes pour Mageia qui semble préférer ce bureau non ?


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
stroibe974 Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 13/08/2018 à 16h22

Localisation : Réunion

Messages: 1013

Le 28/12/2018 à 17h25
À mon avis, la réponse se trouve quelque part ici, dans les paquets pour Mageia 7 :

Citation :

libreoffice-kde4 : LibreOffice KDE4 integration plug-in
libreoffice-kf5 : LibreOffice KDE Frameworks 5 integration plug-in


Donc je dirais : à l'avenir, il faudra installer libreoffice-kf5 à la place, pour une bonne intégration à Plasma. Edité par stroibe974 Le 28/12/2018 à 17h31


Mageia 7 (64bits) - Plasma - Intel Core i7-8700K @ 3.70Ghz - 16Go RAM
frenchmageiauser_9c2c8
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6847

Le 28/12/2018 à 17h29
Ah oui, j'aurais dû me souvenir que tu utilisais la version "bundle". Dans ce cas, il n'y a pas de rpm à désinstaller.
Je présume que l'apport essentiel est de changer les fenêtres de gestion d'ouverture et d'enregistrement des fichiers. Ce n'est pas un blocage si cette modification n'est pas faite. Les utilisateurs de Mageia s'en remettront.
Si le rapport a été fermé, c'est que les références à KDE4 sont supprimées. Et ce que semble dire le gars, c'est qu'il n'est pas nécessaire de faire une correction puisque par défaut, c'est KDE5 qui est utilisé. Il reste qu'il faut le temps que les modifications arrivent, je suppose (la modif date du 17 décembre).
En attendant tu peux peut être utiliser la variable d'environnement SAL_USE_VCLPLUGIN=gtk3 ou SAL_USE_VCLPLUGIN=gen
(par exemple en préfixe du lancement de LO en ligne de commande).


Yves
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 940

Le 28/12/2018 à 17h46
stroibe974 :
Donc je dirais : à l'avenir, il faudra installer libreoffice-kf5 à la place, pour une bonne intégration à Plasma.


Va falloir rajouter ça en gros dans une doc quelque part à mon avis.


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 940

Le 28/12/2018 à 17h48
Papoteur :
En attendant tu peux peut être utiliser la variable d'environnement SAL_USE_VCLPLUGIN=gtk3 ou SAL_USE_VCLPLUGIN=gen
(par exemple en préfixe du lancement de LO en ligne de commande).


Honnêtement je ne saurais pas faire et si ça ne garantie pas les résultats, je peux espérer que la prochaine version de LibreOffice tiendra réellement compte de KDE5 et sera débarrassée de ces gros bugs.


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
stroibe974 Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 13/08/2018 à 16h22

Localisation : Réunion

Messages: 1013

Le 28/12/2018 à 20h02
Ysabeau :
stroibe974 :
Donc je dirais : à l'avenir, il faudra installer libreoffice-kf5 à la place, pour une bonne intégration à Plasma.


Va falloir rajouter ça en gros dans une doc quelque part à mon avis.


Apparemment, c'est prévu comme une dépendance : je viens de lancer « urpmi libreoffice » sur ma Cauldron, et le système me demande de choisir entre :
- libreoffice-kde4
- libreoffice-kf5
- libreoffice-x11

D'ailleurs, je me demande s'il ne devrait pas y avoir libreoffice-gtk3 parmi les choix, puisque ce dernier est prévu pour l'intégration GTK+3... Si d'autres pouvaient donner leur avis, avant que je fasse un rapport de bug :mafia:


Mageia 7 (64bits) - Plasma - Intel Core i7-8700K @ 3.70Ghz - 16Go RAM
frenchmageiauser_9c2c8
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 940

Le 29/12/2018 à 13h46
stroibe974 :
Apparemment, c'est prévu comme une dépendance


Cela s'installerait donc automatiquement en fonction de la configuration du système ?

Sinon, est-il possible de récupérer cette version pour que je puisse l'installer sur mon Mageia 6 et vérifier que ça fonctionne bien ?


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
stroibe974 Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 13/08/2018 à 16h22

Localisation : Réunion

Messages: 1013

Le 29/12/2018 à 18h57
Ysabeau :
stroibe974 :
Apparemment, c'est prévu comme une dépendance


Cela s'installerait donc automatiquement en fonction de la configuration du système ?


Normalement, oui !

Ysabeau :

Sinon, est-il possible de récupérer cette version pour que je puisse l'installer sur mon Mageia 6 et vérifier que ça fonctionne bien ?


Je ne pense pas... Mais sur la Cauldron, ça fonctionne bien avec le RPM de Libreoffice 6.1.4 !


Mageia 7 (64bits) - Plasma - Intel Core i7-8700K @ 3.70Ghz - 16Go RAM
frenchmageiauser_9c2c8
   
cmoifp Membre non connecté

Rang

Avatar

Inscrit le : 01/01/2013 à 18h41

Messages: 938

Le 07/01/2019 à 10h50
Bonjour à toutes et tous,

Je ne souhaitais ouvrir un nouveau sujet. Je ne sais pas si cela a un rapport, mais LibreOffice 6.1.4.2 ne fonctionne plus. Dans le détail : Désolé, le paquetage suivant ne peut pas être sélectionné :

– libreoffice-6.1.4.2-2.mga7.x86_64

Je pense que c’est dû à libpython3.6m.so.1.0 parce que libreoffice-pyuno ne s’installe par manque de cette bibliothèque.


Carte Mère MSI FM2 A75MA E35
Processeur socket FM2 AMD A4-5300 AMD Radeon HD 7480D Graphics, 2 coeurs, 3,40 GHz
   
Ysabeau Membre non connecté

Rang

Avatar

Inscrit le : 09/08/2015 à 17h23

Messages: 940

Le 11/01/2019 à 15h56
cmoifp :
Je ne souhaitais ouvrir un nouveau sujet. Je ne sais pas si cela a un rapport, mais LibreOffice 6.1.4.2 ne fonctionne plus. Dans le détail : Désolé, le paquetage suivant ne peut pas être sélectionné :

– libreoffice-6.1.4.2-2.mga7.x86_64


Aucune idée, mais, as-tu retenté depuis ? J'ai déjà eu ce genre de problème, en recommençant plus tard (pas forcément le même jour) j'ai pu récupérer le paquet que je voulais.


OS préféré Mageia 6 (LXDE) et 7 (XFCE), CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie