Connexion

Forum

Système et matériels » Cartes graphiques et webcams Bumblebee et cartes Nvidia 720M et 740M Ça marche sur la 740M et pas sur la 720M

euclide24 Membre non connecté

Rang

Avatar

Inscrit le : 02/06/2011 à 20h27

Localisation : Dordogne - Lot et Garonne

Messages: 344

Le 28/10/2018 à 11h15
Bonjour.

Je rencontre un problème de fonctionnement de bumblebee sur un portable Asus X75V équipé d'une carte graphique Nvidia 720M, alors que tout fonctionne sur un autre portable Asus R751J équipé d'une carte graphique Nvidia 740M.

J'ai essayé de voir les différences entre les 2 ordinateurs.

D'abord celui qui fonctionne normalement (avec la 740M).

La carte Nvidia est bien éteinte par défaut, vérifié par la commande
Code BASH :
$ optirun --status


Puis je teste l'allumage et le bon fonctionnement de la carte nvidia avec la commande
Code BASH :
 $ optirun glxspheres64


Et la carte s'éteint normalement, vu avec
Code BASH :
$ optirun --status


Pour le portable qui ne fonctionne pas correctement (avec la 720M).

La carte Nvidia est allumée par défaut.

Puis la commande suivante conduit à une erreur
Code BASH :
 $ optirun glxspheres64
[ 1247.898883] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[ 1247.898923] [ERROR]Aborting because fallback start is disabled.


Et encore
Code BASH :
$ optirun --status
Bumblebee status: Error (3.2.1-2016-11-07-Format:%h$): Could not load GPU driver


Je redémarre le service bumblebee avec :
Code BASH :
systemctl restart bumblebeed.service


Mais ça ne règle pas le problème.

Une bonne âme aurait une idée ?
Je continue à chercher de mon côté. Edité par euclide24 Le 28/10/2018 à 11h34


Fixe ASUS A88X-Plus
Mageia 7 - KDE 64
A8-7600 – 8 Go
Portable ACER 5315
Mageia 5 - KDE 64
Intel Celeron M – 2 Go
Portable Elitegroup i-Buddie
Mageia 1 - LXDE 32
P4 – 1 Go
Portable ASUS F75VC
Mageia 7 - KDE 64
i5-3230M – 12 Go
Portable ASUS X75VD
Mageia 7 - KDE 64
i5-3337U – 12 Go
Portable ASUS R751J
Mageia 7 - KDE 64
i7-4700HQ – 6 Go
Portable ASUS K756U
Mageia 7 - KDE 64
i7-6500U – 4 Go
   
euclide24 Membre non connecté

Rang

Avatar

Inscrit le : 02/06/2011 à 20h27

Localisation : Dordogne - Lot et Garonne

Messages: 344

Le 28/10/2018 à 11h24
J'apporte quelques précisions.

Les deux ordinateurs ont les 2 paquets dkms-nvidia-current et x11-driver-video-nvidia-current (NVIDIA kernel module for GeForce 420 and later cards)
Celui qui marche est en version 390.87 et l'autre en version 410.57.

Je remarque aussi que la commande
Code BASH :
# lsmod | grep video

donne notamment :

Sur celui qui marche :
Code BASH :
video                  45056  2 asus_wmi,i915


Et sur celui qui ne marche pas :
Code BASH :
video                  45056  1 i915
Edité par euclide24 Le 28/10/2018 à 11h25


Fixe ASUS A88X-Plus
Mageia 7 - KDE 64
A8-7600 – 8 Go
Portable ACER 5315
Mageia 5 - KDE 64
Intel Celeron M – 2 Go
Portable Elitegroup i-Buddie
Mageia 1 - LXDE 32
P4 – 1 Go
Portable ASUS F75VC
Mageia 7 - KDE 64
i5-3230M – 12 Go
Portable ASUS X75VD
Mageia 7 - KDE 64
i5-3337U – 12 Go
Portable ASUS R751J
Mageia 7 - KDE 64
i7-4700HQ – 6 Go
Portable ASUS K756U
Mageia 7 - KDE 64
i7-6500U – 4 Go
   
cmoifp Membre non connecté

Rang

Avatar

Inscrit le : 01/01/2013 à 18h41

Messages: 909

Le 28/10/2018 à 11h27
Je pense que cela vient de dkms-nvidia. J’ai le même problème avec ma carte graphique 760M.


Carte Mère MSI FM2 A75MA E35
Processeur socket FM2 AMD A4-5300 AMD Radeon HD 7480D Graphics, 2 coeurs, 3,40 GHz
   
euclide24 Membre non connecté

Rang

Avatar

Inscrit le : 02/06/2011 à 20h27

Localisation : Dordogne - Lot et Garonne

Messages: 344

Le 28/10/2018 à 11h28
Ok, merci. Je me sens moins seul.


Fixe ASUS A88X-Plus
Mageia 7 - KDE 64
A8-7600 – 8 Go
Portable ACER 5315
Mageia 5 - KDE 64
Intel Celeron M – 2 Go
Portable Elitegroup i-Buddie
Mageia 1 - LXDE 32
P4 – 1 Go
Portable ASUS F75VC
Mageia 7 - KDE 64
i5-3230M – 12 Go
Portable ASUS X75VD
Mageia 7 - KDE 64
i5-3337U – 12 Go
Portable ASUS R751J
Mageia 7 - KDE 64
i7-4700HQ – 6 Go
Portable ASUS K756U
Mageia 7 - KDE 64
i7-6500U – 4 Go
   
cmoifp Membre non connecté

Rang

Avatar

Inscrit le : 01/01/2013 à 18h41

Messages: 909

Le 28/10/2018 à 11h30
Oui, mais ça ne résout pas le problème.


Carte Mère MSI FM2 A75MA E35
Processeur socket FM2 AMD A4-5300 AMD Radeon HD 7480D Graphics, 2 coeurs, 3,40 GHz
   
euclide24 Membre non connecté

Rang

Avatar

Inscrit le : 02/06/2011 à 20h27

Localisation : Dordogne - Lot et Garonne

Messages: 344

Le 28/10/2018 à 11h35
cmoifp :
Oui, mais ça ne résout pas le problème.


Je vais chercher dans les jours qui viennent.
J'ai vu quelques posts où d'autres distributions ont rencontré le même problème.


Fixe ASUS A88X-Plus
Mageia 7 - KDE 64
A8-7600 – 8 Go
Portable ACER 5315
Mageia 5 - KDE 64
Intel Celeron M – 2 Go
Portable Elitegroup i-Buddie
Mageia 1 - LXDE 32
P4 – 1 Go
Portable ASUS F75VC
Mageia 7 - KDE 64
i5-3230M – 12 Go
Portable ASUS X75VD
Mageia 7 - KDE 64
i5-3337U – 12 Go
Portable ASUS R751J
Mageia 7 - KDE 64
i7-4700HQ – 6 Go
Portable ASUS K756U
Mageia 7 - KDE 64
i7-6500U – 4 Go
   
euclide24 Membre non connecté

Rang

Avatar

Inscrit le : 02/06/2011 à 20h27

Localisation : Dordogne - Lot et Garonne

Messages: 344

Le 28/10/2018 à 17h06
En continuant à bidouiller, j'ai tenté d'installer mageia-prime mais sans succès.

D'après ce que j'ai compris, mageia-prime m'a installé la version précédente des drivers nvidia (390.87) à la place de la version 410.57

Quand j'ai voulu réinstaller bumblebee en ligne de commande, j'ai eu un message d'erreur m'indiquant qu'il ne pouvait pas s'installer à cause d'une dépendance avec une version plus ancienne (la 390.57).

En passant par le CCM, je n'ai pas eu un tel message, et l'installation de bumblebee s'est passée normalement, avec retour à la version 410.57

Mais le problème subsiste.

Donc cela semble confirmer ce que disait cmoifp, à savoir un problème avec la dernière version de dkms-nvidia. Edité par euclide24 Le 28/10/2018 à 17h06


Fixe ASUS A88X-Plus
Mageia 7 - KDE 64
A8-7600 – 8 Go
Portable ACER 5315
Mageia 5 - KDE 64
Intel Celeron M – 2 Go
Portable Elitegroup i-Buddie
Mageia 1 - LXDE 32
P4 – 1 Go
Portable ASUS F75VC
Mageia 7 - KDE 64
i5-3230M – 12 Go
Portable ASUS X75VD
Mageia 7 - KDE 64
i5-3337U – 12 Go
Portable ASUS R751J
Mageia 7 - KDE 64
i7-4700HQ – 6 Go
Portable ASUS K756U
Mageia 7 - KDE 64
i7-6500U – 4 Go
   
euclide24 Membre non connecté

Rang

Avatar

Inscrit le : 02/06/2011 à 20h27

Localisation : Dordogne - Lot et Garonne

Messages: 344

Le 29/10/2018 à 14h56
Modification au niveau de la version des paquetages :
dkms-nvidia-current
nvidia-current-doc-html
x11-driver-video-nvidia-current

C'est en version 410.66


Fixe ASUS A88X-Plus
Mageia 7 - KDE 64
A8-7600 – 8 Go
Portable ACER 5315
Mageia 5 - KDE 64
Intel Celeron M – 2 Go
Portable Elitegroup i-Buddie
Mageia 1 - LXDE 32
P4 – 1 Go
Portable ASUS F75VC
Mageia 7 - KDE 64
i5-3230M – 12 Go
Portable ASUS X75VD
Mageia 7 - KDE 64
i5-3337U – 12 Go
Portable ASUS R751J
Mageia 7 - KDE 64
i7-4700HQ – 6 Go
Portable ASUS K756U
Mageia 7 - KDE 64
i7-6500U – 4 Go
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie