Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Réseau Internet Wi-Fi [Réglé] Wake on lan, wake on wan Comment débloquer le WOL

bermisch Membre non connecté

Rang

Avatar

Inscrit le : 18/05/2013 à 10h41

Localisation : ardèche

Messages: 130

Le 26/08/2018 à 12h36
Bonjour,
J'ai un PC sur le LAN personnel derrière une livebox qui me sert de "serveur perso" mais le trafic ne justifie pas qu'il soit ON LINE en permanence, pour de la lecture de photos à distance en particulier, si bien qu'il faut le démarrer par WAKE ON LINE quand on veut accéder. Ça se fait très bien via un site spécialisé : depicus.com.Le problème est que le WOL est inhibé lors de la mise sous tension du système (coupure de courant volontaire ou non) .
Il est nécessaire d'exécuter une commande spéciale pour activer le WOL quand on remet le courant :
Code TEXT :
ethtool -s <nom de l'interface ethernet> wol g
 

Cette commande doit être exécutée automatiquement avant même le login. Quel est le meilleur endroit pour la mettre, sachant que je suis avec systemd. Peut-on la mettre dans /etc/init.d/network ou ailleurs ? Il s'agit qu'elle soit exécutée au premier démarrage [manuel] du PC (et des suivants) après coupure de courant. Cette commande reste active tant que la carte mère est alimentée, même à l'arrêt par shutdown -h, à fortiori en veille.
Il faudrait qu'on la garde même en cas de mise à jour des scripts de démarrage, et pour les niveaux de fonctionnement courants (2,3,4,et 5 ?)

CDT


2 PC intel X86 sous Mageia - 64 bits - 8G bits mémoire, KDE dont un avec serveur LDAP "wake-on-waned "
. + portable amilo (mageia 32 ) livebox orange ADSL avec. Wifi ..
Lien pour l'allumage : du pc avec serveur LDAP :
https://www.depicus.com/wake-on-lan/woli?m=BCAEC58C7279&i=bermisch.ddns.net&s=255.255.255.255&p=9
Lien pour le site lui-même : http://bermisch.ddns.net
(erreur 403 à ce niveau mais .../cpg15x donne accès à coppermine avec id et passwd ...) sur ip dynamique (ddns)
Site web    
bermisch Membre non connecté

Rang

Avatar

Inscrit le : 18/05/2013 à 10h41

Localisation : ardèche

Messages: 130

Le 26/08/2018 à 14h27
Hi,
Je dois préciser que l'appel de depicus.com ne permet que d'allumer le PC avec un paquet magique wake-on-wan/lan , c'est ce qui se passe quand on clique le lien fourni dans la signature. Quelqu'un l'a fait tout à l'heure (souriez, vous êtes filmé :) ). Mais ça ne sert pas à grand chose pour le moment, le serveur LDAP http Apache correspondant donne une erreur 403 accès interdit au niveau racine. Ce serveur est destiné aux gens de la famille et aux proches pour recevoir un "thesaurus" de photos ( coppermine) . Il est possible d'ailleurs de fournir un espace visiteur "sans mot de passe" . Le tout en lecture seule pour raison de sécurité.
Il conviendrait d'arrêter le PC au bout d'un certain temps d'inactivité (c'est moi qui paie l'électricité). J'ai cru comprendre qu'on pouvait lire le nombre d'utilisateurs connectés par une tâche de fond. On est dans le P2P.

CDT


2 PC intel X86 sous Mageia - 64 bits - 8G bits mémoire, KDE dont un avec serveur LDAP "wake-on-waned "
. + portable amilo (mageia 32 ) livebox orange ADSL avec. Wifi ..
Lien pour l'allumage : du pc avec serveur LDAP :
https://www.depicus.com/wake-on-lan/woli?m=BCAEC58C7279&i=bermisch.ddns.net&s=255.255.255.255&p=9
Lien pour le site lui-même : http://bermisch.ddns.net
(erreur 403 à ce niveau mais .../cpg15x donne accès à coppermine avec id et passwd ...) sur ip dynamique (ddns)
Site web    
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 2769

Le 26/08/2018 à 20h20
Bonjour,

"le WOL est inhibé lors de la mise sous tension du système" => c' est à cause de la carte Asus ! ;-)


Sinon, plutôt que de taper la commande à chaque fois, il n' y a pas une option dans le bios/uefi qui permet de régler ce paramètre de manière permanente ?
   
bermisch Membre non connecté

Rang

Avatar

Inscrit le : 18/05/2013 à 10h41

Localisation : ardèche

Messages: 130

Le 27/08/2018 à 19h40
Le problème semble connu pour un certain nombre de cartes mères. En fait le bios permet le démarrage à partir d'une carte NIC PCIE -l'onglet "power"- et ne comporte qu'une seule option : enabled ou disabled conservée en mémoire semi permanente des options bios. Certains ont inventé une mini usine à gaz pour faire du WOL un service de systemd mais ce n'est pas très satisfaisant. Surtout qu'il faut spécifier dans la commande ethtool l'interface qui a désormais un nom bizarre genre enp4s0.
L'idée serait d'insérer la commande dans les scripts de démarrage réseau
genre /etc/sysconfig/network-scripts/ifup-eth mais ce script est assez abscons pour moi et il ne faut pas faire n'importe quoi.
Si quelqu'un connait bien ce script, il est le bienvenu.


2 PC intel X86 sous Mageia - 64 bits - 8G bits mémoire, KDE dont un avec serveur LDAP "wake-on-waned "
. + portable amilo (mageia 32 ) livebox orange ADSL avec. Wifi ..
Lien pour l'allumage : du pc avec serveur LDAP :
https://www.depicus.com/wake-on-lan/woli?m=BCAEC58C7279&i=bermisch.ddns.net&s=255.255.255.255&p=9
Lien pour le site lui-même : http://bermisch.ddns.net
(erreur 403 à ce niveau mais .../cpg15x donne accès à coppermine avec id et passwd ...) sur ip dynamique (ddns)
Site web    
Eric David Petit Membre non connecté

Rang

Avatar

Inscrit le : 01/01/2020 à 15h53

Localisation : Bordeaux

Messages: 2

Le 01/01/2020 à 15h56
Bonjour,
même si le post est ancien cela pourrait aider :-)
Dans mon cas, pour mon usage, car si il y a une coupure de courant, perte de paramètre de la carte réseau, il faudra au moins une ouverture de session.
donc dans mon ~/.bashrc j'ai ajouté ceci :
#permet d'activer le WOL de la carte reseau :
Interface=`ifconfig -a | grep BROADCAST | cut -s -d : -f1`
echo $Interface":activation du WOL"
sudo ethtool -s $Interface wol g


Éventuellement on pourrai imaginer la création d'un service :-) Edité par Eric David Petit Le 01/01/2020 à 15h57
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie