Connexion

Forum

Système et matériels » Cartes son et périphériques audio [Réglé] Bang & Ofulsen technologie non reconnu

Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 492

Le 16/07/2018 à 20h47
Bonjour à tous,

J'ai un gros problème de son que je n'arrive pas à régler...
J'ai un hp omen 17-w009nf avec la technologie bang et ofulsen pour les sorties audio. Je suis sous plasma Mga6

J'aime écouter de la musique mais le son est horrible, j'ai que des aigus et la différence est flagrante lorsque je switch sous windows.

En cherchant sur internet, j'ai trouver un tuto mais pour ubuntu ici.

Il y a 5 étapes a suivre.
-la première étape ne sert à rien
-La seconde étape est réussie, j'ai généré un script qui liste ma config audio
-La troisième étape concerne l'installation et j'ai 3 choix. La première solution ne marche pas avec la commande. La seconde solution est d'installer plein de paquet en lien avec hda, pas très détaillé mais j'ai installé pas mal de truc avec le ccm sans résultat.

Ils disent ensuite d'installer un égaliseur pour pulse (ce que j'ai fait) et de Cocher la case "EQ Enable" pour avoir des basses mais impossible de trouver cette fichu case... J'ai l'impression d'avoir 3-4 égaliseurs pulse pour le volume (volume audio, contrôle du volume pulse audio, préférence de pulseaudio etc.); J'ai essayer avec gnome-égaliseur mais rien du tout.

Ensuite il faut jouer avec HDAJackRetask pour les interrupteurs audio, et là j'avoue être complètement paumé.

Une idée pour m'aider ?

Je vous remercie


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
OursoNoir Membre non connecté

Rang

Avatar

Inscrit le : 14/02/2016 à 18h38

Localisation : Sisteron (04)

Messages: 154

Le 23/08/2018 à 08h09


Fiat Lux !
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 492

Le 25/08/2018 à 15h02
Bonjour Oursonoir,

AU fait, j'ai eu le problème de grésillement aussi mais j'ai résolu le problème.

Ici, le problème vient du fait que j'ai 4 écouteurs, 2 écouteurs classiques qui fonctionnent et 2 Subwoofers qui ne fonctionnent pas (donc pas de bass et pas de rendu en profondeur du son). Dommage de ne pas pouvoir profiter d'un bon son quand on a un bon système.

En recherchant sur internet, j'ai trouvé plusieurs solutions :

méthode 1
: en remplacant dans le fichier /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=auto position_fix=0


le mot "auto" peut être remplacé par une des références de cette liste, en fonction de ton codec. Cela n'a pas marché pour moi.

méthode 2
: utiliser HDAJackRetask diponible que sur ubuntu... J'essaie en ce moment même de créer un rpm mais la version de alsa-tools n'est pas la même que sur une autre distribution donc je galère.

méthode 3
: configurer les fichiers de paramétrage audio selon ce tuto.
J'ai essayé mais je n'arrive pas encore a trouver la config des enceintes sur mon laptop pour que ça fonctionne donc je vais retenter encore !!!




config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 492

Le 09/09/2018 à 11h02
Bonjour à tous,

Je reviens après avoir un peu mis les mains dans le cambouis !
Donc en recherchant sur internet, pas mal de gens avait ce problème de bass qui ne fonctionnait pas et la plupart des forums indiquaient d'aller modifier les fichiers de paramétrage audio pulse et alsa.

Voici ce que j'ai fait :

Mettre dans le fichier /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=auto position_fix=0


Ensuite, mettre dans le fichier /etc/pulse/deamon.conf
enable-lfe-remixing = yes


Enfin, dans le dossier /usr/share/pulseaudio/alsa-mixer/profile-sets/
Il y a le fichier extra-hdmi.conf qui établi le profil des enceintes de l'ordinateur (enfin c'est ce que j'ai compris)
Dans ce même dossier, il y a le fichier default.conf ou il y a toute une liste de paramétrage prédéfini et il suffit de choisir le bon profil et de le copier dans le fichier extra-hdmi.conf pour que cela fonctionne.

Après je me suis rendu qu'il y avait bien plus simple, cette dernière étape n'est pas nécessaire puisque les profils se trouve également dans "contrôle de volume", onglet configuration... :malade:

J'ai testé et je suis arrivé a retrouver mes bass (même si le son n'est pas aussi bon que sous windows, j'ai retrouvé quand même mes bass et ça fait plaisir !)


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 492

Le 03/11/2018 à 16h31
Bonjour,

Toujours pas satisfait du son qui sortait des enceintes de mon ordinateur portable, je me suis encore penché sur le problème et j'ai réussi (enfin !) a voir la solution. Je pense que je vais faire un page wiki pour ceux que ça intéresse.

Tout d'abord, j'ai lancé cette commande
aplay -L


pour voir quel type de sortie j'avais.
Caché :
[fab@localhost ~]$ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
default
Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
HDA Intel PCH, ALC295 Analog
Default Audio Device
front:CARD=PCH,DEV=0
HDA Intel PCH, ALC295 Analog
Front speakers
surround21:CARD=PCH,DEV=0
HDA Intel PCH, ALC295 Analog
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
HDA Intel PCH, ALC295 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
HDA Intel PCH, ALC295 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
HDA Intel PCH, ALC295 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
HDA Intel PCH, ALC295 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
HDA Intel PCH, ALC295 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=PCH,DEV=0
HDA Intel PCH, HDMI 0
HDMI Audio Output
hdmi:CARD=PCH,DEV=1
HDA Intel PCH, HDMI 1
HDMI Audio Output
hdmi:CARD=PCH,DEV=2
HDA Intel PCH, HDMI 2
HDMI Audio Output
hdmi:CARD=PCH,DEV=3
HDA Intel PCH, HDMI 3
HDMI Audio Output
hdmi:CARD=PCH,DEV=4
HDA Intel PCH, HDMI 4
HDMI Audio Output


Ici on peut voit que j'ai un surround 71 donc 7.1. Or en écoutant de la musique, j'ai l'impression d'avoir toujours que 2 écouteurs...

Donc ce que je suggère :

- La première méthode simple :
c'est de configurer pulse audio-controle volume


et de choisir le type de sono qui correspond a notre matériel. Si ça marche tant mieux, pour ma part, cela n'a pas fonctionné à cause de valeurs par défaut de pulse audio. Donc j'ai du creuser un peu plus pour arriver a la méthode 2

- méthode 2 approfondie

il faut modifier les valeurs du fichiers /etc/pulse/deamon.conf

et remplacer ces valeurs :
; enable-lfe-remixing = no
; default-sample-channels = 2
; default-channel-map = front-left,front-right




par
enable-lfe-remixing = yes
default-sample-channels = 8
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe, side-left, side-right


en n'oubliant pas de supprimer les ";". Et là on peut se dire, oh mon dieu, c'est du chinois ces valeurs !!!
Pas de panique, on peut les récupérer en fonction du type de sono dans le fichier /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf
(qui sont les valeurs de paramètres de la méthode 1.


Et voila !







config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
richard24 Membre non connecté

Rang

Avatar

Inscrit le : 04/01/2014 à 13h04

Localisation : Dordogne

Messages: 64

Le 04/11/2018 à 19h17
Bonsoir,
J'ai un portable ASUS 6930G avec CG nvidia 9600m et un lecteur bluray d'origine.
Depuis 15 ans que je l'ai je ne jamais pu sortir un son sur la prise HDMI qu'en 2.0.

J'ai utilisé la "méthode 2 approfondie" et j'ai ainsi pu avoir une sortie en 7.1 (mon portable est branché sur un ampli home vidéo - qui fonctionne parfaitement avec un lecteur bluray autonome et une TV Full HD).

J'ai toutefois remarqué via "Configuration du système/Multimédia" que l'affectation du son sur les enceintes n'était pas correcte; en effet, je constate une inversion des sorties "rear-left" avec "front-center" et "rear-right" avec "lfe".
J'ai essayé de changer l'ordre dans "defaut-channel-map" mais cela n'a rien changé au pb.

Je ne sais plus où chercher pour le moment. Peut-être dans la configuration de Alsa...

Cordialement




Richard24
CM: ASUS Z170ProGaming - Proc : i5/6500 - RAM: 16Go - CV: Asus NVIDIA 1050
- scanner EPSON V350 PHOTO - Mageïa 7 KDE Plasma
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 492

Le 05/11/2018 à 20h30
Bonsoir Richard,

richard24 :
j'ai ainsi pu avoir une sortie en 7.1


C'est déjà une belle avancée mais je ne suis pas un expert dans les home cinéma et je ne vois pas ou et comment gérer la répartition du son dans les bonnes enceintes...

richard24 :
Peut-être dans la configuration de Alsa...


Surement !

Une piste : Tu peux essayer de copier un des profils 7.1 (il y en a plusieurs) du fichier /usr/share/pulseaudio/alsa-mixer/profile-sets/ default.conf

dans le fichier /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf

N'oublie pas de relancer alsa a chaque test (en redémarrant l'ordinateur) Edité par Fafoulous Le 05/11/2018 à 20h31


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie