Connexion

Forum

Logiciels » Virtualisation et Émulation message d'erreur à l'ouverture machine virtuelle mg6 virtu 5.2.8 r120774

bruno-legrand Membre non connecté

Rang

Avatar

Inscrit le : 07/03/2015 à 18h42

Messages: 184

Le 13/04/2018 à 12h15
Salut tout le monde :)


J'ai des soucis avec Virtuabox sous Mageia, voilà ce qu'il me met en message d'erreur dès que je veux ouvrir une machine virtuelle :
Virtualbox :
RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing

'/sbin/vboxconfig'

may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user



J'ai tenté de rentrer dans un terminal administrateur la commande "/sbin/vboxconfig" qu'indique Vitualbox, et le terminal me retourne "Aucun dossier ou fichier de ce type".


Pouvez-vous m'aider s'il vous plaît, ou m'aider sinon à remonter proprement ce bug.
funix Membre non connecté

Rang

Avatar

Inscrit le : 17/12/2012 à 21h03

Messages: 461

Le 13/04/2018 à 12h37
c'est écrit dans le texte, la version du module virtual box (vboxdrv) ne correspond pas au binaire virtualbox, donc effectivement il y a un problème d'install quelque part, à moins qu'il y ait eu une mise à jour avec l'ancien module toujours chargé et dans ce cas un

systemctl stop vboxdrv
systemctl start vboxdrv

pourrait résoudre ton problème


FUNIX - http://www.funix.org
Mettez un pingouin dans votre PC
Blog - http://olivier.hoarau.org
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Messages: 6017

Le 13/04/2018 à 13h52
Bonjour,
tu peux vérifier que virtualbox a été compilé pour le noyau que tu utilises.
Pour connaître la version du noyau :
uname -r
ou depuis Mageia Welcome, dans le coin en haut à droite.
Pour les versions pour lesquelles virtualbox a été compilé, voir dans /var/lib/dkms/virtualbox/

Si la compilation pour le noyau actuel n'est pas faite :
# dkms build virtualbox
# dkms install virtualbox


Yves
   
bruno-legrand Membre non connecté

Rang

Avatar

Inscrit le : 07/03/2015 à 18h42

Messages: 184

Le 13/04/2018 à 22h14
Merci pour vos réponses. :)

Pour info j'avais installé virtualbox avec le mageia welcome.

@ Papoteur, mon noyau actuellement utilisé est le 4.9.56 (les autres noyaux sont installés mais mon ordi me met un message d'erreur et ne veut pas démarrer avec les noyau supérieur au 4.9, même en recovery mode, ça ce sera l'objet d'un autre fil de discussion).

J'ai regardé dans le dossier virtualbox que tu indiques, ben sur 2 sous-dossiers virtualbox présents (une fois arrivé au chemin exact que tu indiques) il y à marqué dans leur noms 4.14.30


Je pense que je vais laisser tomber, quelque chose me dit que si je résous mon soucis de noyau (je ferai prochainement un fil de discussion pour ça), je n'aurai plus de soucis avec virtualbox, vu que sur mon ordi portable j'ai également Mageia 6 mais avec le dernier noyau et j'ai virtualbox dessus qui lui arrive à ouvrir ma machine virtuelle.
nmrk.n Membre non connecté

Rang

Avatar

Inscrit le : 20/04/2018 à 16h27

Messages: 23

Le 26/11/2018 à 12h27

Bonjour,

Dommage qu'il n'y ait pas de solution proposée, si quelqu'un a une idée elle sera la bienvenue :



Ma façon d'aborder la question :

Comment désinstaller (supprimer complètement) tout ce qui concerne l'application VirtualBox OSE et/ou PUEL (sauf les systèmes virtuels invités que l'on désire conserver que je ne considère pas comme faisant partie de l'application) ?

Le but étant de pouvoir réinstaller proprement selon la méthode de son choix (VirtualBox OSE ou PUEL) afin de satisfaire

"Make sure that you do not mix the OSE version and the PUEL version of VirtualBox."

:merci:


Penguin Pro 5 GNU/Linux Desktop | Processeur : Intel Quad-Core i5-4430 (6M Cache, up to 3.20 GHz) | Memory: 32GB DDR3 |
Hard Drive: ATA Samsung SSD 840 256Go table::dos et Seagate Barracuda ATA ST2000DM001-1CH1 2To 64Mo table::gpt |
DVD : TSSTcorp CDDVDW SH-224DB | Wireless N: Wireless N PCIe Card (TPE-N300PCIE4) | Graphics Card: GeForce 8400GS 1GB PCI Express 2.0 Video Card |
Bluetooth: USB Micro Adapter v2 (TPE-USBBLUV2) | Keyboard & Mouse: Selecline sans fils | Monitor: Essentiel B Photo + Essentiel B Studio 2 x 1920 x 1080 |
Printer : All-in-one HP Officejet 6500A Plus connectée wifi | Power Cable: Europe - Plug Type Europlug (CEE 7/16) | Autre Distribution : Trisquel |
   
joel Membre non connecté

Rang

Avatar

Inscrit le : 10/04/2011 à 18h32

Messages: 406

Le 02/12/2018 à 16h13
Bonjour nmrk.n,

nmrk.n :

Dommage qu'il n'y ait pas de solution proposée, si quelqu'un a une idée elle sera la bienvenue :


Je ne sais pas si mon intervention sera utile, n'ayant pas eu le même message d'erreur.

Mais voici ce que j'avais fait en août 2017 :

Désinstallation :
# /opt/VirtualBox/uninstall.sh

Réinstallation :
# urpmi virtualbox

Mais j'avais toujours le même message d'erreur...

En suivant https://forum.ubuntu-fr.org/viewtopic.php?id=153383 :
# modprobe vboxdrv
# kwrite /etc/modules
et j'y ai ajouté cette ligne :
vboxdrv

Voir aussi https://passiongnulinux.tuxfamily.org/tag/virtualbox/


joel
   
dantou Membre non connecté

Rang

Avatar

Inscrit le : 04/01/2011 à 00h46

Messages: 491

Le 07/12/2018 à 20h20
Bonjour. Moi j'ai le même type de message, mais sans numéro d'erreur :

" Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/sbin/vboxconfig'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT."

et il me manque également /sbin/vboxconfig.

J'ai désinstallé et réinstallé par le CCM, puis par urpme (j'en ai supprimé ainsi des anciennes morceaux de versions antérieures) puis réinstallé par urpmi, mais sans succès.. Toujours le même panneau d'erreur.
Merci de vos réactions.

et en essayant comme indiqué ci-dessus, j'obtiens :
modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.18.20-desktop-1.mga6 Edité par dantou Le 07/12/2018 à 20h21


Acer Aspire E 15 (E5-573G-565T) -Intel I5 4200 - Geforce 940M - 4 G° RAM - DD 1 T° - Dual-boot Windows 10 / Mageia 5
PC Antec Sonata 300 - Intel E8400 - ATI Radeon HD 5470 - 6 G° RAM - 1 T° DD1 - 500 G° DD2 -
Synology DS 215J - DSM 5.2 - DD : WD Red 3 T°
Magéia 64 bits - KDE - Digikam -
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 675

Le 07/12/2018 à 21h53
Bonjour,

Le choix du noyau 4.18.20 est un choix volontaire ?

Il me semble que pour Mageia 6, il n' est que dans les backports.

Or il me semble qu' à chaque montée de version de virtualbox ou du kernel, il y a installation du paquet virtualbox-kernel- correspondant au couple version kernel/version virtualbox.

Or dans les backports, il ne me semble pas avoir vu ce paquet. Donc, il est probable que le vboxdrv ne soit pas compilé pour le 4.18.20.

On peut toujours essayer de demander à dkms de construire le module:

dkms build -m virtualbox
dkms install -m virtualbox

Mais je me demande s'il ne manquera pas quelque chose quand même. En effet, j' ai par exemple ces deux lignes ( et je ne sais à quoi correspond le binaire).

virtualbox, 5.2.22-1.1.mga6, 4.14.78-desktop-1.mga6, x86_64: installed
virtualbox, 5.2.22-1.1.mga6, 4.14.78-desktop-1.mga6, x86_64: installed-binary from 4.14.78-desktop-1.mga6

Edité par nic80 Le 07/12/2018 à 22h03
   
teutates Membre non connecté

Rang

Avatar

Inscrit le : 24/09/2011 à 01h41

Messages: 1266

Le 07/12/2018 à 22h12
nic80 :
Bonjour,

Le choix du noyau 4.18.20 est un choix volontaire ?

Il me semble que pour Mageia 6, il n' est que dans les backports.

Or il me semble qu' à chaque montée de version de virtualbox ou du kernel, il y a installation du paquet virtualbox-kernel- correspondant au couple version kernel/version virtualbox.

Or dans les backports, il ne me semble pas avoir vu ce paquet. Donc, il est probable que le vboxdrv ne soit pas compilé pour le 4.18.20.

On peut toujours essayer de demander à dkms de construire le module:

dkms build -m virtualbox
dkms install -m virtualbox

Mais je me demande s'il ne manquera pas quelque chose quand même. En effet, j' ai par exemple ces deux lignes ( et je ne sais à quoi correspond le binaire).

virtualbox, 5.2.22-1.1.mga6, 4.14.78-desktop-1.mga6, x86_64: installed
virtualbox, 5.2.22-1.1.mga6, 4.14.78-desktop-1.mga6, x86_64: installed-binary from 4.14.78-desktop-1.mga6


Bonjour,

Je confirme intégralement. J'utilise un noyau 4.18.12 suite à l'activation (je ne sais plus pourquoi) du dépôt backport. J'ai ensuite eu ce message d'erreur avec VirtualBox. J'ai solutionné en installant le paquet dkms-virtualbox. A noter que j'ai, depuis, désactivé ce dépôt Backport.


Toco y se gausos !
Asus P8Z68-V/GEN3 + Intel Core i2700k + RAM G-Skill 4x4Go PC 12800 + Gainward Geforce GTX 560 - 2 Go + Western Digital Velociraptor 300 Go (Mageia Cauldron / Fedora / Debian / Manjaro / Windows 10) + Seagate Barracuda 7200t/mn - 2 To - Sata 3 (data) + SSD Samsung 64 Go - Sata 3 (Mageia stable)
Site web    
Yuusha Membre non connecté

Rang

Avatar

Inscrit le : 04/07/2017 à 19h52

Messages: 284

Le 22/01/2019 à 19h36
teutates :

Bonjour,

Je confirme intégralement. J'utilise un noyau 4.18.12 suite à l'activation (je ne sais plus pourquoi) du dépôt backport. J'ai ensuite eu ce message d'erreur avec VirtualBox. J'ai solutionné en installant le paquet dkms-virtualbox. A noter que j'ai, depuis, désactivé ce dépôt Backport.


Pour compléter, une fois le paquet dkms-virtualbox installé et le bon module compilé (au prochain redémarrage par exemple), il faut ensuite faire la commande :
Code BASH :
systemctl enable vboxdrv

afin de s'assurer que le noyau virtualbox démarre bien à chaque fois. Edité par Yuusha Le 22/01/2019 à 19h36
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie