Connexion

Forum

Packaging LXQt 0.12.0 pour Mageia6

Dimitrios Membre non connecté

Rang

Avatar

Inscrit le : 24/02/2008 à 00h55

Localisation : Paris

Messages: 321

Le 27/01/2018 à 05h17
Bonjour,

Paquets pour LXQt 0.12.0 pour Mageia 6, rpm de Compton pour transparence (composition) avec openbox
Un thème (transparence complète) Artemis



http://www.mageia-gr.org/rpm/6/x86_64/
http://www.mageia-gr.org/rpm/6/noarch/
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6704

Le 27/01/2018 à 07h52
C'est joli.
Utilises-tu Lxqt tous les jours ? Quel est ton retour ?


Yves
   
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 3880

Le 27/01/2018 à 08h56
je ne connaissais pas LXQT
alors pour les ignorants comme moi :

LXDE est un environnement de bureau libre pour les systèmes de type Unix, tels que Linux ou BSD. Le nom LXDE est l'acronyme de "Lightweight X11 Desktop Environment" (environnement de bureau X11 léger). Le projet LXDE a fusionné avec Razor-qt pour donner LXQt. LXQt, une fois opérationnel remplacera LXDE.

Razor-qt est un environnement de bureau basé sur Qt pour le système X Window3,4. Le projet n'est plus maintenu depuis son rapprochement avec LXDE, dont la philosophie est proche. Le développement se poursuit désormais avec LXQt5,6, dont la première version (0.7.0) a été publiée le 7 mai 2014

https://lxqt.org/


.
____________________________________________ :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
Dimitrios Membre non connecté

Rang

Avatar

Inscrit le : 24/02/2008 à 00h55

Localisation : Paris

Messages: 321

Le 17/02/2018 à 08h09
C'est mon environnement principal depuis quelques années
Très stable et rapide

Site web    
neoclust Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 09/02/2013 à 15h43

Messages: 282

Le 06/03/2018 à 12h52
j'ai commencé a mettre a jour lxqt en 0.12.0 pour mageia6 ( repos officiels )

Si tu veux me donner un coup de main je suis preneur :)


Membre de l'équipe KDE
   
paiiou Membre non connecté

Rang

Avatar

Inscrit le : 12/10/2010 à 13h42

Localisation : Courtavon Haut-Rhin

Messages: 509

Le 21/03/2018 à 19h58
Dimitrios :
C'est mon environnement principal depuis quelques années
Très stable et rapide



LXQt est également devenu mon environnement de travail.
Je l'avais installé sur un 'viel' ordinateur pour tester.
Il équipe également mon 'très vieil' ordinateur, utilisé pour les sauvegardes.

Très stable et assez rapide, même sur un Athlon XP 2600+, mga5 au départ. Mga6 maintenant.

Cela fait un moment que je souhaite ne plus utiliser Gtk ni KDE que je considèrent comme étant des "monstres", mais ce n'est pas évident
J'ai réussi à créer des paquetages plymouth + lxqt sans dépendance à Gtk ni KDE. C'est trèe léger et rapide.

Paiiou


Des bureaux efficaces et rapides : Xfce, LXQt
En savoir plus sur Païou http://paiiou.free.fr
3 ordinateurs avec LXQt, 1 ordinateur avec Xfce
Site web    
neoclust Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 09/02/2013 à 15h43

Messages: 282

Le 24/03/2018 à 00h31
si cela vous tente je veux bien votre retour d'utilisation du LxQT qui est dans update_testing. :)


Membre de l'équipe KDE
   
paiiou Membre non connecté

Rang

Avatar

Inscrit le : 12/10/2010 à 13h42

Localisation : Courtavon Haut-Rhin

Messages: 509

Le 25/03/2018 à 17h22
neoclust :
si cela vous tente je veux bien votre retour d'utilisation du LxQT qui est dans update_testing. :)


Je viens de tester une installation en choisissant : Environnement graphique/Bureau LXQt => 1350 pkgs

J'obtiens es messages d'erreur suivants :
file /usr/sharelxqt/themes/xxx/lxqt-panel.qss from install of lxqt-themes-0.12.0-1.mga6.noarch conflicts with file from package lxqt-common-0.11.0-1.mga6, et ceci pour les différents thèmes du package lxqt-themes.

Par ailleurs, j'ai récemment complété la traduction française de lxqt. Il est préférable d'utiliser git et le lxqt-l10n de GitHub, plutôt que d'utiliser le paquetage lxqt-l10n. Ceci est d'ailleurs valable pour toutes les traductions récentes et qui ne se trouvent que dans GitHub.

Georges alias Paiiou


Des bureaux efficaces et rapides : Xfce, LXQt
En savoir plus sur Païou http://paiiou.free.fr
3 ordinateurs avec LXQt, 1 ordinateur avec Xfce
Site web    
Visiteur

Visiteur

Rang

Avatar

Message : 0

Le 28/03/2018 à 12h16
Je crois qu'il y a un problème de hdlist ou de rpm :

http://www.mageia-gr.org/rpm/6/x86_64/pcmanfm-qt-0.12.0-2mgr6.x86_64.rpm
... échec de la récupération : wget a échoué : sortie avec 8

L'installation a échoué, certains fichiers sont manquants :
http://www.mageia-gr.org/rpm/6/x86_64/pcmanfm-qt-0.12.0-2mgr6.x86_64.rpm
Vous devriez mettre à jour votre base de données urpmi.

Et sur le dépôt je vois :
http://www.mageia-gr.org/rpm/6/x86_64/pcmanfm-qt-0.12.0-1mgr6.x86_64.rpm
   
neoclust Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 09/02/2013 à 15h43

Messages: 282

Le 03/05/2018 à 19h09
vous pouvez essayer mageia 6 updates_testing.
La mise a jour est presque prete pour diffusion:

https://bugs.mageia.org/show_bug.cgi?id=22669

Mes tests sont concluants


Membre de l'équipe KDE
   
neoclust Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 09/02/2013 à 15h43

Messages: 282

Le 03/05/2018 à 19h13
paiiou :
neoclust :
si cela vous tente je veux bien votre retour d'utilisation du LxQT qui est dans update_testing. :)


Je viens de tester une installation en choisissant : Environnement graphique/Bureau LXQt => 1350 pkgs

J'obtiens es messages d'erreur suivants :
file /usr/sharelxqt/themes/xxx/lxqt-panel.qss from install of lxqt-themes-0.12.0-1.mga6.noarch conflicts with file from package lxqt-common-0.11.0-1.mga6, et ceci pour les différents thèmes du package lxqt-themes.

Par ailleurs, j'ai récemment complété la traduction française de lxqt. Il est préférable d'utiliser git et le lxqt-l10n de GitHub, plutôt que d'utiliser le paquetage lxqt-l10n. Ceci est d'ailleurs valable pour toutes les traductions récentes et qui ne se trouvent que dans GitHub.

Georges alias Paiiou


je n'avais pas vu cette erreur.

Je corrige


Membre de l'équipe KDE
   
neoclust Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 09/02/2013 à 15h43

Messages: 282

Le 03/05/2018 à 19h27
Le conflit lxqt-themes devrait être corrigé dans le prochain rpm


Membre de l'équipe KDE
   
neoclust Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 09/02/2013 à 15h43

Messages: 282

Le 03/05/2018 à 19h37
dans quel repo se trouve lxqt-l10n ?


Membre de l'équipe KDE
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6704

Le 04/05/2018 à 08h04
Je pense que c'est ça :
https://github.com/lxqt/lxqt-l10n


Yves
   
paiiou Membre non connecté

Rang

Avatar

Inscrit le : 12/10/2010 à 13h42

Localisation : Courtavon Haut-Rhin

Messages: 509

Le 04/05/2018 à 09h37
neoclust :
Le conflit lxqt-themes devrait être corrigé dans le prochain rpm


Dans mon paquet task-lxqt, j'ai ajouté deux lignes :
Conflicts: lxqt-common < 0.12.0
Obsoletes: lxqt-common < 0.12.0

Par ailleurs, j'ai une vieille machine dont le processeur ne gère pas sse2. De ce fait sddm bogue. J'installe donc xdm et sddm et dans un post script
J'ai donc également ajouté les lignes suivantes :
# Display manager
Requires: xdm
Requires: sddm
%post
dm=xdm
[ $(grep -c sse2 /proc/cpuinfo) -gt 0 ] && dm=sddm
conf_file="/etc/sysconfig/desktop"
if [ -f $conf_file ]; then
if [ $(grep -q DISPLAYMANAGER $conf_file) ]; then # aucun display manager
echo "DISPLAYMANAGER=$dm" >> $conf_file
else
sed -i "s!DISPLAYMANAGER=.*!DISPLAYMANAGER=$dm!" $conf_file
fi
else
echo "DISPLAYMANAGER=$dm" > $conf_file
fi
Edité par paiiou Le 04/05/2018 à 09h37


Des bureaux efficaces et rapides : Xfce, LXQt
En savoir plus sur Païou http://paiiou.free.fr
3 ordinateurs avec LXQt, 1 ordinateur avec Xfce
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie