Connexion

Forum

Packaging skypeforlinux installation

alder Membre non connecté

Rang

Avatar

Inscrit le : 17/06/2010 à 14h03

Messages: 16

Le 17/06/2017 à 13h43
Bonjour,
Il parait que skype version 4.3, celle qui est installée d'origine sur mageia5 et cauldron, ne fonctionnera plus après le 1er juillet 2017, d'après skype; or comme il ne semble pas qu'une maj soit prévue, et comme se priver de skype est impensable, j'ai installé skypeforlinux (package téléchargé sur le site skype); ce package existe sous les versions rpm et deb; curieusement la version rpm ne s'installe pas avec urpmi (je n'ai pas essayé la commande rpm -ivh); le truc consiste à transformer la version deb en rpm à l'aide de la commande alien (sans l'option --scripts), et là ça marche nickel
cordialement
   
Ami age Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 18/08/2012 à 10h28

Localisation : France

Messages: 3883

Le 18/06/2017 à 08h32
merci de l'info


.
____________________________________________ :silence:
::d . .Un petit clic pour Mageia ? =>> CLIQUEZ I C I :
.
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6716

Le 18/06/2017 à 08h50
Bonjour,
de mémoire, il faut avoir installé gnome-keyring, et forcer l'installation. La dépendance est nommée différemment de ce que fournit Mageia.
Dans Mageia 6, ce n'est pas nécessaire, le paquet gnome-keyring a été modifié pour fournir ce que recherche skypeforlinux.
Pour forcer l'installation
urpmi --allow-nodeps /chemin/vers/le/rpm/skypeblabla.rpm


Yves
   
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2681

Le 18/06/2017 à 11h12
Bonjour

Je pense qu'il serait souhaitable de retirer temporairement le paquet get-skype des dépôts Mageia, quitte à documenter sur le wiki la procédure d'installation manuelle pour Mageia 6 en attendant que le rpm évolue. Pour information, le rapport de bug 21053 a été ouvert. Edité par Papoteur Le 18/06/2017 à 13h41


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go avec driver libre-1 DD 500 Go Western Digital WD20EARS Caviar Blue en mode SATA -SSD 512 Gb Samsung Evo -Raspberry PI2 -Synology DS216+
   
Bidulle Membre non connecté

Rang

Avatar

Inscrit le : 30/05/2016 à 00h14

Localisation : Metz

Messages: 177

Le 23/06/2017 à 17h39
vouf :
Bonjour

Je pense qu'il serait souhaitable de retirer temporairement le paquet get-skype des dépôts Mageia, quitte à documenter sur le wiki la procédure d'installation manuelle pour Mageia 6 en attendant que le rpm évolue. Pour information, le rapport de bug 21053 a été ouvert.


sur le site skype il en parle que que la version 4.3 va être useless au 01/07/2017 donc pas la peine de se casser la tete a faire un nouveau "get-skype"

le rpm du site fonctionne sur ma mga5 64 bit
https://www.skype.com/fr/download-skype/skype-for-computer/

juste besoin de rebuild libsecret-0.18.5-2.mga6.src.rpm qui est absent des dépôts mga5
Edité par Bidulle Le 23/06/2017 à 17h44
   
shaka Membre non connecté

Rang

Avatar

Inscrit le : 03/09/2011 à 01h30

Localisation : Brazzaville / Congo

Messages: 492

Le 23/06/2017 à 18h16
Bidulle :
...
juste besoin de rebuild libsecret-0.18.5-2.mga6.src.rpm qui est absent des dépôts mga5


salut :hello:

non il n'est pas absent, il a juste un autre nom ::d

https://www.mageialinux-online.org/forum/topic-23613-1+skype-4-3-obsolete.php#m227730 Edité par shaka Le 23/06/2017 à 18h17


:frime: < mon OS: Mageia6 64 & XFCE4 > < ma machine: HP EliteBook Workstation >
avec: < Proc - INTEL Core i7 @ 3,4 GHz > < RAM - 4*8 Go > < CG - Nvidia Quadro 5010M - 4Go>
   
Bidulle Membre non connecté

Rang

Avatar

Inscrit le : 30/05/2016 à 00h14

Localisation : Metz

Messages: 177

Le 02/07/2017 à 17h26
Bidulle:
shaka:
Bidulle:
...
juste besoin de rebuild libsecret-0.18.5-2.mga6.src.rpm qui est absent des dépôts mga5


salut :hello:

non il n'est pas absent, il a juste un autre nom ::d

https://www.mageialinux-online.org/forum/topic-23613-1+skype-4-3-obsolete.php#m227730


oui j'vais vu ce thread, mais à moins de ne pas avoir d'autre choix,s'y connaitre un minimum et ne pas avoir peur de se prendre la tête les options de rpm "--nodeps, --force etc" sont à éviter
quand on installe un rpm il s’arrête sur le premier "requires" manquant et en fait il peut y en avoir plein d'autres derrières qui manquent de plus le requis manquant peut lui-meme en appeler d'autres et ainsi de suite et cela peut franchement vite devenir prise de tête et bon chacun fait ce qu'il veut mais d’expérience quand tu as le src.rpm de dispo dans mageia
de plus "patché" par Akien
faut pas hésiter à rebuild surtout sur ce genre de librarie où à tout casser tu en a pour 5 mins

bref chacun fait comme il veut mais si on peut faire simple sans mal de crane :)

voici un dossier contenant le rebuild pour mga5 64 bit ainsi que le src.rpm adapté à mga5
libsecret
   
Bidulle Membre non connecté

Rang

Avatar

Inscrit le : 30/05/2016 à 00h14

Localisation : Metz

Messages: 177

Le 21/07/2017 à 23h43
Pour ceux que cela intéresse voila la méthode pour rajouter le dépôt et installer skypeforlinux derniere version uniquement pour mga6 et 64 bits
ouvrir une console
Code BASH :
su

Code TEXT :
Mot de passe root

Code BASH :
dnf config-manager --add-repo https://repo.skype.com/data/skype-stable.repo 
dnf install skypeforlinux -y 
Edité par Bidulle Le 21/07/2017 à 23h43
   
vouf Membre non connecté

Rang

Avatar

Webmaster Administrateur

Inscrit le : 16/08/2008 à 08h27

Localisation : Gironde

Messages: 2681

Le 22/07/2017 à 08h10
Bonjour

Bien vu Bidulle !! Ça mériterai d'être ajouté au wiki !!


Mageia 7 64 bits Plasma 5- Asus B150 Pro Gaming-Intel Core i7 6700-16 Go Hyper X Fury DDR4-2133 Mhz-Asus Strix GTX Nvidia 1060 - Go avec driver libre-1 DD 500 Go Western Digital WD20EARS Caviar Blue en mode SATA -SSD 512 Gb Samsung Evo -Raspberry PI2 -Synology DS216+
   
Natitou Membre non connecté

Rang

Avatar

Inscrit le : 03/02/2008 à 12h18

Localisation : Cachan (Val de Marne)

Messages: 242

Le 22/07/2017 à 16h57
Bonjour,

Je suis sous Mageia 6 Plasma x64, j'ai pu installer Skypeforlinux RPM que j'ai téléchargé sur le site de Skype sans problème, par contre celui-ci ne mémorise pas mes identifiant et mot de passe !
A chaque fois Wallet était lancé, j'ai donc entré un mot de passe dans Wallet et depuis celui-ci me demande mon mot de passe Wallet à chaque démarrage ce qui est énervant !
Que faire pour que Skype se lance automatiquement comme par le passé ? Je n'ai rien trouvé dans la configuration de cette version de Skype pour configurer la mémorisation du mot de passe.
   
Bidulle Membre non connecté

Rang

Avatar

Inscrit le : 30/05/2016 à 00h14

Localisation : Metz

Messages: 177

Le 23/07/2017 à 03h22
Natitou :
Bonjour,

Je suis sous Mageia 6 Plasma x64, j'ai pu installer Skypeforlinux RPM que j'ai téléchargé sur le site de Skype sans problème, par contre celui-ci ne mémorise pas mes identifiant et mot de passe !
A chaque fois Wallet était lancé, j'ai donc entré un mot de passe dans Wallet et depuis celui-ci me demande mon mot de passe Wallet à chaque démarrage ce qui est énervant !
Que faire pour que Skype se lance automatiquement comme par le passé ? Je n'ai rien trouvé dans la configuration de cette version de Skype pour configurer la mémorisation du mot de passe.


1) Menu --> Outils --> Outils système --> KwalletManager
2)Fichier --> Exporter avec chiffrement puis Exporter en XML ( par securité mieux de faire les deux sauvegardes)
3) Fichier --> Supprimer le porte-feuille

et tu déconnectes de plasma et te reconnectes de nouveau kwallet va créer un nouveau porte-feuille quand tu arrives au mot de passe tu laisses vide

en ce qui concerne le démarrage automatique de Skype
Outils --> et tu coches lancer à la connexion, tu peux aussi cocher lancer en réduit

voilà normalement tout devrait aller comme tu le souhaite Edité par Bidulle Le 23/07/2017 à 03h23
   
Natitou Membre non connecté

Rang

Avatar

Inscrit le : 03/02/2008 à 12h18

Localisation : Cachan (Val de Marne)

Messages: 242

Le 24/07/2017 à 20h13
Bonjour,
Bidulle :
[quote=Natitou]Bonjour,

en ce qui concerne le démarrage automatique de Skype
Outils --> et tu coches lancer à la connexion, tu peux aussi cocher lancer en réduit

voilà normalement tout devrait aller comme tu le souhaite


Merci Bidulle c'est tout bon !
   
henryco Membre non connecté

Rang

Avatar

Inscrit le : 08/06/2014 à 21h48

Messages: 270

Le 10/01/2018 à 13h34
Salut,

J'ai un son pourri (ca craque tellement que c'est à peine comprehensible) avec ce skype pour linux sous une VM (virtualbox) mageia6... La VM etant surdimensionnée à tous les niveaux je ne ne vois vraiment pas quelle peut etre la cause du probleme... des idées ?
   
Bidulle Membre non connecté

Rang

Avatar

Inscrit le : 30/05/2016 à 00h14

Localisation : Metz

Messages: 177

Le 27/10/2019 à 18h03
Bon j'ai pas trop le temps de develloper là donc je vais faire court, voici une methode pour installer la derniere version de skype linux

Ouvrir une console

Code BASH :
su

Code TEXT :
mot de passe root

Code BASH :
urpmi flatpak
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install https://flathub.org/repo/appstream/com.skype.Client.flatpakref

skype-flappak

pour ceux qui veulent une interface graphique gerant flatpak
Code BASH :
su

Code TEXT :
mot de passe root

Code BASH :
urpmi gnome-software


il existe vraiment beaucoup de programme comme skype qui ne sont pas dans les dépots Mageia et qui fonctionne tres bien sous.
Voici la liste vous avez aussi acces a la liste avec gnome-software, juste un conseil donner toujours la priorité aux applications qui sont dans les depots mageia


Edité par Bidulle Le 27/10/2019 à 18h03
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie