Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Imprimantes scanners et Appareils Photo [Réglé] HP 6950 scan ne fonctionne pas

phil-french32 Membre non connecté

Rang

Avatar

Inscrit le : 05/03/2014 à 18h28

Localisation : france

Messages: 131

Le 01/02/2017 à 14h43

Reprise du message précédent

Pour info j'ai une vielle epson office BX300F et le scan n'est pas reconnu lui aussi.Par contre sur ma Lexmark le scan fonctionnait mais pas l'imprimante.... :diable:


[b][/b]
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 531

Le 01/02/2017 à 15h26
Bonjour,

Il y a un fichier dans /etc/sane ou /etc/xsane je crois. Il faut regarder si le scanner hp6950 est bien décommenté.
Je regarderai ce soir à la maison le nom exact du fichier.
J'avais dû modifier ce fichier pour mon scanner Epson.

Xuo. Edité par xuo Le 01/02/2017 à 15h28
   
PapyLinux Membre non connecté

Rang

Avatar

Inscrit le : 23/05/2011 à 20h37

Localisation : Saint-Germain-les-Corbeil

Messages: 876

Le 01/02/2017 à 15h44
Bonjour,

Je suppose que xuo pense au fichier /etc/sane.d/dll.conf. Il faut effectivement décommenter (supprimer le #) les lignes contenant des références HP, y compris hpaio généralement en fin de fichier.

JLB Edité par PapyLinux Le 01/02/2017 à 15h44
   
m@rco123 Membre non connecté

Rang

Avatar

Inscrit le : 15/05/2009 à 08h07

Localisation : Val d'Oise

Messages: 3164

Le 01/02/2017 à 19h26
si tu as tout bien fais :

désinstallé ce que tu as installé
lancé hp-setup

tu dois avoir dans la même console:

Edité par m@rco123 Le 01/02/2017 à 19h27


Lenovo g70-70
cg intel 810 / ssd SanDisk 250Go
Mageia 7.1 plasma 64b

Packard Bell ls11hr
cg intel 810 / ssd SanDisk 128Go
Mageia 7.1 plasma 64b
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8021

Le 02/02/2017 à 13h14
Bonjour,
La version minimale pour cette imprimante est hplip 3.14.10. Donc, çà ne colle pas.
http://hplipopensource.com/hplip-web/supported_devices/officejet.html
Tu as une version 3.15 disponible en activant les dépôts backports Core.
Tu actives ce dépôt.
Tu recherches hplip et sélectionne l'installation de la version 3.15.
Cà devrait aller mieux.


Yves
   
phil-french32 Membre non connecté

Rang

Avatar

Inscrit le : 05/03/2014 à 18h28

Localisation : france

Messages: 131

Le 04/02/2017 à 10h16
Merci, je vais essayer tout ça , je me suis absenté qques jours.


[b][/b]
   
phil-french32 Membre non connecté

Rang

Avatar

Inscrit le : 05/03/2014 à 18h28

Localisation : france

Messages: 131

Le 05/02/2017 à 20h47
Comprends pas j'ai activé les dépôts en question mais je ne capte que hplip debuginfo en version 3.15.11.J'ai essayé d'installer la bibli en manuel mais ça n'a pas marché.


[b][/b]
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8021

Le 06/02/2017 à 09h00
Bonjour,
Quelque chose ne va pas dans la manœuvre.
J'ai testé ici, la version hplip 3.15 apparaît dans la liste.
Il faut vérifier les médias qui sont cochés. Core Backports Debug n'a pas à être coché, mais celui d'au-dessus.

Pour plus de certitude, depuis l'ajout des médias, faire Fichier/Mettre à jour et demander la mise à jour au moins de Core Backports.


Yves
   
phil-french32 Membre non connecté

Rang

Avatar

Inscrit le : 05/03/2014 à 18h28

Localisation : france

Messages: 131

Le 06/02/2017 à 18h30
Désolé mais j'ai les mêmes sources de cochées et la mise à jour effectuée ,résultat pas de hplip 3.15 :diable:


[b][/b]
   
m@rco123 Membre non connecté

Rang

Avatar

Inscrit le : 15/05/2009 à 08h07

Localisation : Val d'Oise

Messages: 3164

Le 06/02/2017 à 18h52
pourtant il y est bien :

Mageia Core Backports i586

hplip-3.15.11-1.mga5.i586.rpmHP printer/all-in-one driver infrastructure

Mageia Core Backports x86_64

hplip-3.15.11-1.mga5.x86_64.rpmHP printer/all-in-one driver infrastructure


https://pkgs.org/download/hplip


Lenovo g70-70
cg intel 810 / ssd SanDisk 250Go
Mageia 7.1 plasma 64b

Packard Bell ls11hr
cg intel 810 / ssd SanDisk 128Go
Mageia 7.1 plasma 64b
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8021

Le 06/02/2017 à 19h34
Autre hypothèse. Le miroir n'est pas à jour : supprimer toutes lignes des médias et rajouter un jeu complet.


Yves
   
m@rco123 Membre non connecté

Rang

Avatar

Inscrit le : 15/05/2009 à 08h07

Localisation : Val d'Oise

Messages: 3164

Le 06/02/2017 à 19h40
sinon, par le lien que j'ai donné, logiquement, il peut l'installer ... mais le mieux, c'est de mettre a jour la liste des miroirs !


Lenovo g70-70
cg intel 810 / ssd SanDisk 250Go
Mageia 7.1 plasma 64b

Packard Bell ls11hr
cg intel 810 / ssd SanDisk 128Go
Mageia 7.1 plasma 64b
   
phil-french32 Membre non connecté

Rang

Avatar

Inscrit le : 05/03/2014 à 18h28

Localisation : france

Messages: 131

Le 07/02/2017 à 12h44
HP Linux Imaging and Printing System (ver. 3.15.11)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.15.11)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: mandrake distro is not found in AUTH_TYPES


Checking for Deprecated items....
error: This distro (i.e unknown 5) is either deprecated or not yet supported.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y


Checking for HPLIP updates....
error: Failed to locate hp-upgrade utility


Checking for Dependencies....
warning: unknown-5 version is not supported. Using unknown-0 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

Kernel: 4.4.39-desktop586-1.mga5 #1 SMP Fri Dec 16 18:34:16 UTC 2016 GNU/Linux
Host: localhost
Proc: 4.4.39-desktop586-1.mga5 #1 SMP Fri Dec 16 18:34:16 UTC 2016 GNU/Linux
Distribution: unknown 5
Bitness: 32 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.15.11
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for unknown distro 5 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.15.11

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.15.11
html=/usr/share/doc/hplip-3.15.11
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=yes
internal-tag=3.15.11
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:


Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 07/02/2017 12:29:15
version = 3.15.11

[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri =
printer_name =
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[upgrade]
notify_upgrade = true
last_upgraded_time = 1486463017.31017
pending_upgrade_time = 0


<Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------------------
| External Dependencies |
--------------------------

gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.14 OK -
scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.24 OK -
xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
policykit PolicyKit - Administrative policy framework OPTIONAL - 0.113 OK -
network network -wget OPTIONAL - 1.15 OK -
avahi-utils avahi-utils OPTIONAL - 0.6.31 OK -
error: dbus DBus - Message bus system REQUIRED - 1.8.20 MISSING 'DBUS may not be installed or not running'

-------------------------
| General Dependencies |
-------------------------

error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 MISSING 'libcrypto needs to be installed'
python-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.0 OK -
reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.1.8 OK -
python-notify Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.3 OK -
python-xml Python XML libraries REQUIRED - 2.1.0 OK -
error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
python2X Python 2.2 or greater - Python programming language REQUIRED 2.2 2.7.9 OK -
pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 REQUIRED 4.0 4.11.3 OK -
error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
libpthread libpthread - POSIX threads library REQUIRED - 2.20 OK -
error: python-devel Python devel - Python development files REQUIRED 2.2 2.7.9 MISSING 'python-devel needs to be installed'
error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
sane SANE - Scanning library REQUIRED - - OK -

---------------
| COMPILEDEP |
---------------

error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - 4.9.2 MISSING 'gcc needs to be installed'
make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.0 OK -

----------------------
| Python Extentions |
----------------------

cupsext CUPS-Extension REQUIRED - 3.15.11 OK -
hpmudext IO-Extension REQUIRED - 3.15.11 OK -

-----------------------
| Scan Configuration |
-----------------------

scanext Scan-SANE-Extension REQUIRED - 3.15.11 OK -
hpaio HPLIP-SANE-Backend REQUIRED - 3.15.11 OK 'hpaio found in /etc/sane.d/dll.conf'

-----------------------
| Other Dependencies |
-----------------------


------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------


EPSON-Stylus-Office-BX300F
--------------------------
Type: Unknown
Device URI: usb://EPSON/Stylus%20Office%20BX300F?serial=4B504A593139353124&interface=1
PPD: /etc/cups/ppd/EPSON-Stylus-Office-BX300F.ppd
warning: Failed to read /etc/cups/ppd/EPSON-Stylus-Office-BX300F.ppd ppd file
PPD Description:
Printer status: printer EPSON-Stylus-Office-BX300F is idle. enabled since sam. 28 janv. 2017 10:41:06 CET
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

HP-OfficeJet-6950
-----------------
Type: Unknown
Device URI: usb://HP/OfficeJet%206950?serial=TH6A321030&interface=1
PPD: /etc/cups/ppd/HP-OfficeJet-6950.ppd
warning: Failed to read /etc/cups/ppd/HP-OfficeJet-6950.ppd ppd file
PPD Description:
Printer status: printer HP-OfficeJet-6950 is idle. enabled since mar. 07 févr. 2017 12:16:26 CET Rendering completed
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

error: Unsupported model: OfficeJet_6950


Checking Permissions....


Checking for Configured Queues....
warning: Fail to read ppd=/etc/cups/ppd/EPSON-Stylus-Office-BX300F.ppd file
warning: Insufficient permission to access file /etc/cups/ppd/EPSON-Stylus-Office-BX300F.ppd
warning: Could not complete Queue(s) configuration check


Checking for HP Properitery Plugin's....
No plug-in printers are configured.

Diagnose completed...



More information on Troubleshooting,How-To's and Support is available on http://hplipopensource.com/hplip-web/index.html


Please close this terminal manually.

J'ai installé la hplip 3.15 manuellement avec les media zéro mais toujours pas de scanner ni avec Xsane ni avec le CCM voila ci-dessus ce que donne HP device manager. au sec.. Ne tenez pas compte de l'Epson.


[b][/b]
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8021

Le 07/02/2017 à 12h58
Bonjour,
Il faut commencer par utiliser la commande hpsetup.


Yves
   
phil-french32 Membre non connecté

Rang

Avatar

Inscrit le : 05/03/2014 à 18h28

Localisation : france

Messages: 131

Le 07/02/2017 à 16h06
Quand je lance hp-setup : error: No devices found on bus: usb et pourtant l'imprimante fonctionne.


[b][/b]
   
m@rco123 Membre non connecté

Rang

Avatar

Inscrit le : 15/05/2009 à 08h07

Localisation : Val d'Oise

Messages: 3164

Le 07/02/2017 à 17h39
error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - 4.9.2 MISSING 'gcc needs to be installed'


Lenovo g70-70
cg intel 810 / ssd SanDisk 250Go
Mageia 7.1 plasma 64b

Packard Bell ls11hr
cg intel 810 / ssd SanDisk 128Go
Mageia 7.1 plasma 64b
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie