Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Cartes son et périphériques audio [Réglé] Impossibilité d'installer ffmpeg tainted

jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 03/12/2016 à 21h25
Bonjour,

J'ai installé Mageia sur le PC de ma fille cet été et lorsqu'elle veut lire une video mp4 elle a l'image mais pas le son
Xine indique "utilise un codec non supporté Codec Audio MPEG4 (ffmpeg) (mp4a)"

J'ai pourtant déjà installé les task codec audio et vidéo

Ce jour j'ai donc désinstallé vlc , mis vlc tainted
Je souhaite installer ffmpeg tainted. Il m'est demandé d'installer 2 autres modules nécessaires à ffmpeg tainted. Je le fais (je ne me rappelle plus de ce qui m'a été demandé car cela semblait marcher)
A la 3ème tentative il m'est indiqué le message suivant (idem en x64)

Désolé, le paquetage suivant ne peut pas être sélectionné :

- ffmpeg-2.4.9-1.mga5.tainted.i586

Questions:
  • comment savoir si son PC est en x64 et quel version de mageia est installé?
  • comment pouvoir installer ce ffmpeg....tainted?
  • est-ce qu'il faudrait que je désinstalle les task codec maintenant que j'ai un vlc tainted pour que j'aie aussi les task codec "tainted"?


Merci d'avance

Nota
J'avoue que je rame dure sur ces questions de vidéo (sin mp4 + certains dvd non lisibles)

Dans le menu rechercher sur un mot donné, je trouve que ce serait intéressant d'avoir dans la fiche résultat la date du fil correspondant (quelque fois on tombe ainsi sur des fils sous mageia 3 qui ne sont peut être plus pertinents avec mageia 4 ou 5)


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 03/12/2016 à 22h03
En regardant ce qui est installé sur le PC j'ai actuellement

les 3 modules théoriquement nécessaires pour l'installation (il y a aussi des modules dépendants)
- libavformat56-2.4.9 1mga5.tainted i586
- libswresample1-2.4.9 1mga5.tainted i586
- libswscaler3-2.4.9 1mga5.tainted i5861

Au niveau ffmpeg j'ai les modules suivants

ffmpeg2theora 0.29 9.mga5 x86_64
fffmpegthumbs 4.14.3 1.mga5 x86_64
gstreamer0.10-ffmpeg 0.10.13 19.mga5 x86_64

Est ce qu'il faudrait que je désinstalle ces 3 là pour pouvoir installer ffmpeg tainted?


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4128

Le 03/12/2016 à 23h40
Bonjour,
Version et architecture :
$ cat /etc/release

On dirait que tu as un PC x86_64 et installé VLC tainted i586. Pour savoir ce que tu as d'installé :
#urpmq -i vlc

A ma connaissance, il n'y qu'un seul type de paquet task-codec.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 04/12/2016 à 17h33
cat/etc/release indique en effet Mageia release 5 for x86_64

urpmq -i vlc donne les choses suivantes:
Code TEXT :
 
Name        : vlc
Version     : 2.2.1
Release     : 1.mga5
Group       : Video/Players
Size        : 32698363                     Architecture: x86_64
Source RPM  : vlc-2.2.1-1.mga5.src.rpm
URL         : http://www.videolan.org/
Summary     : MPEG, MPEG2, DVD and DivX player
Description :
VideoLAN is an OpenSource streaming solution for every OS developed by
students from the Ecole Centrale Paris and developers from all over the
World.
VLC (VideoLAN Client) is a media player that can play MPEG1, MPEG2 and
MPEG4 (aka DivX) files, DVDs, VCDs, SVCDs, from a satellite card, from
a stream sent by VLS (VideoLAN Server), from another VLC, or from a Web
server.
This package contains no CSS unscrambling functionality for DVDs ;
you need the libdvdcss library available from
http://www.videolan.org/libdvdcss/
 
Name        : vlc
Version     : 2.2.1
Release     : 1.1.mga5
Group       : Video/Players
Size        : 32698363                     Architecture: x86_64
Source RPM  : vlc-2.2.1-1.1.mga5.src.rpm
URL         : http://www.videolan.org/
Summary     : MPEG, MPEG2, DVD and DivX player
Description :
VideoLAN is an OpenSource streaming solution for every OS developed by
students from the Ecole Centrale Paris and developers from all over the
World.
VLC (VideoLAN Client) is a media player that can play MPEG1, MPEG2 and
MPEG4 (aka DivX) files, DVDs, VCDs, SVCDs, from a satellite card, from
a stream sent by VLS (VideoLAN Server), from another VLC, or from a Web
server.
This package contains no CSS unscrambling functionality for DVDs ;
you need the libdvdcss library available from
http://www.videolan.org/libdvdcss/
 
Name        : vlc
Version     : 2.2.2
Release     : 1.mga5
Group       : Video/Players
Size        : 38365559                     Architecture: x86_64
Source RPM  : vlc-2.2.2-1.mga5.src.rpm
URL         : http://www.videolan.org/
Summary     : MPEG, MPEG2, DVD and DivX player
Description :
VideoLAN is an OpenSource streaming solution for every OS developed by
students from the Ecole Centrale Paris and developers from all over the
World.
VLC (VideoLAN Client) is a media player that can play MPEG1, MPEG2 and
MPEG4 (aka DivX) files, DVDs, VCDs, SVCDs, from a satellite card, from
a stream sent by VLS (VideoLAN Server), from another VLC, or from a Web
server.
This package contains no CSS unscrambling functionality for DVDs ;
you need the libdvdcss library available from
http://www.videolan.org/libdvdcss/
 
Name        : vlc
Version     : 2.2.3
Release     : 1.mga5
Group       : Video/Players
Size        : 37514595                     Architecture: x86_64
Source RPM  : vlc-2.2.3-1.mga5.src.rpm
URL         : http://www.videolan.org/
Summary     : MPEG, MPEG2, DVD and DivX player
Description :
VideoLAN is an OpenSource streaming solution for every OS developed by
students from the Ecole Centrale Paris and developers from all over the
World.
VLC (VideoLAN Client) is a media player that can play MPEG1, MPEG2 and
MPEG4 (aka DivX) files, DVDs, VCDs, SVCDs, from a satellite card, from
a stream sent by VLS (VideoLAN Server), from another VLC, or from a Web
server.
This package contains no CSS unscrambling functionality for DVDs ;
you need the libdvdcss library available from
http://www.videolan.org/libdvdcss/
 
Name        : vlc
Version     : 2.2.4
Release     : 1.mga5
Group       : Video/Players
Size        : 38451885                     Architecture: x86_64
Source RPM  : vlc-2.2.4-1.mga5.src.rpm
URL         : http://www.videolan.org/
Summary     : MPEG, MPEG2, DVD and DivX player
Description :
VideoLAN is an OpenSource streaming solution for every OS developed by
students from the Ecole Centrale Paris and developers from all over the
World.
VLC (VideoLAN Client) is a media player that can play MPEG1, MPEG2 and
MPEG4 (aka DivX) files, DVDs, VCDs, SVCDs, from a satellite card, from
a stream sent by VLS (VideoLAN Server), from another VLC, or from a Web
server.
This package contains no CSS unscrambling functionality for DVDs ;
you need the libdvdcss library available from
http://www.videolan.org/libdvdcss/
 
Name        : vlc
Version     : 2.2.1
Release     : 1.mga5.tainted
Group       : Video/Players
Size        : 32698363                     Architecture: x86_64
Source RPM  : vlc-2.2.1-1.mga5.tainted.src.rpm
URL         : http://www.videolan.org/
Summary     : MPEG, MPEG2, DVD and DivX player
Description :
VideoLAN is an OpenSource streaming solution for every OS developed by
students from the Ecole Centrale Paris and developers from all over the
World.
VLC (VideoLAN Client) is a media player that can play MPEG1, MPEG2 and
MPEG4 (aka DivX) files, DVDs, VCDs, SVCDs, from a satellite card, from
a stream sent by VLS (VideoLAN Server), from another VLC, or from a Web
server.
This package contains no CSS unscrambling functionality for DVDs ;
you need the libdvdcss library available from
http://www.videolan.org/libdvdcss/
 
 
This package is in the 'tainted' section as it is violating software patents.
 
 
 


En regardant vlc installé j'ai en effet le i 586 donc je le désinstalle et mets l'autre


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 04/12/2016 à 17h44
J'ai installé le vlc tainted x86-64 mais ffpmeg tainted ne peut toujours pas s'installer et toujours le même problème de code audio

J'installe ffpmeg non tainted x86-64 version 2.14... mais toujours le message d'erreur:

Code TEXT :
 
code non supporté: (null)Codec Audio: MPEG4 (ffmpeg) (mp4a)
 


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4128

Le 04/12/2016 à 19h25
D'après ta sortie de urpmq -i vlc, VLC 2.2.4 tainted n'est pas installé.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 04/12/2016 à 22h40
En fin de retour de commande urpmq j'ai:

Code TEXT :
 
Name        : vlc
Version     : 2.2.1
Release     : 1.mga5.tainted
 


Est ce que ce dernier n'est pas mon installation la plus récente car d'après mes souvenirs dans le CCM le tainted me semble installé. Ma fille étant repartie chez elle j'essayerai de le savoir à distance en lui faisant faire les manips par téléphone (ou aux vacances de Noel)

Merci de l'aide :)


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4128

Le 05/12/2016 à 09h58
2.2.1 est une ancienne version tu dois avoir :
[samageia@localhost ~]$ rpm -qa vlc
vlc-2.2.4-1.mga5.tainted


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 18/12/2016 à 20h32
Coucou
J'ai de nouveau le pc de ma fille
Je supprime via CCM un vlc non tainted et quand j'utilise dans la console administrateur la commande
Code TEXT :
rpm -qa | grep vlc 
je ne trouve plus de vlc installé!!
Cependant quand je veux installer un vlc tainted x64 il me dit qu'un vlc est installé!?
Je décide donc de faire un
Code TEXT :
urpmi --auto-update
pour remettre les choses au propre
Après un reset du pc je regarde quel vlc tainted jx64 e peux installer dans le MCC: il me propose la version 2.2.1.1 et ne vois pas la 2.2.4-1
Je l'installe quand même ce qui règle le problème initial de son dans les fichiers mp4: "utilise un codec non supporté Codec Audio MPEG4 (ffmpeg) (mp4a)"
Je considère donc le problème résolu (au moins pour ma fille) :hehe:
Pour information, j'ai sur son pc les fichiers suivants (vlc/codec/ffmpeg):

Code TEXT :
rpm -qa | grep vlc > fichier.txt:
 
lib64vlc5-2.2.4-1.mga5
libvlc5-2.2.4-1.mga5
npapi-vlc-2.0.6-7.mga5
vlc-plugin-pulse-2.2.4-1.mga5
libvlccore8-2.2.4-1.mga5
vlc-plugin-common-2.2.4-1.mga5
lib64vlccore8-2.2.4-1.mga5
phonon-vlc-0.8.2-2.mga5
vlc-2.2.1-1.mga5.tainted
 
rpm -qa | grep vlc > fichier.txt:
 
task-codec-video-4-4.mga5.tainted
apache-commons-codec-1.9-2.mga5
libavcodec56-2.4.13-1.mga5
lib64avcodec56-2.4.13-1.mga5
lib64gstcodecparsers1.0_0-1.4.3-2.mga5.tainted
task-codec-audio-4-4.mga5.tainted
lib64kcodecs5-5.5.0-1.mga5
 
rpm -qa | grep vlc > fichier.txt:
 
gstreamer0.10-ffmpeg-0.10.13-19.mga5
ffmpegthumbs-4.14.3-1.mga5


Pour les débutants linux le
Code TEXT :
> fichier.txt 
envoie le résultat de la commande dans un fichier text
Il faut ensuite taper
Code TEXT :
rm fichier.txt /home 
pour pouvoir le lire via Dolphin et Kwrite
Un
Code TEXT :
rm fichier.txt 
efface ensuite le fichier ;)


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 18/12/2016 à 20h51
Maintenant dans la mise à jour il m'est proposé vlc la version 2.2.4 mais il n'est pas proposé la version tainted (bon je faisais pas attention avant dans les propositions de maj que j'acceptais tout le temps)
Je refuse la maj et regarde dans MCC les choix possibles et la version 2.2.4 de vlc mais la seule proposée est non tainted donc je reste dans la situation actuelle en attendant qu'une 2.2.4 tainted me soit proposée?


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4128

Le 18/12/2016 à 22h13
Bonsoir,
Tu devrais peut-être changer de sources, celles que tu as ne semblent pas à jour.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
zalappy Membre non connecté

Rang

Avatar

Inscrit le : 28/07/2012 à 20h43

Messages: 810

Le 22/12/2016 à 09h35
Pourquoi le VLC du dépôt tainted.

Vous ne le mettez pas dans les dépôts courants (ceux utilisé par tout le monde)
ça serait plus simple, non?
jpanmto Membre non connecté

Rang

Avatar

Inscrit le : 17/09/2014 à 13h26

Localisation : Provence

Messages: 134

Le 22/12/2016 à 10h35
Bonjour,
En regardant les sources le tainted était coché en effet en maj mais pas activé. Après son activation la version tainted 2.2.4 de vlc m'a bien été proposée. J'ai accès également à la dernière version ffmpeg tainted...
Toutes les vidéos et DVD essayés sont lisibles, super :blub:

Citation:
zalappy
Pourquoi le VLC du dépôt tainted.

Vous ne le mettez pas dans les dépôts courants (ceux utilisé par tout le monde)
ça serait plus simple, non?


Pour ce qui est de le mettre dans le dépôt courant, ce serait plus simple mais on perdrait en clarté sur ce qui est du libre, et ce qui ne l'est pas. C'est surtout pour moi la coche activé et maj qui n'était pas trop clair.

Côté amélioration, si c'était possible d'avoir la date de la discussion quand on cherche une solution avec l'outil de recherche ce serait un plus car actuellement on peut se retrouver avec des post qui date de versions antérieures de Mageia et peut être plus trop pertinents
En tout cas merci pour le soutien,
Bon bout d'an comme on dit ici en Provence :hello:


Netbook Asus avec Xfce -> 2016 :) Medion Akoya E6239 testé en 2016 sans pouvoir installer Mageia :pendu:
2016/08 -> Mageia 5 (64) Bureau KDE Ultra-portable why! W840AU contre l'obsolescence programmée :siffle:
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4128

Le 22/12/2016 à 12h10
Bonjour,

zalappy:
Pourquoi le VLC du dépôt tainted.

Vous ne le mettez pas dans les dépôts courants (ceux utilisé par tout le monde)
ça serait plus simple, non?


Les dépots Tainted contiennent les logiciels qui peuvent enfreindre des brevets et des lois sur le droit d'auteur (copyright) dans certains pays dans le monde. Ils doivent donc être séparés des autres.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
zalappy Membre non connecté

Rang

Avatar

Inscrit le : 28/07/2012 à 20h43

Messages: 810

Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie