Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Packaging [Réglé] Rednotebook en version 1.13

Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 545

Le 29/09/2016 à 18h59
Bonjour à tous,

J'essaie en vain de créer mon premier paquet rpm avec le logiciel Rednotebook (site)
Mais je n'y arrive pas...

Sous mageia 5 :
j'ai récuperé le paquet src sous rpmfind.net
Ensuite, j'ai lancé dans la console
Caché:
urpmi --buildrequires rednotebook-1.13-1.fc26.src.rpm


Mais il m'indique un manque de dépendance
Caché:
erreur : Dépendances de construction manquantes:
python2-devel est nécessaire pour rednotebook-1.13-1.mga5.noarch
python2-setuptools est nécessaire pour rednotebook-1.13-1.mga5.noarch


J'essaie d'installer gnome-python-devel et python-setuptools mais ça ne marche pas... c'est peut être a cause du python2 ?!

Sous cauldron : (car les paquets sont peut être plus récent)
je tente la même manipulation et la construction du paquet est réussi ! Mais quand je veux l'installer, il me dit qu'il manque aussi une dépendance de gnome-python2-extras.
J'essaie d'installer gnome-python-extras dans le ccm mais ca ne doit pas être le bon paquet. et impossible de construire

Vous pouvez m 'aider ? que ce soit sous Mg5 ou cauldron, peu m'importe !
:merci:


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 545

Le 29/09/2016 à 19h02
Quand je dis vous pouvez m'aider, je dis pouvez-vous me dire ce qui cloche ou bien faire directement le paquet si c'est pas trop compliqué car c'est possible que je sois une grosse quiche en matière de construction de paquet...

:siffle:


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
magnux77 Membre non connecté

Rang

Avatar

Inscrit le : 21/09/2009 à 11h49

Localisation : Champs-sur-Marne France

Messages: 5424

Le 29/09/2016 à 20h31
Fafoulous:
c'est possible que je sois une grosse quiche
Cette phrase et ton avatar vont bien ensemble ;-)...


...depuis Mandrake 7
Membre de l'April - « promouvoir et défendre le Logiciel Libre»
Soutien Framasoft - « Changer le monde, un octet à la fois»
Config n°1 : cpu=AMD64x6 mem=16G SSD=64G HDD=1T OS=Mageia7-64 DE=Xfce, Config n°2 : Dell Latitude E6410 SSD=120G OS=Mageia7 DE=Xfce, Config n°3 : ThinkpadR40 SSD=32G OS=[Manjaro, Parabola, Mageia6] DE=Xfce, Config n°4 : EeePC901 SSD=20Gb, OS=[SliTaz5/Lxde, Mageia6/Xfce]
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 545

Le 29/09/2016 à 20h55
je fais cette tronche uniquement quand le système répond "erreur" !


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8022

Le 30/09/2016 à 15h08
Bonjour,
il faut modifier le fichier spec pour qu'il soit adapté aux paquets déjà présents dans Mageia.
Mageia n'utilise pas le nommage python2. C'est python, tout court, quand çà concerne le python 2, sinon, c'est python3.
Donc, tu dois avoir gnome-python-devel, python-setuptools et gnome-python-extras
Si c'est juste pour l'essayer, le README dit :
Requirements

Python 2.7 (3.x not supported)
PyYaml (>=3.05)
PyGTK (>=2.16)

pywebkitgtk (>=1.1.5)

Optional:
pygtkspellcheck

Run under Linux (without installation)

$ ./run

donc, tu récupères les sources, tu vérifies si les dépendances sont là et tu exécutes.
python-yaml
python-webkitgtk
pygtk2.0
gnome-python-gtkspell


Yves
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 545

Le 01/10/2016 à 11h05
Merci Papoteur !

Le test a été concluant avec le ./run
Je vais tenter de modifier le fichier spec pour qu'il fonctionne et si ça marche, je le soumettrais peut être à Mga5 ou 6 !

:merci:


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
Fafoulous Membre non connecté

Rang

Avatar

Inscrit le : 27/07/2011 à 18h49

Localisation : Dijon

Messages: 545

Le 01/10/2016 à 12h48
Re-salut,

J'ai effectué les modifications ce matin, et ça a marché (avec quelques difficultés car j'ajoutais des macros mageia inutiles !) mais le paquet s'est bien installé, en français avec les dépendances manquantes, donc tout est ok !!
Je vous sans doute le soumettre pour Mageia 6.

Merci à vous :super:


config : hp omen 17" i5 6400, Dual boot dd 1To win10 + SSD 120Go Mageia 7 KDE,
dual graphique intel hd & nvidia gtx 960m
   
Visiteur

Visiteur

Rang

Avatar

Message : 0

Le 01/10/2016 à 14h04
:resolu:
   
david.david Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 11/02/2008 à 23h08

Localisation : Bernwiller, Haut-Rhin

Messages: 2654

Le 02/10/2016 à 13h19
rednotebook est maintenant dispo sur mga6 et aussi sur mga5 dans le dépôt Core/Backports_testing.


ASUS K73S (portable) :
Intel Core i3-2350M_2.3GHz, 8 GO RAM DDR3, écran LED 17" (1600x900), CG Intel HD intégrée + CG Nvidia GeForce 610M_1GB dédiée (Technologie Optimus), SSD Samsung 850 EVO 250GB + SSD Samsung 850 EVO 500GB.

Mageia 7 - x86_64bits/ KDE Plasma-5.15.4 (DVD édition), c' est de la bombe, vive MAGEIA et toute l'équipe du STAFF MLO.
de david.david <david.david@mageialinux-online.org>
28281 .Venez nous rejoindre sur le salon IRC de MLO
   
Visiteur

Visiteur

Rang

Avatar

Message : 0

Le 04/10/2016 à 21h02
Je vois que le .RPM est dispo aussi sous fédora 24 :)

Et, effectivement, Mageia à la version la plus a jour ^^

Merci david, pour ta disponibilité. Edité par Visiteur Le 04/10/2016 à 21h03
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie