Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Packaging LightWorks une chance qu'il soit intégré ?

lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 25/02/2016 à 21h29

Reprise du message précédent

Si tu fais (en supposant que ton rpm est dans /home/<user>/Téléchargements) :
#urpmi /home/<user>/Téléchargements/lib64cg0-3.0.0018-0.4.mga4.nonfree.x86_64.rpm
le système te réponds quoi ?


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 25/02/2016 à 21h43
Ah eh bien ça c'est bizarre, à moins que la réinstallation suite à ta remarque n'ait abîmé quelque chose, parce que la première fois il m'avait pourtant semblé que l'installation s'était bien faite (la seconde fois suite à ta remarque, je n'ai eu aucune fenêtre après avoir entré mon code root)

Quoi qu'il en soit on m'a répondu :

Citation :
L'installation a échoué : lib64cg0 < 3.0.0018-1 est rendu obsolète par (déjà installé) task-obsolete-5-109.1.mga5.tainted.noarch
Edité par Ourya Le 25/02/2016 à 21h51
Site web    
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 26/02/2016 à 08h49
Des conflits de versions maintenant !
Pour lib64cg0, essaye celui là à la place
https://www.rpmfind.net/linux/RPM/rpmfusion/nonfree/fedora/devel/x86_64/libCg-3.1.0013-4.fc22.x86_64.html
(libCg-3.1.0013-4.fc22 RPM for x86_64 tout en haut)


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 26/02/2016 à 10h54
C'est désespérant :( Non pas que ça n'ait pas marché, je l'ai installé et quand je fais

Citation:
# urpmi libCg-3.1.0013-4.fc22.x86_64.rpm


Je n'ai aucune réponse donc je suppose que tout est bon.

Mais rien ne change pour la réponse sur

Citation:
# urpmi --replacepkgs lwks-12.6.0-amd64.rpm

L'installation a échoué : libCg.so()(64bit) est nécessaire pour lightworks-12.6-1.x86_64
libCgGL.so()(64bit) est nécessaire pour lightworks-12.6-1.x86_64
libcrypto.so.10()(64bit) est nécessaire pour lightworks-12.6-1.x86_64
libcrypto.so.10(libcrypto.so.10)(64bit) est nécessaire pour lightworks-12.6-1.x86_64
Site web    
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 26/02/2016 à 11h54
Bizarre, il nous faudrait un spécialiste de l'installation et de la recherche de fichiers, ce que je ne suis pas.

Fais quand même
#find /lib64/ -name "libCg*" -print
en respectant la casse
moi j'ai :
/lib64/libCg.so
/lib64/libCgGL.so

si tu as la même chose, tente l'installation avec
# urpmi --allow-nodeps lwks-12.6.0-amd64.rpm


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 26/02/2016 à 15h59
Je n'ai rien du tout...

Je verrai bien par la suite, avec peut-être moyen de me dépanner si Cinerella est plus facilement installable (encore que ce ne soit pas gagné...)

Quoi qu'il en soit je te remercie beaucoup pour ton aide
Site web    
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 26/02/2016 à 16h39
C'est donc que les paquets ne sont pas installés.

Utilise le mode verbeux :
# urpmi -v /chemin/vers/le/rpm/libCg-3.1.0013-4.fc22.x86_64.rpm
et donne nous le retour

Sinon tu as Openshot dans les dépôts.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Sylv_01 Membre non connecté

Rang

Avatar

Inscrit le : 29/05/2012 à 18h16

Messages: 592

Le 26/02/2016 à 18h42
Salut,
alors comme promis j'ai installé Cinelerra sur ma Mageia5 64b, ça a l'air de fonctionner...
Tout d'abord, récupérer le tar-gz ici, prendre la version
"64 bit binary tested on Ubuntu-14.04.2."
Puis, décompresser dans ton home, ça va créer un répertoire "cinelerra" avec tout dedans...
Tu ouvres une console depuis ce répertoire (important, sinon il ne se lance pas, je ne sais pas pourquoi..)
Ensuite, dans la console, tu lances ./cinelerra
Normalement, ça va te mettre un message d'erreur parce qu'il ne trouve pas libbz2.so.1.0
c'est normal, car sous Mageia le lien symbolique situé en usr/lib64 et qui pointe vers la librairie libbz2 s'apelle libbz2.so.1, il manque le .0 à la fin.
Donc tu créés un autre lien symbolique libbz2.so.1.0 pointant vers la même lib, et ça devrait rouler...
Ne fais pas comme moi, au début j'avais renommé le lien existant, et ma Mageia ne voulais plus démarrer, car toutes les autres libs appelant celle-ci étaient perdues !
Je n'ai pas eu besoin d'installer autres choses...
Tiens-nous au courant !
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 27/02/2016 à 08h44
J'ai obtenu

Citation:
getting lock on urpmi
using mirror http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/5/x86_64
examen de la liste de synthèse [/var/lib/urpmi/Core Release2/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree Release2/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core 32bit Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core 32bit Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree 32bit Release/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree 32bit Updates/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core Release (distrib1)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core Updates (distrib3)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree Release (distrib11)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree Updates (distrib13)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted Release (distrib21)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted Updates (distrib23)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core 32bit Release (distrib31)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Core 32bit Updates (distrib32)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree 32bit Release (distrib36)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Nonfree 32bit Updates (distrib37)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted 32bit Release (distrib41)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Tainted 32bit Updates (distrib42)/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/google-chrome/synthesis.hdlist.cz]
examen de la liste de synthèse [/var/lib/urpmi/Google Chrome 64bit/synthesis.hdlist.cz]
getting exclusive lock on rpm
unlocking urpmi database
unlocking rpm database


Note que je ne veux pas abuser de ton temps si mes compétences limitées sont à l'origine de ces problèmes en chaîne !

@ Sylv_01: Merci beaucoup, mais je ne connais pas les codes et je ne sais toujours pas comment lancer un programme dans la console... Tout ce que je peux faire comme recherche me conduit au wiki console qui ne liste que quelques commandes basiques, qui lui-même conduit vers "Le shell sans peine" qui ne contient aucun texte, je ne sais pas où vous les avez appris, probablement parce que je ne sais pas lancer la bonne recherche avec les bons mots clefs :( Si vous avez un lien je suis preneur ! En tous cas si je lance tel quel la commande ./cinelerra dans le répertoire home il me dit "bash: ./cinelerra : est un dossier" et si je la lance dans le répertoire Cinelerra il me met "Aucun fichier ou dossier de ce type"
Site web    
Sylv_01 Membre non connecté

Rang

Avatar

Inscrit le : 29/05/2012 à 18h16

Messages: 592

Le 27/02/2016 à 10h02
Va dans le répertoire cinelerra puis tape "ls" et retourne nous le résultat, pour voir...
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 27/02/2016 à 11h50
A Ourya
Voici la réponse lorsque le paquet est installé :
[root@localhost ~]# urpmi /home/sam/Downloads/Cg-docs-3.0.0015-1.fc13.i686.rpm
Package Cg-docs-3.0.0015-1.fc13.i686 is already installed


Donc il faut d'abord que tu trouves le moyen de correctement télécharger et installer les 2 paquets en question. Il doit y avoir des conflits avec des programmes déjà en place sur ton PC, mais je ne vois pas. Lightworks a t-il déjà été installé ? Il faudrait purger toute ancienne installation ou partir sur une partition système vierge, c'était mon cas.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 27/02/2016 à 22h53
Ouh Sylv_01 j'en ai eu un... paquet ^^

Citation :
720to480.plugin* color3way.plugin* histogram.plugin* mpeg3cat* spectrogram.plugin*
aging.plugin* dcoffset.plugin* invertaudio.plugin* mpeg3dump* suv.plugin*
bandslide.plugin* deinterlace.plugin* invertvideo.plugin* normalize.plugin* synthesizer.plugin*
bandwipe.plugin* denoisefft.plugin* leveleffect.plugin* overlay.plugin* timefront.plugin*
blur.plugin* denoise.plugin* livevideo.plugin* parametric.plugin* timestretch.plugin*
brightness.plugin* denoisevideo.plugin* locale/ photoscale.plugin* timestretchrt.plugin*
brighttheme.plugin* despike.plugin* loopaudio.plugin* pitch.plugin* titler.plugin*
burn.plugin* dissolve.plugin* models/ reframert.plugin* translate.plugin*
chromakeyhsv.plugin* flash.plugin* motion2.plugin* removegaps.plugin* wipe.plugin*
chromakey.plugin* fonts/ motionblur.plugin* sharpen.plugin* yuv.plugin*
Cinelerra_plugins gain.plugin* mpeg2enc.plugin* shiftinterlace.plugin*


Ah mais Le barhon, peut-être que c'est là le problème alors ? J'avais un conflit de version avec le paquet précédent et quand j'ai téléchargé l'autre qui aurait dû marcher il est entré en conflit avec LightWorks qui est toujours installé de la manipulation précédente, bien qu'inutilisable ?

J'étais tout content parce que j'avais (croyais-je) la commande pour désinstaller et j'imaginais (pensais-je) que j'allais m'en sortir tout seul... Plein d'espoir j'ai demandé un petit urpme lwks-12.6.0-amd64.rpm, malheureusement je n'ai réussi qu'à avoir un

Citation :
paquetage inconnu: lwks-12.6.0-amd64.rpm


Alors même qu'un urpmi lwks-12.6.0-amd64.rpm au même endroit me met bien Le paquetage lightworks-12.6-1.x86_64 est déjà installé

Je crois que mon cas est désespéré, et que je prends de votre temps dans mon naufrage ! Non ? Edité par Ourya Le 27/02/2016 à 22h56
Site web    
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 28/02/2016 à 11h54
Ne t'inquiète pas pour le temps ... il passe de toute façon. :)

Mais là, je suis à cours d'idées.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 28/02/2016 à 12h11
Et moi donc :langue4:

Mais je suis très heureux d'avoir pu avancer un peu dans la démarche, et de savoir que cela peut marcher sur Mageia, et peut-être même plus facilement via Mageia 6 dans le futur proche ?
Site web    
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8024

Le 28/02/2016 à 19h34
essaye 'urpme lwks'


Yves
   
Sylv_01 Membre non connecté

Rang

Avatar

Inscrit le : 29/05/2012 à 18h16

Messages: 592

Le 29/02/2016 à 08h10
Ourya:
Ouh Sylv_01 j'en ai eu un... paquet ^^

Citation:
720to480.plugin* color3way.plugin* histogram.plugin* mpeg3cat* spectrogram.plugin*
aging.plugin* dcoffset.plugin* invertaudio.plugin* mpeg3dump* suv.plugin*
bandslide.plugin* deinterlace.plugin* invertvideo.plugin* normalize.plugin* synthesizer.plugin*
bandwipe.plugin* denoisefft.plugin* leveleffect.plugin* overlay.plugin* timefront.plugin*
blur.plugin* denoise.plugin* livevideo.plugin* parametric.plugin* timestretch.plugin*
brightness.plugin* denoisevideo.plugin* locale/ photoscale.plugin* timestretchrt.plugin*
brighttheme.plugin* despike.plugin* loopaudio.plugin* pitch.plugin* titler.plugin*
burn.plugin* dissolve.plugin* models/ reframert.plugin* translate.plugin*
chromakeyhsv.plugin* flash.plugin* motion2.plugin* removegaps.plugin* wipe.plugin*
chromakey.plugin* fonts/ motionblur.plugin* sharpen.plugin* yuv.plugin*
Cinelerra_plugins gain.plugin* mpeg2enc.plugin* shiftinterlace.plugin*

Salut désolé pour le silence du week-end...
Alors c'est bizarre, tu n'as pas l'exécutable cinelerra...
Lorsque tu as décompressé le tar.gz, tu as fais comment ?
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie