Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Packaging LightWorks une chance qu'il soit intégré ?

Aranud Membre non connecté

Rang

Avatar

Inscrit le : 06/11/2010 à 12h20

Localisation : Nîmes, Marseille

Messages: 1872

Le 25/02/2016 à 13h28

Reprise du message précédent

@lebarhon : il n'y a pas l possibilité d'inclure juste "petites" 4 lib pour le faire fonctionner ?
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 25/02/2016 à 14h27
Merci à vous, malheureusement j'avais traduit le message avec plus d'optimisme... Je comprends complètement qu'il ne puisse pas être intégré dans la compilation des paquets, je vais donc juste attendre d'avoir une confirmation de la question d'Aranud.

Je me suis rendu compte que j'avais sur Mageia le logiciel "Kdenlive" que je peux effectivement comparer à un outil dont j'ai besoin, et avec lequel je pourrais travailler. D'ailleurs, c'est génial que ce logiciel ait été développé dans les logiciels libres. Mais... Comment dire... Au delà du fait que ça me prendrait beaucoup plus de temps (et le montage prend déjà un temps vraiment considérable), et même si j'étais certain que ce logiciel puisse supporter la complexité d'un véritable film, il serait impossible de travailler convenablement un véritable montage. Sans lui nier son intérêt certainement remarquable pour tout amateur, débutant dans le milieu, ou même professionnel dans des projets courts ou plus simples. Pour prendre une analogie facile, on va dire qu'un scooter remplit exactement les mêmes fonctions qu'une berline routière, et que pour des trajets modestes il n'y a pas une différence marquante d'efficacité, mais dès que l'on voudrait faire de longues routes, ce n'est pas que le scooter serait incapable de les faire... C'est juste qu'il faudrait une foi absolue dans les logiciels libres pour accepter des sacrifices importants, que ne peux pas concilier avec ma démarche présente, et je suppose que je suis loin d'être le seul. Cela n'a vraiment aucun rapport avec d'autres domaines du libre comme le graphique avec Gimp ou même Inkscape pour le dessin vectoriel, où les solutions libres offrent une alternative suffisante pour travailler sans trop de compromis sur sa méthode de travail...
Site web    
Aranud Membre non connecté

Rang

Avatar

Inscrit le : 06/11/2010 à 12h20

Localisation : Nîmes, Marseille

Messages: 1872

Le 25/02/2016 à 14h30
Non mais on doit pouvoir mettre ces 4 lib (manuellement au pire), je suis en repos demain, je me pencherai sur le truc, c'est dommage que pour juste ça plusieurs utilisateurs ne vont pas utiliser Mageia...
   
Sylv_01 Membre non connecté

Rang

Avatar

Inscrit le : 29/05/2012 à 18h16

Messages: 592

Le 25/02/2016 à 14h37
Bonjour,
il fut un temps où j'avais expérimenté cinelerra, qui à l'époque était (je crois) dans les paquetages, mais que tu dois pouvoir installer en stand-alone, rien qu'en décompressant l'archive...
Après, je ne garanti pas qu'il fonctionnera sous Mageia...
Je ne connais pas Lightworks, mais Cinelerra m'avait paru être très proche d'un soft "pro"...
Si tu ne veux pas t’embêter à essayer, je peux pour t'aider tenter l'install dans ma Mageia en VB et voir si c'est ok ?
Voila, c'était "my two pences..."
[Edit] : j'ai vu sur leur site qu'il existe un rpm (pour Suse), je suis en train de le télécharger et je vais voir si'il s'installe sur ma Mageia VB... Edité par Sylv_01 Le 25/02/2016 à 14h44
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 25/02/2016 à 15h28
@ Aranud : ça serait super :) Ce n'est pas hyper urgent, mais je sais qu'à terme (d'ici un mois environ) je serai vraiment confronté au problème, et je doute fort d'être un cas isolé, surtout avec la démocratisation vidéo des dernières années.

@ Sylv_01 : c'est très gentil ! J'ai essayé de voir mais je n'ai pas réussi (j'obtiens un fichier texte au lieu d'un fichier rpm). Bon, si tu n'y arrives pas, ça réglera la question. Autrement... Eh bien, sans minimiser d'aucune manière l'intérêt d'avoir accès à LightWorks, j'avoue qu'il semble y avoir du potentiel. Après, honnêtement, si ce logiciel semble être ce qu'il dit, il serait certainement un bon dépannage, le problème résidera davantage dans les codecs d'import/export et la stabilité sur des projets complexes... J'ai certains projets qui me demanderont plusieurs mois de montage, il est donc strictement impossible que je prenne le moindre risque, sachant que ce risque est proche de 0 avec LightWorks. Mais effectivement, tu me laisses à réfléchir, je ne sais pas pourquoi j'ai zappé ce logiciel... Je dois présenter mes excuses à la communauté du libre, puisque voilà une alternative notable... Pour être franc, sans LightWorks, j'aurais de suite plongé dedans. Avec LightWorks, j'avoue que c'est un peu dur de ne pas le choisir, et pour de nombreuses raisons... ça ne m'empêchera pas de faire des essais sur Cinerella si je peux car ce logiciel attise ma curiosité.
Site web    
Sylv_01 Membre non connecté

Rang

Avatar

Inscrit le : 29/05/2012 à 18h16

Messages: 592

Le 25/02/2016 à 15h43
Ne t'emballe pas, ça m'a l'air coton, il manque aussi des dépendances (lib...)
En attendant, puisque tu m'as l'air attiré par le montage vidéo en général, et sur du libre en particulier, je ne peux que te recommander le site LProd, qui renferme pas mal d'infos sur ce sujet...

[Edit] Bon, à priori j'ai réussi à installer les libs qui manquaient à Cinelerra, mais il ne se lance pas, il ne plante pas non plus, pas de messages d'erreurs dans la console...
Je soupçonne que ce soit mes ressources limités dans la VB qui le gênent...
Donc je vais retenter sur ma Mageia "officielle" à la maison, mais pas avant demain soir...
Si c'est ok j'écrirais un petit tuto, parce qu'il faut quand même mettre (un peu) les mains dans le cambouis... :happy1: Edité par Sylv_01 Le 25/02/2016 à 16h18
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 25/02/2016 à 17h37
J'ai obtenu un truc qui démarre, ensuite il faut s'enregistrer et je ne l'ai pas fait.
J'ai installé libCg.so ici : https://www.rpmfind.net/linux/rpm2html/search.php?query=libCg.so%28%29%2864bit%29
celui de Mageia 4

libCgGL.so ici : https://www.rpmfind.net/linux/rpm2html/search.php?query=libCgGL.so, clui de rpmfusion pour Fedora
Installer depuis le CCM, openssl 1.02.f; lib64openssl-static-devel, lib64openssl1.0.0; lib64openssl-devel; lib64openssl-engines1.0.0

J'ai aussi installé openssl-libs-1.0.2f-2.fc24.i686.html d'ici https://rpmfind.net/linux/rpm2html/search.php?query=libcrypto.so.10
et /openssl10-libs-1.0.1e-1.ius.el6.x86_64.rpm d'ici http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/libcrypto.so.10%28%29%2864bit%29 mais je ne pense pas que ce fut nécessaire, essayer sans.

Créer les liens
ln -s /lib64/libcrypto.so.1.0.0 /lib64/libcrypto.so.10
ln -s /lib64/libssl.so.1.0.0 /lib64/libssl.so.10

Ensuite télécharger lwks-12.6.0-amd64.rpm du site Lightworks et l'installer avec la commande
urpmi --allow-nodeps /chemin/vers/paquet/lwks-12.6.0-amd64.rpm
Accepter le manque de signature et les paquetages manquants, certains sont trouvés automatiquement
Réitérer la commande jusqu'à ce qu'il ne trouve plus de dépendances manquantes.

S'il faut refaire des tentatives d'installation alors que le système répond déjà installé, utiliser la commande
urpmi --replacepkgs /chemin/vers/paquet/openssl-libs-1.0.2f-2.fc24.i686.rpm

Bon courage, ça peut marcher sur une Mageia 5 Edité par lebarhon Le 25/02/2016 à 17h38


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 25/02/2016 à 19h19
Dans le CCM la plupart des paquetages étaient déjà installés avec l'icône verte ou rouge.

Pour le reste, je ne sais pas ce que j'ai pu mal faire... Ah, LightWorks s'est bien installé, seulement il plante au démarrage. Et je n'arrive pas à faire urpmi --replacepkgs /chemin/vers/paquet/openssl-libs-1.0.2f-2.fc24.i686.rpm , j'ai passé du temps à chercher le chemin mais rien à faire... c'est qu'il y en a des chemins, et même en faisant des recherches je n'ai pas réussi à localiser openssl-libs-1.0.2f-2.fc24.i686.rpm . Du coup je ne peux pas réinstaller comme tu le suggères.

J'ai aussi essayé, alors, d’installer les deux paquets que tu conseillais de ne pas installer, mais aucun des deux n'a réussi de toute façon (il manquait des dépendances).

Je serai pas trop disponible sur internet dans les jours qui viennent mais j'essaierai de refaire toute la manipulation au cas où... A moins qu'il ne suffise de trouver ce fameux openssl-libs-1.0.2f-2.fc24.i686.rpm , mais comme c'est le nom du rpm que tu conseillais de ne pas installer et que je ne pouvais pas installer de toute façon ("crypto-policies n'est pas satisfait"), je me dis que...

Voilà :( Merci beaucoup pour ton temps en tous cas

Edit : j'ai téléchargé le openssl-libs-1.0.2f-2.fc24.i686.rpm pour le mettre dans le même dossier d'install et j'ai recommencé les commandes mais sans plus de succès, juste un message différent : paquetage(s) openssl-libs-1.0.2f-2.fc24.i686 dans la base urpmi mais aucun n'est installé Edité par Ourya Le 25/02/2016 à 19h27
Site web    
Aranud Membre non connecté

Rang

Avatar

Inscrit le : 06/11/2010 à 12h20

Localisation : Nîmes, Marseille

Messages: 1872

Le 25/02/2016 à 19h22
Salut,

Je pense qu'il faut que tu le télécharges : openssl-libs-1.0.2f-2.fc24.i686.rpm
Donc par défaut ton dossier de téléchargement, ce qui donnerai :

su
tonmotdepasseadmin
urpmi --replacepkgs /home/Ourya/Téléchargemets/openssl-libs-1.0.2f-2.fc24.i686.rpm

Pour le télécharger : ftp://fr2.rpmfind.net/linux/fedora/linux/development/rawhide/x86_64/os/Packages/o/openssl-libs-1.0.2f-2.fc24.i686.rpm Edité par Aranud Le 25/02/2016 à 19h24
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 25/02/2016 à 19h31
Heu oui, j'avais fait un edit en ce sens, j'ai réessayé avec ton fichier à toi mais ça ne s'installe toujours pas, par contre c'est autre chose qui bloque, un certain ca-certificate (>= 2008-5) ...
Site web    
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 25/02/2016 à 20h30
Ouh là, mauvais copier/coller, oublie openssl-libs-1.0.2f-2.fc24.i686.rpm
si le paquet lwks ne veut pas s'installer à nouveau, c'est lui qu'il faut installer avec l'option replacepkgs, donc exécuter :

# urpmi --replacepkgs /chemin/vers/paquet/lwks-12.6.0-amd64.rpm

Sinon, LightWorks s'est-il ajouté au menu ?
As tu essayé de lancer LightWorks dans une console et voir les commentaires ?


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 25/02/2016 à 20h34
Pour info, voilà le style de réponse du système que j'avais lors d'une tentative d'installation :

[root@localhost ~]# urpmi /home/sam/Downloads/lwks-12.6.0-amd64.rpm
A requested package cannot be installed:
lightworks-12.6-1.x86_64 (due to unsatisfied libcrypto.so.10(libcrypto.so.10)(64bit))
Continue installation anyway? (Y/n) y
While some packages may have been installed, there were failures.
A requested package cannot be installed:
lightworks-12.6-1.x86_64 (due to unsatisfied libcrypto.so.10(libcrypto.so.10)(64bit))

Libcrypto est la dernière dépendance à avoir posé problème. Résolu avec les liens symboliques.


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 25/02/2016 à 21h01
Je me suis fait les wiki et j'ai parcouru des tas de pages pour trouver la commande mais rien à faire, donc désolé je n'ai pas pu essayer de lancer via la console. Je ne sais absolument pas quelle invite dire...

Oui LightWorks s'est tout de suite ajouté dans les programmes récemment installés, c'est de là que je l'ai lancé sans succès.

Sinon, quand je lance la bonne commande (effectivement ça paraît tout de suite plus clair !) il me met :

Citation:
L'installation a échoué : libCg.so()(64bit) est nécessaire pour lightworks-12.6-1.x86_64
libCgGL.so()(64bit) est nécessaire pour lightworks-12.6-1.x86_64
libcrypto.so.10()(64bit) est nécessaire pour lightworks-12.6-1.x86_64
libcrypto.so.10(libcrypto.so.10)(64bit) est nécessaire pour lightworks-12.6-1.x86_64


Et rien ne change
Site web    
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 25/02/2016 à 21h11
tu prends libCg.so ici : https://www.rpmfind.net/linux/rpm2html/search.php?query=libCg.so%28%29%2864bit%29
celui de Mageia 4

tu prends libCgGL.so ici : https://www.rpmfind.net/linux/rpm2html/search.php?query=libCgGL.so, celui de rpmfusion pour Fedora

A chaque fois tu télécharges le rpm et tu l'installes par un double clic dessus et entrée du mot de passe root


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Ourya Membre non connecté

Rang

Avatar

Inscrit le : 15/02/2016 à 09h29

Messages: 40

Le 25/02/2016 à 21h17
Ben oui, c'est ce que tu avais dit. J'ai recommencé en téléchargeant (la première fois, je les avais installés directement), mais ça ne change rien du tout
Site web    
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4138

Le 25/02/2016 à 21h29
Si tu fais (en supposant que ton rpm est dans /home/<user>/Téléchargements) :
#urpmi /home/<user>/Téléchargements/lib64cg0-3.0.0018-0.4.mga4.nonfree.x86_64.rpm
le système te réponds quoi ?


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie