Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Packaging [Réglé] Kmymoney Mageia5 Passage à la version 4.7.2.2

Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 8014

Le 05/01/2016 à 13h58

Reprise du message précédent

BOnjour,
je suppose que tu as des rpm mga6 installés.
rpm -qa| grep mga6
t'en donnera la liste.
Désinstalle les un par un.


Yves
   
Visiteur

Visiteur

Rang

Avatar

Message : 0

Le 05/01/2016 à 14h00
Papoteur :
Désinstalle les un par un.


Ou même tous d'un coup via le CCM ? Edité par Visiteur Le 05/01/2016 à 14h01
   
taboutanche Membre non connecté

Rang

Avatar

Inscrit le : 02/12/2013 à 04h27

Localisation : indian ocean

Messages: 81

Le 05/01/2016 à 18h35
oui j'ai essayé , j'ai ceci :
[root@localhost lajoiejp]# rpm -qa| grep mga6
libstdc++6-5.3.1-0.20151222.1.mga6
[root@localhost lajoiejp]# urpme libstdc++6-5.3.1-0.20151222.1.mga6
La désinstallation du paquetage suivant rendra votre système instable
basesystem-minimal-2-21.mga5.x86_64
(en raison du manque de procps,
en raison du manque de termcap,
en raison du manque de psmisc,
en raison du manque de less,
en raison du manque de vim,
en raison du manque de util-linux,
en raison du manque de initscripts,
en raison du manque de kbd,
en raison du manque de sed,
en raison du manque de findutils,
en raison du manque de tar,
en raison du manque de gzip,
en raison du manque de time,
en raison du manque de cronie,
en raison du manque de timezone,
en raison du manque de rpm,
en raison du manque de makedev,
en raison du manque de etcskel,
en raison du manque de passwd,
en raison du manque de shadow-utils)
[root@localhost lajoiejp]#
   
david.david Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 11/02/2008 à 23h08

Localisation : Bernwiller, Haut-Rhin

Messages: 2654

Le 05/01/2016 à 20h22
Hello taboutanche, :hello:

Ohlala !! tu t'es mis dans un gros pétrin là quand même !! je ne comprends toujours pas pourquoi vouloir toujours les tous derniers logiciels à jour... mais bon passons...

Alors pour ton problème il ne faut pas désinstaller les paquets "*.mga6" mais plutôt les remplacer à nouveau par ceux de Mageia5,
donc pour ceci il faut faire la commande suivante :

Code BASH :
 
urpmi --downgrade libstdc++6



tu peux mettre plusieurs paquets à la suite avec la commande et il faut juste le nom exacte du paquet pas besoin de la version.


ASUS K73S (portable) :
Intel Core i3-2350M_2.3GHz, 8 GO RAM DDR3, écran LED 17" (1600x900), CG Intel HD intégrée + CG Nvidia GeForce 610M_1GB dédiée (Technologie Optimus), SSD Samsung 850 EVO 250GB + SSD Samsung 850 EVO 500GB.

Mageia 7 - x86_64bits/ KDE Plasma-5.15.4 (DVD édition), c' est de la bombe, vive MAGEIA et toute l'équipe du STAFF MLO.
de david.david <david.david@mageialinux-online.org>
28281 .Venez nous rejoindre sur le salon IRC de MLO
   
Visiteur

Visiteur

Rang

Avatar

Message : 0

Le 05/01/2016 à 21h25
david.david :
je ne comprends toujours pas pourquoi vouloir toujours les tous derniers logiciels à jour...


Quand ceux-ci apportent des corrections de bogues par rapport aux versions précédentes, il me semble que c'est plus que justifié :fesse:
   
david.david Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 11/02/2008 à 23h08

Localisation : Bernwiller, Haut-Rhin

Messages: 2654

Le 06/01/2016 à 07h33
Oui et bien dans ce cas je me répète il faut le signaler sur le bugzilla en argumentant le pourquoi du comment. ;-)


ASUS K73S (portable) :
Intel Core i3-2350M_2.3GHz, 8 GO RAM DDR3, écran LED 17" (1600x900), CG Intel HD intégrée + CG Nvidia GeForce 610M_1GB dédiée (Technologie Optimus), SSD Samsung 850 EVO 250GB + SSD Samsung 850 EVO 500GB.

Mageia 7 - x86_64bits/ KDE Plasma-5.15.4 (DVD édition), c' est de la bombe, vive MAGEIA et toute l'équipe du STAFF MLO.
de david.david <david.david@mageialinux-online.org>
28281 .Venez nous rejoindre sur le salon IRC de MLO
   
taboutanche Membre non connecté

Rang

Avatar

Inscrit le : 02/12/2013 à 04h27

Localisation : indian ocean

Messages: 81

Le 06/01/2016 à 15h47
Un grand merci à tous , j'ai pu me rattraper , et installer Kmymoney 4.7.2
Moralité , j'ai pas mal patiné , j'ai découvert l'option
urpmi --downgrade
et j'ai appris a installer à partir de sources ;
C'est déjà pas si mal !
Pour la mise à jour , je ne suis pas un fana des M AJ à tout prix , au contraire .
Mais quand je bute sur un bug , que je sais qu'il a été corrigé et que je ne peux pas y accéder , là çà me dépasse complètement.
j'avais expliqué quelques messages au dessus que j'avais déposé le bug sur le bugzilla de Kmymoney et j'ai mis le lien. Ils m'ont expliqué que c'est corrigé dans la version kmymoney 4.7.2 qui est une version stable.
JE pense qu'il serait tout de même judicieux de mettre cette version dans les dépôts magéia pour les autres de sorte qu'on ne soit pas obligé de se lancer dans des manips relativement compliquées pour un profane.
Tout de même encore merci à tous Edité par taboutanche Le 06/01/2016 à 15h51
   
david.david Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 11/02/2008 à 23h08

Localisation : Bernwiller, Haut-Rhin

Messages: 2654

Le 06/01/2016 à 16h15
Quand je disais sur le bugzilla je parlais du bugzilla de Mageia, si la demande et l'explication y est faite alors nous pourrions faire officiellement cette mise à jour correctrice. ;-)


ASUS K73S (portable) :
Intel Core i3-2350M_2.3GHz, 8 GO RAM DDR3, écran LED 17" (1600x900), CG Intel HD intégrée + CG Nvidia GeForce 610M_1GB dédiée (Technologie Optimus), SSD Samsung 850 EVO 250GB + SSD Samsung 850 EVO 500GB.

Mageia 7 - x86_64bits/ KDE Plasma-5.15.4 (DVD édition), c' est de la bombe, vive MAGEIA et toute l'équipe du STAFF MLO.
de david.david <david.david@mageialinux-online.org>
28281 .Venez nous rejoindre sur le salon IRC de MLO
   
taboutanche Membre non connecté

Rang

Avatar

Inscrit le : 02/12/2013 à 04h27

Localisation : indian ocean

Messages: 81

Le 06/01/2016 à 18h14
j'ai vérifié , le bug de kmymoney est bien corrigé dans la version 4.7.2
J'ai soumis le problème dans bugzilla de magéia afin que la mise a jour soit mise dans les dépôts
voici le lien :https://bugs.mageia.org/show_bug.cgi?id=17458
   
Visiteur

Visiteur

Rang

Avatar

Message : 0

Le 06/01/2016 à 18h25
Bien joué, d'autres t'en seront reconnaissants ! :super:
   
david.david Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 11/02/2008 à 23h08

Localisation : Bernwiller, Haut-Rhin

Messages: 2654

Le 06/01/2016 à 19h14
Tellement bien joué que un packager sympa tel zezinho vient juste de lancer la compilation de kmymoney pour mga5, il sera donc dispo d'ici peu dans le dépôt Core/Updates_Testing :super:

Alors paré pour les tests et faire valider cette mise à jour.

https://pkgsubmit.mageia.org Edité par david.david Le 06/01/2016 à 19h16


ASUS K73S (portable) :
Intel Core i3-2350M_2.3GHz, 8 GO RAM DDR3, écran LED 17" (1600x900), CG Intel HD intégrée + CG Nvidia GeForce 610M_1GB dédiée (Technologie Optimus), SSD Samsung 850 EVO 250GB + SSD Samsung 850 EVO 500GB.

Mageia 7 - x86_64bits/ KDE Plasma-5.15.4 (DVD édition), c' est de la bombe, vive MAGEIA et toute l'équipe du STAFF MLO.
de david.david <david.david@mageialinux-online.org>
28281 .Venez nous rejoindre sur le salon IRC de MLO
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie