Connexion

Besoin d'aide ? Une question ? Un avis ? Rejoignez nous sur notre salon IRC pour clavarder

Forum

Système et matériels » Cartes son et périphériques audio [Réglé] son spatialisé avec kernel 4.1.8 et pas avec le 3.19.8

choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 491

Le 06/10/2015 à 15h27
Bonjour,


j'observe une regression de la qualité du son avec le Kernel 4.1.8. Car si je reboote en choississant le Kernel 3.19.8 (qui est proposé au menu), alors le son est parfait. Avec le nouveau Kernel, le son est "spatialisé" et sans basses. Bref c'est tout pourri. A moins que ce ne soient juste des points de restauration et que le problème vienne d'une install que j'aurais faite après (j'ai juste installé gnuplot ... )

Sous les différents kernels, je remarque simplement qu'il y a une différence lorsque je fais un ps :

[afb@localhost ~]$ uname -a
Linux localhost 3.19.8-desktop-3.mga5 #1 SMP Sat Jun 13 17:05:48 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost afb]# ps aux | grep audio
root 506 0.0 0.0 0 0 ? S< 14:50 0:00 [hd-audio0]
afb 2286 1.1 0.2 369380 11004 ? S<sl 14:50 0:02 /usr/bin/pulseaudio
root 2685 0.0 0.0 12304 2272 pts/0 S+ 14:53 0:00 grep --color audio


[root@localhost afb]# uname -a
Linux localhost 4.1.8-desktop-1.mga5 #1 SMP Sun Sep 20 12:39:07 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost afb]# ps aux | grep audio
afb 2300 1.5 0.3 435276 13124 ? S<sl 14:55 0:01 /usr/bin/pulseaudio
root 2627 0.0 0.0 12304 2148 pts/1 S+ 14:57 0:00 grep --color audio


Quelqu'un aurait-il une idée ? :gene5: Edité par choucroot Le 12/08/2016 à 14h41



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 7716

Le 07/10/2015 à 08h28
Non, pas d'idée..
Il faudrait passer par le bugzilla, le spécialiste du noyau n'est pas ici.


Yves
   
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 491

Le 07/10/2015 à 11h23
[quote=afaurebo]OK.J'ai regardé sur bugzilla en filtrant avec "sound", mais pas très fructueux. C'est très bizarre, car ça n'arrive que si je lance le son après avoir rebooté avec le kernel 4 et démarré une session KDE. Je n'avait pas encore vu le problème car j'utilise l'hibernation et du coup je reboote rarement ...

car bizarrement, lorsque le problème est là, si j'hiberne et que je redémarre, le problème n'apparaît plus !! :]

Allez, je clos, mais le mystère reste entier ... ...

merci.
:magic: Edité par choucroot Le 07/10/2015 à 11h24



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 491

Le 19/06/2016 à 12h34
Bonjour,

8 mois après, j'en rajoute une petite couche ici, histoire de savoir s'il existe d'autre utilisateur de NUC sous linux et s'ils ont constaté le même problème :siffle:

A savoir qu'avec la sortie du nouveau kernel 4.4, et bien pas d'amélioration au niveau de l'audio. Toujours ce son spatialisé sur mon NUC, toujours la même solution de contournement, à savoir passer en hibernation et redémarrer

J'ai conservé une version 3.19.8-desktop du noyau où le problème n'apparaît pas.

Dans ce contexte, une petite question : que risqué-je si j'utilise le noyau 3.19 alors que j'ai "installé" le 4.4 ? Y-a-t-il une indépendance totale entre le noyau et les logiciels ou alors vais au devant de graves difficultés ... ?



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 7716

Le 19/06/2016 à 13h45
A ma connaissance, il n'y a pas de risques.


Yves
   
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 491

Le 19/06/2016 à 14h18
OK merci.

je vais donc rester en 3.19. Je remets le sujet en résolu, sachant qu'il ne l'est pas réellement, mais vu qu'il y a un contournement ...

Après, je n'ai pas fait de tests avec un autre bureau (genre XFCE à la place de KDE). Car c'est peut-être un soucis avec KDE et pulseaudio ou je ne sais quoi d'autre.

Allez, une bouteille à la mer à tous les utilisateurs de NUC sous linux :hello:

et je rajoute les liens suivants pour que d'éventuels moteurs de recherche attrape la bouteille ;-) :

http://www.intel.fr/content/www/fr/fr/nuc/nuc-kit-dn2820fykh.html
http://www.materiel.net/ordinateur/materiel-net-nucleus-mini-93492.html ( là où je l'ai acheté ... )



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
choucroot Membre non connecté

Rang

Avatar

Inscrit le : 07/08/2015 à 15h21

Localisation : France, Hérault

Messages: 491

Le 12/08/2016 à 14h58
Bonjour à tous,

une mise à jour de ce fil, étant donné qu'Intel ne semble plus vendre de Mini-PC DN2820FYKH, le NUC5CPYH étant son "remplaçant". En effet, après une panne sous la garantie d'un an ( le mini-PC ne démarrait plus, même pas jusqu'au bios ), Materiel.net me l'ont carrément remplacé par un NUC5CPYH , et je n'observe plus ce problème de son spatialisé ! Ouf .... !

Voici pour les infos: http://www.intel.fr/content/www/fr/fr/nuc/nuc-kit-nuc5cpyh.html
On pourra remarquer ici qu'il est "certifié" compatible avec les distro suivantes :



Et bien on peut désormais aussi ajouter Mageia ... :magic: ;-)

Voilà voilà ... Edité par choucroot Le 12/08/2016 à 14h59



Ordinateur : Mageia7 64bits XFCE / MSI Cubi N-8GL-002BEU ( Pentium N5000 / Intel HD Graphics 605 / SSD M.2 240Go / 4Go DDR4 2400)
Smartphone: /e/ ( > Android 7.1.2) / Samsung S7 Edge
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie