Connexion

Forum

Système et matériels » Cartes graphiques et webcams Bumblebee et Nvidia 840M

Troubadour Membre non connecté

Rang

Avatar

Inscrit le : 10/07/2015 à 08h00

Messages: 24

Le 14/07/2015 à 13h42
Bonjour,
je post car j'ai des comportements vraiment bizarres avec Bumblebee qui ne m'apporte qu'une satisfaction très partielle...
Mon matériel:
HP envy 17' touchsmart
geforce 840M
16 GO de Ram.

J'ai installé Bumblebee en ligne de commandes avec le driver propriétaire. (urpmi bumblebee-nvidia). J'ai aussi ajouté la ligne pour les dépôts backport 32 bits. (urpmi libvirtualgl libturbojpeg0 libprimus)

Je lance mes jeux steam avec primusrun %command% dans les options de lancements et mes jeux fonctionnent au top. Le test glxspheres64 est également concluant.Oui mais...

Même sans utiliser bumblebee, en utilisation normale, j'ai une autonomie annoncée de 3 heures au lieu de plus de 6 sous Windows... En faite la carte doit tourner à vide comme c'est le cas sous les machines sous optimus sous linux sans Bumblebee.... C'est très problématique car je compte prendre mes cours sur ma machine cette année....

En outre, quand je tente de voir le status de Bumblebee, je me fais insulter de la sorte:
Code BASH :
[simara@localhost ~]$ optirun -status -vv
[  915.375071] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  915.375243] [INFO]Configured driver: nvidia
[  915.375304] [ERROR]The Bumblebee daemon has not been started yet or the socket path tatus was incorrect.
[  915.375314] [DEBUG]Socket closed.
[  915.375325] [ERROR]Could not connect to bumblebee daemon - is it running?
 


Et pourtant tout baigne quand je lance une application:
Code BASH :
[simara@localhost ~]$ optirun steam
Couldn't find dpkg, please update steamdeps for your distribution.
Running Steam on mageia 5 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
 
(steam:4186): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »
 
(steam:4186): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita »
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:1163: error: unexpected identifier `direction', expected character `}'
Installing breakpad exception handler for appid(steam)/version(1433441724)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
[0714/133732:ERROR:browser_main_loop.cc(170)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steamwebhelper)/version(20150604103540)
Installing breakpad exception handler for appid(steamwebhelper)/version(1433414140)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
FillInMachineIDInfo took a total of 0 milliseconds
[0714/133733:ERROR:nss_util.cc(981)] Failed to load NSS libraries.
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steamwebhelper)/version(20150604103540)
Installing breakpad exception handler for appid(steamwebhelper)/version(1433441724)
Installing breakpad exception handler for appid(steamwebhelper)/version(1433441724)
 
** (steam:4186): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory.
Installing breakpad exception handler for appid(steam)/version(1433441724)
Generating new string page texture 2: 48x256, total string texture memory is 49,15 KB
Generating new string page texture 3: 256x256, total string texture memory is 311,30 KB
Installing breakpad exception handler for appid(steam)/version(1433441724)
local (potentially out of sync) copy of roaming config loaded - 2436 bytes.
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Adding licenses for the following package(s): 0, 168, 461, 1369, 1438, 1774, 1909, 2300, 2481, 4109, 4820, 4821, 7587, 7932, 8423, 8999, 11089, 12361, 12443, 12444, 13054, 13258, 15996, 17915, 21240, 21244, 21310, 27214, 28315, 46441, 46481, 46682, 53329, 55833, 61166, 72925, 73198
roaming config store loaded successfully - 2436 bytes.
migrating temporary roaming config store
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
Failed to init SteamVR because it isn't installed
ExecCommandLine: ""/home/simara/.local/share/Steam/ubuntu12_32/steam" "
Installing breakpad exception handler for appid(steam)/version(1433441724)
System startup time: 17,05 seconds
Couldn't find dpkg, please update steamdeps for your distribution.
Running Steam on mageia 5 64-bit
STEAM_RUNTIME has been set by the user to: /home/simara/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(1433441724)
Generating new string page texture 70: 128x256, total string texture memory is 442,37 KB
Generating new string page texture 71: 128x256, total string texture memory is 131,07 KB
Generating new string page texture 72: 64x256, total string texture memory is 507,90 KB
Generating new string page texture 73: 32x256, total string texture memory is 540,67 KB
ExecCommandLine: "/home/simara/.steam/root/ubuntu12_32/steam steam://open/driverhelperready"
ExecSteamURL: "steam://open/driverhelperready"
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)
[0714/133750:ERROR:renderer_main.cc(212)] Running without renderer sandbox
Installing breakpad exception handler for appid(steam)/version(1433441724)
Installing breakpad exception handler for appid(steam)/version(1433441724)


Merci d'avance pour les plus téméraires qui se pencheront sur le problème!
   
Troubadour Membre non connecté

Rang

Avatar

Inscrit le : 10/07/2015 à 08h00

Messages: 24

Le 21/07/2015 à 18h59
Rebonjour,
Tout d'abord je corrige ma commande plus haut: optirun -status est en faite optirun --status, et cela marche.

Ceci-dit,
Après un long temps de recherche, j'ai l'explication à mon problème...En faite je pense que le pépin vient de ma CG, la 840M. J'ai souillé ma machine avec une ubuntu pour tester nvidia prime et...Il n'y a aucune augmentation de durée de batterie à signaler que je sois sur la nvidia ou la intel. Peut-être que Nvidia à chier dans la colle pour les divers sur la 840M. Si quelqu'un à une 840M qui fonctionne qu'il se manifeste je pense que le pépin viendra alors directement de mon modèle de PC...
   
Troubadour Membre non connecté

Rang

Avatar

Inscrit le : 10/07/2015 à 08h00

Messages: 24

Le 09/10/2015 à 09h24
Sait-on jamais si il y a du nouveau, je up (de mon coté pas de changement avec le nouveau kernel...)
   
admel Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 21/09/2014 à 10h27

Localisation : Nord

Messages: 1074

Le 09/10/2015 à 09h36
Bonjour,

Que renvoie la commande $ rpm -qa|grep bbswitch ?


EDIT : je suis sur une Gforce 840M aussi. Edité par admel Le 09/10/2015 à 09h37
Papoteur Membre non connecté

Rang

Avatar

Modérateur Équipe Mageia

Inscrit le : 03/10/2011 à 22h16

Localisation : Metz

Messages: 6722

Le 16/10/2015 à 12h34
Bonjour,
J'ai soigneusement évité de prendre une machine avec Optimus et consors. Je n'ai donc pas d'expérience pour t'aider. Mais je compatis.


Yves
   
lebarhon Membre non connecté

Rang

Avatar

Équipe Mageia Membre d'Honneur

Inscrit le : 09/10/2010 à 14h18

Localisation : Normandie

Messages: 4092

Le 16/10/2015 à 13h52
Bonjour,
Je ne possède pas non plus de PC avec Bumbledee (non joueur) mais as-tu respecté la procédure d'installation :
- Ouvrir le CCM
- Configurer uniquement l'IGP, probablement le pilote i810 and later
- désinstaller l'autre pilote (supprimer le paquet) le cas échéant
- installer bumbledee -nvidia
- redémarrer
- tester "primusrun glxspheres" et "glxspheres" et voir les éventuels messages d'erreur

Peut-être un pilote nvidia était-il installé avant bumbledee ?


CM Asus Z77-A+i5-2500K+GeForceGT520+RAM8Go
SSD Crucial M4+SSD Samsung EVO
Mageia 6 64 bits
   
Akien Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 12/06/2011 à 12h52

Localisation : Allemagne

Messages: 1245

Le 16/10/2015 à 16h12
Tout d'abord quelle est la version de Mageia que tu utilises ? Tu parles des dépôts backports, donc j'imagine qu'il s'agit de Mageia 4 ?

Est-ce que la durée de vie de ta batterie est aussi limitée même si tu n'as utilisé bumblebee depuis le boot ?

Tu peux vérifier si la carte est allumée avec cat /proc/acpi/bbswitch. Cela devrait te donner OFF avant d'utiliser bumblebee, ON pendant, et OFF après (sauf si tu es sous Mageia 5 où le driver ne se décharge pas proprement.



Co-responsable de l'équipe de packaging de Mageia (dev).
Packaging (voir mes paquets) et assurance qualité (QA).
   
stroibe974 Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 13/08/2018 à 16h22

Localisation : Réunion

Messages: 985

Le 06/10/2018 à 06h49
Bonjour à tous,

Je suis en train d'installer Mageia 6 sur un Acer Aspire E15 (modèle E5-571G-32R7 pour être précis), qui possède une nvidia Geforce 840M en plus du chipset intel...
Je me retrouve donc en train d'installer Bumblebee en suivant le guide de Adrien.D.

Dans ce guide, Adrien indique qu'il faut ajouter l'utilisateur au groupe bumblebee avec la commande
Code :
usermod -G bumblebee -a <USER>


À l'heure actuelle, l'installation de bumblebee-nvidia se termine par une série d'indications, parmi lesquelles pour ajouter l'utilisateur dans le groupe bumblebee il faut taper la commande
Code :
gpasswd -a <username> bumblebee


Ça, c'était pour indiquer une petite mise à jour possible du tutoriel :ange:

Et maintenant, mes questions :
Adrien conseille ceci :
Adrien.D :

Si on est sur une machine 64bits, il est nécessaire d'installer quelques librairies 32bits si on souhaite faire fonctionner des applications 32bits (comme steam par exemple) :
Activez les dépôts Backports 32bits
Code :
urpmi libvirtualgl libturbojpeg0 libprimus



Il s'agit d'activer les dépôts Core Backports 32 bits je suppose ?
En sachant qu'à l'heure actuelle, libprimus est déjà installé automatiquement à ce stade du tutoriel... Est-ce toujours conseillé d'installer ces paquetages de Core Backports 32 bits ? indispensable ? uniquement utile pour Steam ? Peut-on les installer plus tard si besoin, étant donné qu'à ce stade dkms s'est déjà chargé d'installer les modules nvidia sur le kernel ? Edité par stroibe974 Le 06/10/2018 à 06h54


Mageia 7 (64bits) - Plasma - Intel Core i7-8700K @ 3.70Ghz - 16Go RAM
frenchmageiauser_9c2c8
   
nic80 Membre non connecté

Rang

Avatar

Inscrit le : 06/08/2018 à 23h52

Messages: 1425

Le 06/10/2018 à 08h51
Bonjour,

Je pense que pour Mageia 6, il n' y a pas besoin d' activer les backports.

Les librairies sont présentes dans i586/media/core et dans i586/media/nonfree ....

Peut être que cela était valable pour Mageia 5 (ou 4), le tutoriel datant de 2014.
   
stroibe974 Membre non connecté

Rang

Avatar

Modérateur

Inscrit le : 13/08/2018 à 16h22

Localisation : Réunion

Messages: 985

Le 06/10/2018 à 09h19
nic80 :
Bonjour,

Je pense que pour Mageia 6, il n' y a pas besoin d' activer les backports.

Les librairies sont présentes dans i586/media/core et dans i586/media/nonfree ....

Peut être que cela était valable pour Mageia 5 (ou 4), le tutoriel datant de 2014.


Oui, c'est ce que je me suis dit aussi...
Et depuis 2014, il y a aussi bumblebee-nouveau qui a disparu. Il s'appelle maintenant bumblebee tout court (??) Edité par stroibe974 Le 06/10/2018 à 09h21


Mageia 7 (64bits) - Plasma - Intel Core i7-8700K @ 3.70Ghz - 16Go RAM
frenchmageiauser_9c2c8
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie