Connexion

Forum

Logiciels » Virtualisation et Émulation [VirtualBox] Mise à jourdes extensions PUEL Impossible de mettre à jour les Extensions licence PUEL

teutates Membre non connecté

Rang

Avatar

Inscrit le : 24/09/2011 à 01h41

Localisation : Ariège

Messages: 1305

Le 18/03/2015 à 01h24
Bonjour,



J'utilise la version du site source de VirtualBox qui me convient mieux que celle livrée avec Mageia 4 en RPM :

* VirtualBox OSE : version RPM donc : en version 4.3.16

* VirtualBox PUEL,, version site source : en version 4.3.26 (soit des corrections que je recherche particulièrement).



Dernièrement, j'installe la dernière version officielle (4.3.26). Si la mise à jour de l'application elle-même se fait sans problème, il n'en est pas de même pour mettre à jour les Extensions. Et ceci que je refasse mes téléchargements plusieurs fois, que j'enregistre le fichier d'installation des extensions préalablement, ou que j'ouvre directement ce fichier d'installation avec VirtualBox. J'obtiens systématiquement l'erreur suivante :

Caché :
Failed to run /opt/VirtualBox/VBoxExtPackHelperApp --stdout /tmp/VBoxExtPackHelper-59s1xg/stdout --stderr /tmp/VBoxExtPackHelper-59s1xg/stderr --elevated install --base-dir /opt/VirtualBox/ExtensionPacks --cert-dir /opt/VirtualBox/ExtPackCertificates --name 'Oracle VM VirtualBox Extension Pack' --tarball /tmp/Oracle_VM_VirtualBox_Extension_Pack-4.3.26-98988-1.vbox-extpack --sha-256 4e39a6d0da23799a31c3f6a4022b144ef3ddfe30c523e51b21bf7d9ebade62ce.



Failed to execute child process "/opt/VirtualBox/VBoxExtPackHelperApp --stdout /tmp/VBoxExtPackHelper-59s1xg/stdout --stderr /tmp/VBoxExtPackHelper-59s1xg/stderr --elevated install --base-dir /opt/VirtualBox/ExtensionPacks --cert-dir /opt/VirtualBox/ExtPackCertificates --name 'Oracle VM VirtualBox Extension Pack' --tarball /tmp/Oracle_VM_VirtualBox_Extension_Pack-4.3.26-98988-1.vbox-extpack --sha-256 4e39a6d0da23799a31c3f6a4022b144ef3ddfe30c523e51b21bf7d9ebade62ce" (No such file or directory)




Je précise que j'ai procédé de la même manière lorsque j'ai installé la version 4.3.20, avec succès.



J'ai contourné le problème d'une façon pas très correcte. Pas du tout même ! Pas taper pour la méthode qui va suivre :

1) J'ai ouvert avec les droits root un gestionnaire de fichiers.

2) Qui m'a permis de lancer, avec les droits root donc, l'installation des extensions via VirtualBox ouvert avec les droits root (menu "ouvrir avec")

L'installation de extensions dans le système hôte s'est bien passé. J'ai vérifié ensuite en tant que simple utilisateur. Sauf que cette solution ne me plait pas.



A part trouver l'origine du problème, existe-t'il une autre solution plus acceptable ?



Merci par avance :super:


Toco y se gausos !
Asus P8Z68-V/GEN3 + Intel Core i2700k + RAM G-Skill 4x4Go PC 12800 + Gainward Geforce GTX 560 - 2 Go + Western Digital Velociraptor 300 Go (Mageia Cauldron / Fedora / Debian / Manjaro / Windows 10) + Seagate Barracuda 7200t/mn - 2 To - Sata 3 (data) + SSD Samsung 64 Go - Sata 3 (Mageia stable)
Site web    
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 18/03/2015 à 23h44
Citation :
J'utilise la version du site source de VirtualBox qui me convient mieux que celle livrée avec Mageia 4 en RPM :


C'est peut être bien ça le problème....


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
Adrien.D Membre non connecté

Rang

Avatar

Webmaster Admin système

Inscrit le : 30/05/2011 à 18h36

Localisation : Dijon-21-FRA

Messages: 10322

Le 19/03/2015 à 07h33
Salut,

Sur Mageia, j'ai toujours utilisé le VBox du site sans soucis.

Je prenais le .run et non pas le RPM.

Assures-toi d'avoir bien la même version de VBox et de l'extension pack.

En passant directement par le logiciel Virtualbox, Fichier -> Paramètres -> Extensions -> Ajouter une extension, une fois le pack sélectionné, il ne te demande pas le mot de passe root ?


Config : PC Fixe : X470 GAMING PRO- AMD Ryzen 5 2600X - 16Go RAM - Radeon RX 560 (Pilote libre) - user_bar_calculate - GNOME Desktop - Kernel 4.19 LTS
Vice président de l'association COAGUL ("Côte-d’Or - Association Générale des Utilisateurs de Logiciels libres")
Webmaster de MageiaLinuxOnline uniquement. Pas de support de ma part.
Site web    
teutates Membre non connecté

Rang

Avatar

Inscrit le : 24/09/2011 à 01h41

Localisation : Ariège

Messages: 1305

Le 19/03/2015 à 22h11
Quelques précisions :

1- Les procédures
1) Pour installer ou mettre à jour VirtualBox, hors Extensions :
Pas de problème. Et si une "vieille" version est détectée, l'installateur VirtualBox PUEL désinstalle en premier la version obsolète. La manip est simple puisqu'il suffit d'ouvrir une console avec les droits root pour entrerla ligne suivante
sh virtualbox.run

2) Pour installer les Extensions :
La manip est simple aussi puisqu'il suffit de télécharger le fichier sur le site source adéquat, et correspondant évidement à la version VirtualBox installé préalablement, pour ensuite l'ouvrir avec VirtualBox. Avec Dolphin, il est possible de sélectionner VirtualBox. Il faut entrer alors le mot de passe root puis confirmer la licence.

3) Pour mettre à jour les Extensions:
Soit on refait la même procédure que pour une installation, soit on ouvre directement VirtualBox nouvellement mis à jour. Dès lors, VirtualBox détecte la présence d'une version obsolètes des Extensions et propose la mise à jour. Il suffit de valider le téléchargement qui sera suivi de l'installation. L'étape d'installation demande aussi le sésame root (logique).

2- Mon cas
1) J'ai toujours réussi à installer le programme VirtualBox. sans problème.
2) Que je passe par une mise à jour ou une nouvelle installation des Extensions, le problème était identique. Bloqué avec le même message d'erreur vu au premier post.
3) J'ai tenté de recréer la même situation dans une machine virtuelle Mageia 4 64 bits (comme ma machine hôte). J'ai poussé le vice jusqu'à "me taper" 9 versions antérieures (obsolètes) à la suite dans cette machine virtuelle. Le but étant de tester les mises à jour. Perdu puisque je n'ai eu aucun problème.
4) Sur ma machine hôte, celle où j'ai eu des problèmes, j'avais "joué" avec le fichier sudoers et je pense que mon problème pourrait venir de là. Lorsque le sésame root m'était demandé, je devais sélectionner mon profil utilisateur puis saisir mon sésame utilisateur. Sur la machine virtuelle, c'était directement et uniquement le sésame root.

Depuis, j'ai annulé toutes mes manipulation du fichier sudoers (ca m'apprendra !) et je dois saisir désormais uniquement et directement le mot de passe root. Pour le moment, j'utilise la dernière version de VirtualBox, soit la 4.3.26. Je vais donc patienter jusqu'à la sortie de la version suivante pour vérifier tout cela.

Donc, affaire en attente .....


Toco y se gausos !
Asus P8Z68-V/GEN3 + Intel Core i2700k + RAM G-Skill 4x4Go PC 12800 + Gainward Geforce GTX 560 - 2 Go + Western Digital Velociraptor 300 Go (Mageia Cauldron / Fedora / Debian / Manjaro / Windows 10) + Seagate Barracuda 7200t/mn - 2 To - Sata 3 (data) + SSD Samsung 64 Go - Sata 3 (Mageia stable)
Site web    
teutates Membre non connecté

Rang

Avatar

Inscrit le : 24/09/2011 à 01h41

Localisation : Ariège

Messages: 1305

Le 07/06/2015 à 22h35
Rhaaaa !

Toujours le même problème sous Mageia 4 pour migrer de la version 4.3.26 vers 4.3.28 !!! :pleur4:


Toco y se gausos !
Asus P8Z68-V/GEN3 + Intel Core i2700k + RAM G-Skill 4x4Go PC 12800 + Gainward Geforce GTX 560 - 2 Go + Western Digital Velociraptor 300 Go (Mageia Cauldron / Fedora / Debian / Manjaro / Windows 10) + Seagate Barracuda 7200t/mn - 2 To - Sata 3 (data) + SSD Samsung 64 Go - Sata 3 (Mageia stable)
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie