Connexion

Forum

Logiciels » Virtualisation et Émulation [Réglé] son dans playonlinux gresillard et très moche

thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 29/11/2014 à 19h29
Bonjour. Depuis un moment le son que j'obtiens avec pinball dans playonlinux est grésillard. Par le MCC j'ai coupé pulse audio et tout est redevenu bon avec ma carte ALSA. J'ai retenté la même chose inversement en remettant pulse audio et j'ai retrouvé la problème. Y a t-il un paramètre quelque part que l'on pourrait changer ?
Le problème se répète-t-il chez vous ?
Merci de vos réponses.


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
Akien Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 12/06/2011 à 12h52

Localisation : Allemagne

Messages: 1245

Le 29/11/2014 à 21h12
Ça ressemble au problème qu'il y a dans Mageia 4 quand on lance Skype en ligne de commande (l'entrée du menu a un truc en plus qui corrige le problème).

A priori il faudrait lancer le jeu en préfixant la commande de PULSE_LATENCY_MSEC=60.

Tu peux peut être essayer de lancer directement playonlinux comme ça :
Code SHELL :
PULSE_LATENCY_MSEC=60 playonlinux


Ou directement ton application (si elle s'appelle "Pinball" dans playonlinux :
Code SHELL :
PULSE_LATENCY_MSEC=60 playonlinux --run "Pinball"



Co-responsable de l'équipe de packaging de Mageia (dev).
Packaging (voir mes paquets) et assurance qualité (QA).
   
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 01/12/2014 à 09h38
Merci Akien. En suivant tes conseils, on n'observe pas d'amélioration. Comme j'ai démaré depuis la console voici la conversation:
Code BASH :
$ PULSE_LATENCY_MSEC=60 playonlinux
Looking for python... 2.7.6 - selected
Gtk-Message: Failed to load module "canberra-gtk-module"
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_System_CheckFS] Message: Checking filesystem for /home/thierry/.PlayOnLinux/
[main] Message: Filesystem is compatible
[maj_check] Message: Web version : 1417399909
[maj_check] Message: Current local version : 1417278673
[maj_check] Message: Updating list
[install_plugins] Message: Vérification de l'extension : Capture...
[install_plugins] Message: Vérification de l'extension : ScreenCap...
[install_plugins] Message: Vérification de l'extension : PlayOnLinux Vault...
[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1417399909
[POL_System_CheckFS] Message: Checking filesystem for pinball.exe
[POL_Wine] Message: Running wine- pinball.exe (Working directory : /home/thierry/.PlayOnLinux/wineprefix/MicrosoftPinball/drive_c/Program Files/Microsoft Games/Pinball)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
[POL_DetectVideoCards] Message: Gettings GPU informations
[POL_LoadVar_Device] Message: VendorID : 8086
[POL_LoadVar_Device] Message: DeviceID : 2a02
[POL_Website_GET] Message: GET http://www.playonlinux.com/api/s.php?data=ODA4Nn4yYTAyfjB%2bTWljcm9zb2Z0IFBpbmJhbGx%2bMH5%2bfn4wfk1hZ2VpYSA0fjB%2bNi44MzM1Mzg4
ODQxMDI0MmUrMTV%2bMX5NaWNyb3NvZnQgUGluYmFsbH40LjIuMn4yNA==
Registered PID: 8537 (Missing)
Registered PID: 8824 (Present)
Registered PID: 8871 (Missing)


Je ne sais pas si ça peut aider....


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
Akien Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 12/06/2011 à 12h52

Localisation : Allemagne

Messages: 1245

Le 01/12/2014 à 09h45
Peut-être que le PULSE_LATENCY_MSEC=60 n'est pas transmis à l'appel de la commande wine par PlayOnLinux.

Tu peux tenter ça pour t'assurer que ce soit pris en compte :
1) Ouvre PlayOnLinux
2) Ouvre la console de PlayOnLinux dans le menu "outils"
3) Tape :
Code PLAYONLINUX :
POL_Config_Write PRE_WINE 'PULSE_LATENCY_MSEC=60'

4) Normalement ça devrait forcer toutes tes applications PlayOnLinux à se lancer avec ce paramètre.

Si ça ne marche, c'est probablement que le problème est ailleurs.

Tu peux aussi tenter directement :
Code SHELL :
PULSE_LATENCY_MSEC=60 wine ~/.PlayOnLinux/wineprefix/MicrosoftPinball/drive_c/Program Files/Microsoft Games/Pinball/pinball.exe



Co-responsable de l'équipe de packaging de Mageia (dev).
Packaging (voir mes paquets) et assurance qualité (QA).
   
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 01/12/2014 à 09h48
Merci Akien. La console accuse bien réception:
Code BASH :
PlayOnLinux: ~/.PlayOnLinux > POL_Config_Write PRE_WINE 'PULSE_LATENCY_MSEC=60'
[POL_Config_Write] Message: Config write: PRE_WINE PULSE_LATENCY_MSEC=60
 

Mais le problème reste identique.
Serais je le seul à avoir ce problème ?


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 01/12/2014 à 10h01
Comme le son fonctionne directement avec ALSA, existe-t-il une commande qui inhiberait pulse audio le temps de l'utilisation de playonlinux ? Merci.


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
Akien Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 12/06/2011 à 12h52

Localisation : Allemagne

Messages: 1245

Le 01/12/2014 à 10h21
Qu'est-ce que ça donne avec la version de wine du système (cf. la commande que j'ai donnée plus haut) ?

Est-ce que tu as fait l'installation via le script de PlayOnLinux ? Chez moi ça marche sans problème avec pulseaudio. Il télécharge wine 1.4 qui est une version un peu antique, mais ça marche. J'ai changé les options pour qu'il utilise la version du système, et ça marche aussi très bien.

Edit : Par contre je suis sous Cauldron donc j'ai une version plus récente de pulseaudio, ce qui peut expliquer que je n'ai pas ce problème. Edité par Akien Le 01/12/2014 à 10h22



Co-responsable de l'équipe de packaging de Mageia (dev).
Packaging (voir mes paquets) et assurance qualité (QA).
   
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 01/12/2014 à 10h34
Par cette commande
Code BASH :
PULSE_LATENCY_MSEC=60 wine ~/.PlayOnLinux/wineprefix/MicrosoftPinball/drive_c/Program Files/Microsoft Games/Pinball/pinball.exe
wine: cannot find '/home/thierry/.PlayOnLinux/wineprefix/MicrosoftPinball/drive_c/Program' 


Heu:
Code BASH :
PULSE_LATENCY_MSEC=60 wine ~/.PlayOnLinux/wineprefix/MicrosoftPinball/drive_c/Program Files/Microsoft Games/Pinball/pinball.exe 

J'ai une console avec le jeu dedans. Mais là, il n'y a plus de son du tout.
Ma version de playon linux est PlayOnLinux 4.2.2

EDIT: je vais désinstaller le jeux puis le remettre. On va voir.


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 01/12/2014 à 10h42
La desinstallation puis la réinstallation n'a rien donné.



Dans la console de debuggage j'ai ceci:

Citation :
Running wine-1.4 pinball.exe (Working directory : /home/thierry/.PlayOnLinux/wineprefix/MicrosoftPinball/drive_c/Program Files/Microsoft Games/Pinball)

fixme:mci:MCI_LoadMciDriver Couldn't load driver for type L"PINBALL.MID".

ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred


Si ça peut aider....


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
Akien Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 12/06/2011 à 12h52

Localisation : Allemagne

Messages: 1245

Le 01/12/2014 à 11h30
Citation :
fixme:mci:MCI_LoadMciDriver Couldn't load driver for type L"PINBALL.MID".


J'ai la même erreur, mais ça marche bien chez moi.



Dans PlayOnLinux, tu peux cliquer "Configurer" puis pour l'entrée Microsoft Pinball, dans l'onglet Wine, clique sur Configurer. Là tu peux jouer un peu avec les paramètres de l'onglet Audio et voir si ça arrange quelque chose.



Co-responsable de l'équipe de packaging de Mageia (dev).
Packaging (voir mes paquets) et assurance qualité (QA).
   
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 01/12/2014 à 14h53
J'essaie les élements que tu me donnes.
J'ai un2e PC toshiba sur lequel il y a la cauldron. Je n'ai aucun souci de son sur celui là. Y a t-il une différence de playonlinux entre MGA4 et la cauldron ?


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
thierryR Membre non connecté

Rang

Avatar

Inscrit le : 02/02/2010 à 13h51

Localisation : Chalons en Champagne

Messages: 6758

Le 01/12/2014 à 14h59
C'est gagné. J'ai retiré la configuration par défaut de wine 1.4 pour y mettre le seul choix possible c'est à dire Alsa. Et la solution est trouvée.
Merci Akien. Tu m'as bien orienté sur la bonne piste.
:hello:


débusqueur de bugs et chercheur en améliorations

Amicalement vôtre.

Kernel: 4.4.92-desktop-1.mga5 x86_64 (64 bit) Desktop: KDE 4.14.35 Distro: Mageia 5 thornicroft
Machine: Mobo: ASUSTeK model: X751SA v: 1.0 Bios: American Megatrends v: X751SA.403
CPU: Quad core Intel Pentium N3710 (-MCP-) cache: 1024 KB Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Site web    
Akien Membre non connecté

Rang

Avatar

Équipe Mageia

Inscrit le : 12/06/2011 à 12h52

Localisation : Allemagne

Messages: 1245

Le 01/12/2014 à 15h31
thierryR :
J'ai un2e PC toshiba sur lequel il y a la cauldron. Je n'ai aucun souci de son sur celui là. Y a t-il une différence de playonlinux entre MGA4 et la cauldron ?


Cauldron a playonlinux 4.2.5 contre 4.2.2 dans Mageia 4, mais je pense que la différence de comportement vient plutôt des versions différentes de pulseaudio.



Co-responsable de l'équipe de packaging de Mageia (dev).
Packaging (voir mes paquets) et assurance qualité (QA).
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie