Connexion

Forum

Logiciels » Autres logiciels [Réglé] Owncloud et fichier .htaccess

xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 478

Le 24/03/2013 à 18h35
Bonjour,

Je viens d'installer owncloud à partir d'un tar.bz2 du site owncloud.org sur mon serveur pour voir comment ça marche.
J'ai réussi à compiler le client mirall et j'arrive à synchroniser un dossier.
J'ai quand même un problème qui me tracasse assez : quand je suis dans l'onglet "Administration" de owncloud, j'ai le message suivant :

Avertissement de sécurité
Votre dossier data et vos fichiers sont probablement accessibles depuis internet. Le fichier .htaccess fourni par ownCloud ne fonctionne pas. Nous vous recommandons vivement de configurer votre serveur web de manière à ce que le dossier data ne soit plus accessible ou bien de déplacer le dossier data en dehors du dossier racine des documents du serveur web.

Dans la doc de owncloud, il y a bien cela qui est indiqué :

Enable .htaccess and mod_rewrite if Running Apache
If you are running the apache webserver, it is recommended that you enable .htaccess files as ownCloud uses them to enhance security and allows you to use webfinger. To enable .htaccess files you need to ensure that AllowOverride is set to All in the Directory /var/www/ section of your virtual host file. This is usually in /etc/apache2/sites-enabled/000-default. You should also run a2enmod rewrite and a2enmod headers. Then restart apache: service apache2 restart (for Ubuntu systems). In order for the maximum upload size to be configurable, the .htaccess file in the ownCloud folder needs to be made writable by the server.

Pour moi, c'est un peu du chinois.

Quelqu'un pourrait-il m'aider à faire en sorte que le fichier .htaccess fasse son travail.

Merci.

Xuo.
   
Adrien.D Membre non connecté

Rang

Avatar

Webmaster Admin système

Inscrit le : 30/05/2011 à 18h36

Localisation : Dijon-21-FRA

Messages: 10322

Le 24/03/2013 à 19h33
Hello,



changer à la ligne 470 du fichier /etc/httpd/conf/httpd.conf :



Code :
    AllowOverride None




par



Code HTML :
    AllowOverride all




Caché :
<Directory "/var/www/html">



# Possible values for the Options directive are "None", "All",

# or any combination of:

# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews

# Note that "MultiViews" must be named *explicitly* --- "Options All"

# doesn't give it to you.

# The Options directive is both complicated and important. Please see

# http://httpd.apache.org/docs-2.0/mod/core.html#options

# for more information.



Options -Indexes FollowSymLinks MultiViews



#

# AllowOverride controls what directives may be placed in .htaccess files.

# It can be "All", "None", or any combination of the keywords:

# Options FileInfo AuthConfig Limit Indexes



AllowOverride None



# Controls who can get stuff from this server.

Order allow,deny

Allow from all



</Directory>





Pour cela :



Code BASH :
 nano /etc/httpd/conf/httpd.conf


Puis Ctrl+_ et taper dans le champ 470, tu arriveras sur la bonne ligne.



Relancer apache avec



Code BASH :
/etc/init.d/httpd restart




Merci



:merci:


Config : PC Fixe : X470 GAMING PRO- AMD Ryzen 5 2600X - 16Go RAM - Radeon RX 560 (Pilote libre) - user_bar_calculate - GNOME Desktop - Kernel 4.19 LTS
Vice président de l'association COAGUL ("Côte-d’Or - Association Générale des Utilisateurs de Logiciels libres")
Webmaster de MageiaLinuxOnline uniquement. Pas de support de ma part.
Site web    
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 478

Le 26/03/2013 à 19h30
Bonsoir,

Désolé pour la réponse tardive. Je n'avais pas reçu de message comme quoi quelqu'un m'avait répondu.
En tout cas, merci, car la manip marche bien.

Xuo.
   
Adrien.D Membre non connecté

Rang

Avatar

Webmaster Admin système

Inscrit le : 30/05/2011 à 18h36

Localisation : Dijon-21-FRA

Messages: 10322

Le 26/03/2013 à 19h44
De rien.

Si sujet résolu :



Config : PC Fixe : X470 GAMING PRO- AMD Ryzen 5 2600X - 16Go RAM - Radeon RX 560 (Pilote libre) - user_bar_calculate - GNOME Desktop - Kernel 4.19 LTS
Vice président de l'association COAGUL ("Côte-d’Or - Association Générale des Utilisateurs de Logiciels libres")
Webmaster de MageiaLinuxOnline uniquement. Pas de support de ma part.
Site web    
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 478

Le 22/05/2013 à 21h24
Bonsoir,

Je réactive ce post car je suis passé sous Mageia 3 et cette manip semble ne plus marcher. Quelqu'un peut-il m'aider ?

Merci.

Xuo.
   
xuo Membre non connecté

Rang

Avatar

Inscrit le : 23/10/2011 à 18h17

Localisation : Bouc-Bel-Air

Messages: 478

Le 23/05/2013 à 04h50
Bonjour matinal,

J'ai dit une bêtise. Je n'avais pas modifié correctement le fichier. Il faut le faire ...

Xuo.
   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie